SiSoftware Sandra Help

Welcome to SiSoftware Sandra, a benchmarking, information and diagnostic utility.

Foreword
  • Introduction
  • The Sandra Program Interface
  • Module List
  • Tips (Performance) List
  • Command-Line Options
  • Copyright, Trademarks & Licence
  • Technical Support and Points of Contact
  • List of Acronyms

Ordering information

  • Get more! (Upgrade)

Documents

  • Program Information
  • What's New
  • Program Requirements
  • Compatibility Issues
  • Questions and Answers (FAQ)
  • License Details
  • Update Sandra
  • Developer information


Foreword

There are tens of million PC Compatibles world-wide, all due to the enormous popularity of the standard IBM PC. All these are supposed to be 100% compatible to the real thing. However, nowadays, as IBM is no longer sets the standard, there is no such thing as a true IBM compatible; this term might mean, today, the most popular specification, i.e. a certain processor, graphics card, sound card, printer, etc. which is widely used - therefore supported by most software. A true PC compatible might mean the one (if available) that the software companies use (e.g. Microsoft) - if it works on theirs it should work on yours, too.

Now Windows! Windows has brought us the key to all this - your program is supposed to work on every machine if you stick to the operating system calls (API). (Other operating systems like Windows NT, OS/2, UNIX, Linux, etc. all do much the same thing or have done long before Windows; I will stick to Windows as Sandra is targeted at this operating system) In a way this is true, most programs now work on systems under Windows that they would not have under DOS.

As far as Sandra is concerned, the situation has not become that much better... Yes, it is easier to detect the characteristics of the system components (if the respective drivers are installed) but not always - the drivers have bugs themselves and sometimes lie for whatever reason. There are still holes in Windows, in the way that you still have to do much of the detection yourself. Worse, Windows is far cleverer than DOS and you can't get away with the things that some DOS programs do. In Windows 9X/Me still need DOS for many things, it gets a bit complicating to juggle virtual & protected mode, ring 0 & ring 3, VxDs & callgates and all other things. In Windows NT/2000/XP/2003 there are other problems… Then we have Windows CE…

Anyway, we’ll find out soon enough what the future holds in store...

Have fun with SiSoftware Sandra and we hope it will be useful to you. We also hope that it will help you learn more about your computer and so make you more aware of what’s going on as well as improving your productivity. In any case don’t lose too much sleep over it...


Introduction

SiSoftware Sandra is a 32 and 64-bit Windows system analyser that includes benchmarking, testing and listing modules. It tries to go beyond other utilities to show you more of what is really going on under the hood so you draw comparisons at both a high and low-level in a single product.

You can get information about the CPU, chipset, video adapter, ports, printers, sound card, memory, network, Windows internals, AGP, ODBC Connections, USB2, Firewire etc.

You can save/print/fax/e-mail/post/upload or insert into ADO/ODBC databases reports in text, HTML, XML, SMS/DMI or RPT format.

This version supports multiple sources of information gathering including: remote computers, PDAs, Smart Phones, ADO/ODBC databases or saved system reports.

All benchmarks are optimised for both SMP & SMT (Hyper-Threading), up to 32/64 CPUs depending on the platform.

Click here for more information.


The Sandra Program Interface

This picture is similar to what you should see when you run Sandra:

As you can see, SiSoftware Sandra looks and behaves like any other Windows application - nothing special.


Module List

The modules in SiSoftware Sandra are divided into the following classes:

Tools | Analyse, monitor, rate or test your computer and its individual components.
Benchmarks | Rate the performance of your computer and its individual components.
Hardware (Information) | Get detailed information about all the components of your computer.
Software (Information) | Explore installed applications, processes, modules, services and other software components.
Testing | Test your computer's components.
Get more! | Get more by upgrading to the commercial versions of Sandra.

For more information, see:

  • Tips (Performance) List
  • Report File Formats


List of Performance Tips

The best way to get more information about a specific tip, either double-click on it or press Enter/Return while the tip is selected in any of the dialogs. A pop-up help window with more information on the tip will be shown.

Related Topics

For more information, please see the (FAQ).


Command Line Options

SiSoftware Sandra supports a variety of command line options:

  • Analysis and Advice in batch mode

    Syntax: sandra.exe /r <full path to analysis script>

    Script: Use the Save the settings in a script file for later use to save your choices in a script you can use later. You can also load settings from a script.

    Example Script: Load the example script Analysis Script.sis from the \Examples folder.

  • Burn-in Computer in batch mode

    Syntax: sandra.exe /r <full path to burn-in script>

    Script: Use the Save the settings in a script file for later use to save your choices in a script you can use later. You can also load settings from a script.

    Example Script: Load the example script Burn Script.sis from the \Examples folder.

  • Create Report in batch mode

    Syntax: sandra.exe /r <full path to report script>

    Script: Use the Save the settings in a script file for later use to save your choices in a script you can use later. You can also load settings from a script.

    Example Script: Load the example script Report Script.sis from the \Examples folder.

  • Environment Monitor in batch mode

    Syntax: sandra.exe /r <full path to monitor script>

    Script: Use the Save the settings in a script file for later use to save your choices in a script you can use later. You can also load settings from a script.

    Example Script: Load the example script Monitor Script.sis from the \Examples folder.

Note: You can also run a script by just double-clicking on it. To edit, open it in Notepad or your favourite text editor.


Copyright, Trademarks & License Information

WARNING: This is a very, very short extract of the full license & copyright document and is featured for information only. Please consult the License Details topic for full information.

SiSoftware Sandra™ is Copyrighted © SiSoftware™ 1995-2007.

ALL RIGHTS RESERVED.

The "Software" means all the files and associated files that come with the original package which were created by the Author. All the other files are used under authorisation and are the propriety of their respective owners. The "Author" is the copyright holder of the Software.

The Software is protected by copyright laws and international treaties. The Author is the exclusive world-wide licenser of the Software, and the copyrights and other proprietary rights there in.

SiSoftware™, SiSoftware Sandra™, SiSoftware SAW™, the SiSoftware logo and the Sandra logo ( [image] blue diamond with while 'i' in it) are trademarks of Catalin-Adrian Silasi c/o SiSoftware and may be registered in certain countries or in the process of being registered. All Rights Reserved. Do not use without authorisation.

All other trademarks acknowledged. E. & O. E.


Technical Support & Points of Contact

You can contact SiSoftware at the addresses below:

 | UK | EU | US
Mail Address | SiSoftware PO Box 17273 London SW5 0HB United Kingdom | As UK | Coming soon
Product E-Mail | Sandra Tech Support | Sandra Tech Support | Sandra Tech Support
User E-Mail | PostMaster WebMaster | PostMaster WebMaster | PostMaster WebMaster
Product Pages | Sandra | Sandra | Sandra

Very Important Notes:

  • The subject of the e-mail message should begin with the program name, i.e. Sandra followed by the type (Lite, Advanced, Professional, Enterprise, etc.) and version (see Help-About), e.g. Sandra Professional Version 2007.X.0.0 : Program Errors. E-mail is sometimes re-routed via different accounts and it may get lost otherwise...
  • We reply to almost all e-mail submissions and inquiries. If you do not receive a reply within a reasonable time, send your message again, giving a better return path (a surprising number of mailers do not insert a correct From: address!)
  • Please include a report (use the Create Report to save one to disk or e-mail it) when you have a hardware problem! Otherwise we cannot help. Also, it will help us improve the program and fix any problems. Very important!
  • Please write in English. Use the alternate addresses for support in other languages.
Open Contact Information document on the Internet [image].


Ordering/Upgrading Information Document

This document is the most important of them all! It tells you how to upgrade to the commercial versions of Sandra, upgrade to a newer version or order more copies!

NB: As the Help file is shared by all versions, you may already be running a commercial version of Sandra; in that case, Thank You for your purchase!

Home Users: open the Order document on the Internet [image].
Business Users: open the Order document on the Internet [image].


Acknowledgements

We’d like to thank our strategic partners:

    • AVIR
    • Jagged Online

We’d like to thank our technology partners:

    • Advanced Micro Devices (AMD/ATI)
    • Intel
    • M-Systems
    • SiS
    • VIA Tech

We’d like to thank the following technology providers:

    • InnoSetup
    • Vix / Votive

We’d like to thank the following sites:

    • 3D Velocity
    • Benchmark HQ
    • Blue Hardware
    • c|net Download.com
    • Deviant PC
    • Extreme Overclocking
    • Gruntville
    • Guru of 3D
    • Manuels d'Aide en français
    • My World Hardware
    • OC Tools
    • OCAddiction
    • OCIA - OverClock Intelligence Agency
    • OcPrices
    • Overclocked Cafe
    • Overclockers (Australia)
    • Overclockers Club
    • Overclockers Shootout
    • PC Extreme
    • PC Hardware (UK)
    • Phlux
    • Tech PC
    • Tech Seekers
    • Tweak Town

We’d like to thank the following people for help (in alphabetical order):

Adam Honek

Alexander van Kaam

Andreas Goettl

Andrew Thomas

Andy Lee

Armand Hirt

Arne Westin

Azman Sahari

Benjamin Brooks III

Birgir ‘Iceman’ Gudjonsson

Bubba Wolford

Chris Pittman

Clarice Simmons

Colin Hoare

Craig Hart

Dan Bennis

Dark Druid

David Altavilla

David Marsiglia

David Ross

Derek Ryba

Dirk van den Berghe

Duane Davis

Edward J. Nethercott

Elie Ayache

Francis Devereux

Fred Dunlap

Galen S. M. Chai

James Campbell

Jane Xia

Jens Scheibel

Jim ‘Justifier’ Miller

Jim Miller

Jim Nucci

Johannes Friederich

John Gatt

John McCrae

John Stephens

Jonathan The

Jordan Russel

Kai Schmerer

Keith ‘Mortin’ Whitsitt

Ken Schutt

Kim Roney

Kirk Johnson

Kyle Benett

Laszlo Molnar

Li Shi

Marco Chiappetta

Markus F.X.J. Oberhumer

Mark Bedingford

Mark Daly

Mark Gaffney

Martin ‘Major’ Jorgensen

Martin Malik

Mats Petersson

Matt Dunford

Mattias Pettersson

Meikel Weber

Micah Schmidt

Michael Herf

Michael Knutson

Michael Schuette

Mike Wall

Mike Warner

Min-Han Lee

Mircea Cioata

Nancy Salani

Nicolas Thibieroz

Nigel A. Dight

Patrick Evans

Paul Hsieh

Paul Kinnaly

Peter Baekgaard Madsen

Peter Hubinsky

Ralf Schafer

Richard Brown

Robert White

Ronen Zohar

Roy Russo

Sander Sassen

Sandy Chen

Serge-Yvan Parel

Shane Dennison

Shervin Kheradpir

Simon Cole

Srinivas Chennupaty

Steve Nutt

Steve Winburn

Steven C Schult

Tara Kalavade

Theresa Chen

Tom Ellis

Van Smith

Vince Freeman

Vincent Valmond

Viorica Silasi

Vlado

Ylona Brooks

Yohai Merzel

NB. If anyone that has helped does not see his or her name here, please forgive us and let us know – we will add it as soon as possible.


Hardware & Software Compatibility Document

The list of hardware and software SiSoftware Sandra has been tested with and works with no problems.

Open Compatibility on the Internet [image].


Licence Information Document

Open the End-User Licence document on the Internet [image].

Open Distribution Licence document on the Internet [image].


Questions & Answers

Questions & Answers (FAQ)

The answer to most questions, bugs listings & fixes, etc.

Open Questions & Answers (FAQ) on the Internet [image].


List of acronyms

3DNow! | Multi-Media Extensions (AMD)
AC | Alternating Current
ACPI | Advanced Configuration and Power Interface
ACR | Advanced Communications Riser
AE | Applications Engineer
AFS | Andrew File System
AGP | Accelerated Graphics Port
AI | Artificial Intelligence
ALU | Arithmetic-Logic Unit
AM | Amplitude Modulated
AMD | Advanced Micro Devices, Inc.
AMD | Air Moving Device (aka fan)
AMI | American Megatrends Inc.
AMR | Audio Modem Riser
ANSI | American National Standards Institute
APIC | Advanced Programmable Interrupt Controller
APM | Advanced Power Management
ASCII | American Standard Code for Information Interchange
ASIC | Application Specific Integrated Circuit
ASPI | Advanced SCSI Programming Interface
AT | Advanced Technology
ATA | AT bus Attachment
ATAPI | ATA Packet Interface
ATDM | Asynchronous Time Division Multiplexing
ATM | Asynchronous Transfer Mode
ATX | AT eXtended
AUI | Attached Unit Interface
BBS | Bulletin Board System
BCC | Block Check Character
BCD | Binary Coded Decimal
BE | Back End
BEDO | Burst EDO
BiCMOS | Bipolar Complementary Metal-Oxide Semiconductor
BIOS | Basic Input / Output System
BMB | Baseboard Management Bus
BNC | Bayonet Nut Connector
BPS/bps | Bytes/bits Per Second
BSC | Binary Synchronous Communications
BSD | Berkeley Standard Distribution
BT | Base Transmit
BTU | British Thermal Units
CAD | Computer Aided Design
CAM | Computer Aided Manufacturing
CAM | Content Addressable Memory
CAM | Common Access Method
CAS | Column Address Strobe
CBX | Common Branch eXtender
CCD | Charge Coupled Device
CCITT | Consultative Committee of International Telephony and Telegraphy
CD | Carrier Detect
CDDI | Copper Distributed Data Interface
CDROM | Compact Disk Read Only Memory
CGA | Colour Graphics Adapter
CHS | Cylinder Head Sector
CISC | Complex Instruction-Set Computer
CLA | Carry Look-ahead Adder
CMOS | Complementary Metal-Oxide Semiconductor
CNR | Communications and Network Riser
CODEC |
CP/M | Control Program / Monitor
CPI | Clocks Per Instruction
CPU | Central Processing Unit
CQFP | Ceramic Quad Flat Pack
CR | Carriage Return
CRC | Cyclical Redundancy Check
CRIMM | Continuity RIMM
CRQ | Command Response Queue
CRT | Cathode Ray Tube
CS | Chip Select
CSMA/CD | Carrier Sense Multiple-Access /with Collision Detect
CSR | Command Status Register
CST | Container Security Breach (aka door open)
CTS | Clear To Send
DAT | Digital Audio Tape
DBI | Dynamic Bus Inversion
DC | Direct Current
DCD | Data Carrier Detect
DCE | Data Circuit-terminating Equipment
DD | Double Density
DDC | Display Data Channel
DDR | Double Data Rate
DEC | Digital Equipment Corporation
DES | Data Encryption Standard
DHCP | Dynamic Host Configuration Protocol
DID | Direct Inward Dial
DIMM | Dual Inline Memory Module
DIN | Deutsche Industrie Norm (German)
DIP | Dual-In-line Package
DIS | Draft International Standard
DMA | Direct Memory Access
DMI | Desktop Management Interface
DOS | Disk Operating System
DP | Dual Processor
DPE | Data Parity Error
DPSK | Differential Phase Shift Keying
DRAM | Dynamic Random Access Memory
DRDOS | Digital Research Disk Operating System
DRM | Dual Retention Mechanism
DS | Double Sided
DSP | Digital Signal Processor
DSR | Data Set Ready
DTC | Data Terminal Controller
DTE | Data Terminating Equipment
DTMF | Dual-Tone Multi-Frequency
DTR | Data Terminal Ready
DVD | Digital Video/Versatile Device/Disk
EBCDIC | Extended Binary Coded Decimal Interchange Code
EC | Error Check
ECC | Error Check and Correction
ECL | Emitter-Coupled Logic
ECO | Engineering Change Order
ECP | Enhanced Communication Port
ECP | Extended Capabilities Port
ECU | EISA Configuration Utility
EDO | Extended Data Out RAM
EDPT | Enhanced Disk Parameter Table
EEPROM | Electrically Erasable Programmable Read Only Memory
EFI | Extensible Firmware Hub
EGA | Enhanced Graphics Adapter
EIA | Electronic Industries Association
EIDE | Enhanced Integrated Device Electronics
EISA | Enhanced Industry Standard Architecture
EMC | Electro-Magnetic Compatibility
EMF | Electro-Magnetic Force
EMI | Electro-Magnetic Interference
EMS | Expanded Memory Specification
EOF | End Of File
EOL | End Of Line
EOS | Electrical Over Stress
EPP | Enhanced Parallel Port
EPROM | Erasable Programmable Read Only Memory
ESCD | Extended System Configuration Data
ESD | Electro-Static Discharge
ESDI | Enhanced Small Devices Interface
FAT | File Allocation Table
FCC | Federal Communications Commission
FDD | Fixed / Floppy Disk Drive
FDDI | Fiber Distributed Data Interface
FDM | Frequency Division Multiplexing
FDX | Full-Duplex Transmission
FE | Front End
FEP | Front End Processor
FF | Form Feed
FIFO | First-In First-Out
FILO | First-In Last-Out
FM | Frequency Modulation
FPGA | Field Programmable Gate Array
FPM | Fast Page Mode RAM
FPU | Floating Point Unit
FRC | Functional Redundancy Checking
FRU | Field-Replaceable Unit
FSB | Front Side Bus
FSF | Free Software Foundation
FSK | Frequency Shifty Keying
FTP | File Transfer Program
FWH | Firmware Hub
GAS | Gallium Arsenide
GFLOPS | Billions of FLOating Point Operations Per Second (GigaFlops)
GNU | Gnu's Not UNIX
GUI | Graphical User Interface
GXB | Graphic eXpansion Bridge
HBA | Host Bus Adapter
HD | High Density / Hard Disk
HDD | Hard Disk Drive
HDX | Half-Duplex Transmission
HFS | Hierarchical File System
HPFS | High Performance File System
HS | Helical Scan
I/O | Input / Output
I2C | Intelligent Controller
IA | Intel Architecture
IB | In-Bound
IBM | International Business Machines Corporation
IC | Integrated Circuit
ICMP | Internet Control Message Protocol
IDC | Insulation Displacement Connector
IDE | Integrated Device Electronics
IEEE | Institute of Electrical and Electronic Engineers
IFB | I/O and Firmware Bridge
IMP | Interface Message Processor
IOAPIC | Input Output Advanced PIC
IPC | Inter Process Communication
IPX | Inter network Packet eXchange
IR | Infra-Red
IRQ | Interrupt ReQuest
ISA | Industry Standard Architecture
ISDN | Integrated Services Digital Network
ISO | International Standards Organisation
ITP | In-Target Probe
JFS | Journalised File System
kVA | KiloVolt-Amps
LAN | Local Area Network
LBA | Linear Block Array / Addressing
LCD | Liquid Crystal Display
LED | Light Emitting Diode
LF | Line Feed
LIM | Lotus/Intel/Microsoft's Expanded Memory Manager (EMS)
LRU | Least-Recently Used
LSB/lsb | Least Significant Byte/bit
LSI | Large Scale Integration
LVD | Low Voltage Differential
LUN | Logical Unit Number
MAN | Metropolitan Area Network
MB/Mb | Mega Bytes/bits
MBR | Master Boot Record
MCA | Micro Channel Architecture
MCGA | Multi-Colour Graphics Array
MCH | Memory Controller Hub
MCM | Multi-Chip Module
MDC | Memory Data Component
MDRAM | Multi-bank RAM
MEC | Memory Expansion Cards
MFLOPS | Millions of FLOating Point Operations per Second (MegaFlops)
MFM | Modified Frequency Modulated
MHz | MegaHertz
MICR | Magnetic Ink Character Recognition
MIDI | Musical Instrument Data Interface
MIMD | Multiple-Instruction Multiple-Data
MIPS | Millions of Instructions per Second
MISD | Multiple-Instruction Single Data
MMU | Memory Management Unit
MMX | Multi-Media Extensions
MNP | Microcom Network Protocol
MODEM | MOdulator / DEModulator
MOPS | Millions of Operations Per Second
MOS | Metal-Oxide Semiconductor
MP | Multi-Processor
MPP | Massively Parallel Processor
MPS | Multi-Processor System
MPT | Memory Protocol Translator
MSB/msb | Most Significant Byte/bit
MSDOS | Microsoft's Disk Operating System
MSI | Medium Scale Integration
MTBF | Mean Time Between Failure
MTH | Memory Translator Hub
N/C | No-Connect
NBS | National Bureau of Standards
NEMA | National Electrical Manufacturers Association
NFS | Network File System
NFU | Not-Frequently Used
NIC | Network Interface Card
NMI | Non-Maskable Interrupt
NMOS | Negatively doped Metal-Oxide Semiconductor
NOP | No OPeration
NRU | Not-Recently Used
NSF | National Science Foundation
NVRAM | NonVolatile Random Access Memory
OAP | Outside Awareness Panel (aka window)
OB | OutBound
OCR | Optical Character Recognition
ODI | Open Datalink Interface
OEM | Original Equipment Manufacturer
OS | Operating System
OSF | Open Software Foundation
OSI | Open Systems Interconnect
PAC | PCI AGP Controller
PAL/PLA | Programmable Array Logic / Logic Array
PAL | Processor Abstraction Layer
PB | Push Button
PBX | Private Branch eXtender
PC | Personal Computer, Program Counter
PCB | Printed Circuit Board
PCI | Peripheral Component Interconnect
PCM | Pulse Code Modulation
PCMCIA | Personal Computer Memory Card International Association
PE | Processor Element
PFC | Power Factor Correction
PFF | Page Fault Frequency
PGA | Professional Graphics Array
PGA | Pin Grid Array
PIC | Programmable Interrupt Controller
PIO | Programmed Input / Output
PIROM | Processor Information ROM
PLCC | Plastic Leaded Chip Carrier
PLL | Phase Locked Loop
PM | Preventive Maintenance
PME | Power Management Event
PMOS | Positively doped Metal-Oxide Semiconductor
PnP | Plug-and-Play
POST | Power On Self Test
PPP | Point-to-Point Protocol
PQFP | Plastic Quad Flat Pack
PROM | Programmable Read Only Memory
PSIPC | PCI Super I/O Integrated Peripheral Controller
PSTN | Public Switched Telephone Network
PTE | Page Table Entry
PXB | PCI eXpansion Bridge
PXE | Pre-Boot eXecution Environment
QAM | Quadrature Amplitude Modulation
QFP | Quad Flat Pack
QIC | Quarter Inch Cartridge
RAID | Redundant Arrays of Inexpensive Disks
RAM | Random Access Memory
RAMDAC | Random Access Memory Digital to Analogue Converter
RAS | Row Address Strobe
RCA | Radio Corporation of America
RCC | Routing Control Centre
RDRAM | Rambus DRAM
RFC | Request For Comments
RFI | Radio Frequency Interference
RI | Ring Indicator
RIMM | Rambus Inline Memory Module
RISC | Reduced Instruction-Set Computer
RLL | Run Length Limited
RMS | Root Mean Squared
RMW | Read Modify Write
ROM | Read Only Memory
RPC | Remote Procedure Call
RPM | Rotations Per Minute
RTC | Real Time Clock
RTS | Request To Send
SAL | System Abstraction Layer
SAM | Sequential Access Memory
SASI | Shugart Associates Standard Interface
SCI | Special Circumstance Instructions
SCSI | Small Computer Systems Interface
SD | Single Density
SDLC | Synchronous Data Link Control
SDRAM | Synchronous Dynamic RAM
SDRAM BDDR II | Bi-Directional Strobed DDR SDRAM
SDRAM DDR II | Double Data Rate SDRAM
SE | Systems Engineer
SEC | Single Edge Contact
SECC | Single Edge Contact Cartridge
SFF | Small Form Factor
SGRAM | Synchronous Graphics RAM
SIMD | Single-Instruction Multiple-Data
SIMM | Single Inline Memory Module
SIPP | Single Inline Pinned Package
SISD | Single-Instruction Single-Data
SLIP | Serial Line Internet Protocol
SMBUS | System Management Bus
SMD | Surface Mount Device
SMI | System Management Interrupt
SMP | Symmetric Multi-Processing
SMT | Surface Mount Technology
SMT | Symmetric Multi-Threading
SNA | System Network Architecture
SNR | Signal to Noise Ratio
SO/SOL | Small Out Line
SOIC | Small Outline Integrated Circuit
SPDIF | Serial Data Interface
SPOOL | Simultaneous Peripheral Operation On Line
SPT | Sectors Per Track
SPU | Single Processor Unit
SRAM | Static Random Access Memory
SS | Single Sided
SSE | Streaming SIMD Extensions
SSE2 | Streaming SIMD Extensions 2
STDM | Synchronous Time Division Multiplexing
STN | Super Twisted Nematic
STR | Suspend To RAM
STU | Streaming Tape Unit
SVGA | Super Video Graphics Array
TCM | Trellis Code Modulation
TCP/IP | Transmission Control Protocol / Internet Protocol
TDM | Time Division Multiplexing
TI | Texas Instruments
TIA | Telecomm. Industry Association
TLB | Translation-Lookaside Buffer
TPI | Tracks Per Inch
TRANSISTOR | TRANSformer resISTOR
TSR | Terminate and Stay Resident
TTL | Transistor-Transistor Logic
TUV | Technischer Ueberwachuags Verein (German)
UAE | Unrecoverable Application Error
UART | Universal Asynchronous Receiver/Transmitter
UDP | User Datagram Protocol
UMB | Upper Memory Block
UPS | Un-interruptible Power Supply
USB | Universal Serial Bus
USL | UNIX System Labs
UUCP | UNIX to UNIX Copy Program
VBE | Video BIOS Extensions
VCR | Video Cassette Recorder
VESA | Video Enhanced Standards Association
VGA | Video Graphics Array
VID | Voltage ID
VLB | VESA Local Bus
VLIW | Very Long Instruction Word
VLSI | Very Large Scale Integration
VM | Virtual Memory
VME | Versa Module Euro-card
VRAM | Video Random Access Memory
VRT | Voltage Reduction Technology
VTR | Video Tape Recorder
WAN | Wide Area Network
WATS | Wide Area Telephone Service
WD | Western Digital
WOL | Wake-up On LAN
WORM | Write Once - Read-Many
WRAM | Window Random Access Memory
WS | Wait State
WXB | Wide eXpansion Bridge
XGA | eXtended Graphics Array
XMS | Extended Memory Specification
XOR | Exclusive-OR
XT | eXtended Technology
ZIF | Zero Insertion Force

Note: Some of these acronyms are explained elsewhere...


About SiSoftware Sandra

Displays program information, version and copyright details. See the License Details topic for more information.


Arrange modules by description

Arranges modules by their description.


Arrange modules by name

Arranges modules by name.


Show in Groups

Arrange icons in groups depending on their type.


The Title Bar

Title Bar

The title bar is located along the top of a window. It contains the name of the application and document.

To move the window, drag the title bar.

Note: You can also move dialog boxes by dragging their title bars.


Back Step

Returns to the previous step in a wizard or return to the previous module.

Shortcut

Keys: CTRL+B


Clear All

Unselects all the choices (modules/options/etc.) as appropriate.

Shortcut

Keys: CTRL+C


(Untitled)

Close command

Use this command to close the active window or dialog box.

Double-clicking a Control-menu box is the same as choosing the Close command.

Note: If you have multiple windows open for a single document, the Close command on the document Control menu closes only one window at a time. You can close all windows at once with the Close command on the File menu.

Shortcut

Keys: CTRL+F4 closes a document window

ALT+F4 closes the application window or dialog box


Connect to Source

This wizard helps you select the data source to connect to and initialises all the active modules. You can connect to:

  • Your local computer
  • A remote computer (subject to credentials)
  • A device: PDA, Smartphone, etc. (device must be connected to your computer)
  • A database of Sandra reports (subject to credentials)
  • A report document

To automatically connect at start-up to the last data source (i.e. when you run the Sandra client) check the provided checkbox. This is especially useful when connecting to the local computer.

Things to remember:

  • To connect to another data source, you must disconnect first. Then click on the connect button!
  • You can only connect to a single data source at any one time (except when using the Enterprise client). You can run multiple copies of the Sandra client that connect to different data sources.

Shortcut

Keys: CTRL+C


Copy Data to Clipboard

Copy the displayed data to the clipboard. The data is copied in text format, equivalent to the format in the report.

Shortcut

Keys: CTRL+C


Enable 3D Shading

Sandra contains a variety of custom controls, all of which are 3D shaded. The controls automatically change their features (3D, shading, anti-aliasing, colour depth, etc.) based on your system's capabilities, theme selected and video mode.

However, you may choose to disable certain features like 3D and shading to improve readability on some screens or increase display performance especially via terminal services and VPN.


Customise Colours

Here you can customise the colours of the data items of charts, bars, etc. displayed. You can use the colour picker to select any colour for any of the available items to the ones you prefer or the ones that match best to the theme you have loaded.

Note: Changing the theme will reset the colours to the theme default.


Customise Control Styles

Sandra contains a variety of custom controls that may support a variety of styles. Here you can choose which style you prefer or the one that matches best to the theme you have loaded.


Delete Module(s)

Delete/remove the selected module(s). This operation will remove the selected module(s) from the display list and will unload them from memory. Note that you cannot delete the wizard modules.

To add the module(s) back, use the Add New Module.

Shortcut

Keys: Del


Disconnect

Closes down all modules and disconnects from the current source.

Shortcut

Keys: CTRL+D


Close Application

Closes down Sandra. It also disconnects all connections if any.

Shortcut

Keys: Alt+F4


Import/Export Benchmark Results

Here you can export the benchmark results you have just gathered as well as the currently selected reference results to a file. You can share this file with someone else which they can import into their Sandra installation or import it into another program.

If you are importing into another program, check with that program as to which format (Comma-spaced values (CSV), Tab delimited text (TAB), XML, etc.) is best to create.

  • Exporting: To save the results internally, use the Save Benchmark Results command rather than this one. To create a report with a full set of results and data, use Create Report wizard rather than this one.
  • Importing: To bulk load results from another Sandra database, use the Import Database command rather than one.


Manage Benchmark Results

Here you can rename (in place) or delete the benchmark results in the results database.

Then you can compare the results of this run with previous or future runs (useful when changing settings or upgrading) or keep a log of results.

Use the Delete and Rename buttons in the toolbar and click OK to commit the changes or Cancel to discard the changes.


System Maximize Command

Maximise command

Use this command to enlarge the active window to fill the available space.

Shortcut

Mouse: Click the maximize icon on the title bar; or double-click the title bar.

Keys: CTRL+F10


System Minimize Command

Minimise command

Use this command to reduce the application window to an icon.

Shortcut

Mouse: Click the minimize icon on the title bar.

Keys: ALT+F9


Change Module Options

This wizard allows you to:

  • Select the tests the module runs. This is useful if some tests lock the computer or you don’t require them.
  • Adjust the amount of information to your specific requirements. Some information may not be needed or may be too large for some reports.
  • Check or uncheck the checkboxes next to the option you want to select/de-select.
  • Options are saved for later use.

While the options come into effect immediately, you may need to click the Update button to refresh the module’s information.

Shortcut

Keys: CTRL+O


System Move Command

Move command

Use this command to display a four-headed arrow so you can move the active window or dialog box with the arrow keys.

Note: This command is unavailable if you maximize the window.

Shortcut

Keys: CTRL+F7


Next Step

Continue with the next step in a wizard or continue to the next module.

Shortcut

Keys: CTRL+N


(Untitled)

No Help Available

No help is available for this area of the window.


Open Module

Loads (runs/executes/activates/updates) the selected module.

Shortcut

Keys: Enter


Set Program Options

Allows you to set program (global) options. When you set this options you set the respective option for all the modules that support that option.


Refresh

Refreshes the module list.


(Untitled)

Restore command

Use this command to return the active window to its size and position before you chose the Maximize or Minimize command.


Run as Administrator

Note: This topic is relevant only to Windows Vista*, Longhorn* and future operating systems that implement UAC (User Access Control).

The Sandra management console itself does not need to run with Administrator/System priviledges, unlike the Sandra services. Thus it does not request special priviledges.

However, if you later need to issue commands (either local or remote) that require administrator priviledges, you will need to re-start Sandra with administrator priviledges. UAC will then prompt you to allow such elevation or (if your account does not have administrator credentials) prompt you for administrative credentials to continue.


Save Benchmark Results

Here you can name the benchmark results you have just obtained or you can just accept the default name generated by the program (system name - date - time). Make sure you choose a descriptive name so you can quickly and easily refer to the results later.

Use the OK button to save the results in the database or Cancel to discard the results.


Save Benchmark Results

Save the current benchmark results to the user benchmark database. Naturally, this only works for benchmark modules once the benchmark has been performed.

The results are labelled with system name, current date and current time for easy identification. This allows you to see the change in results over time.

If the User System Reference Results are not displayed, the display is switched to this view automatically and the newly saved data selected.

Shortcut

Keys: CTRL+S


Set All

Select all the choices (modules/options/etc.) as appropriate.

Shortcut

Keys: CTRL+A


Service Management

Allows you to view the status of Sandra services, as well as start, re-start or stop them should any issues arise.

Sandra currently contains the following services:

  • Remote Agent Service
  • Database Agent Serivice
  • Deployment Agent Service


System Size Command

Size command

Use this command to display a four-headed arrow so you can size the active window with the arrow keys.

After the pointer changes to the four-headed arrow:

  1. Press one of the DIRECTION keys (left, right, up, or down arrow key) to move the pointer to the border you want to move.
  2. Press a DIRECTION key to move the border.
  3. Press ENTER when the window is the size you want.

Note: This command is unavailable if you maximize the window.

Shortcut

Mouse: Drag the size bars at the corners or edges of the window.


Switch Chart Type

Switch the chart type from the Linear (default) to the more specialised types of charts that are available to the specific module. Select the chart type from the pop-up menu.

Shortcut

Keys: CTRL+G


Switch Modules View

Use this command to switch the type of modules shown in the program window (Home, Tools, Benchmarking, etc.).


Switch View

Use this command to switch the type of icons shown in the program window (Large, Small, Tile, Details).


Switch Benchmark Results

Switch the reference benchmark results from the Reference Results to the User System Reference Results or both. Select the result type from the pop-up menu.

Naturally, this only works for benchmark modules if you have saved the results at least once beforehand.

Shortcut

Keys: CTRL+W


Switch to command

Use this command to display a list of all open applications. Use this Task List to switch to or close an application on the list.

Shortcut

Keys: CTRL+ESC

Dialog Box Options

When you choose the Switch To command, you will be presented with a dialog box with the following options:

Task List

Select the application you want to switch to or close.

Switch To

Makes the selected application active.

End Task

Closes the selected application.

Cancel

Closes the Task List box.

Cascade

Arranges open applications so they overlap and you can see each title bar. This option does not affect applications reduced to icons.

Tile

Arranges open applications into windows that do not overlap. This option does not affect applications reduced to icons.

Arrange Icons

Arranges the icons of all minimized applications across the bottom of the screen.


Theme Management

Here you can load different themes/skins and change the look of Sandra. A list of installed skins is shown from which you can select the one you like best.

Not all versions of Sandra contain themes. We may publish new themes on our website or through the Update service.

Note: To fully apply some themes, Sandra will need to re-start.


Tip of the Day

This window shows a tip of the day.

Click the Next Tip button to see the next tip.

Click the Close button to close the window.

Un-check the Show Tips at Startup checkbox if you don’t want the Tip of the Day window to appear each time you start the program.


Refresh or Update

Refresh / Update

Refresh the information displayed or update it.

For information/listing modules the information is updated. For benchmark modules, the benchmarks are re-run. For testing/diagnostic modules the diagnostics/tests are re-run.

Shortcut

Keys: F5


Show Status Bar

Shows or hides the status bar.


Show Classic Menu

Shows or hides the classic menu.


Database Schema

The schema for the database that Sandra requires is analogous to the XML schema (naturally) and thus requires a relational database. A modern database (Oracle, SQL Server, Access) will do just nicely, however any ODBC/OLE DB/ADO compliant database should work also.

Due to the design of the system, the schema is not complex with few enforced keys, but that makes queries quite hard. Please refer to the examples for example SQL queries; you need to be familiar with the SQL syntax.

Database Creation Schema Scripts

There are script schemas for all tested/supported databases in the \Examples folder:

  • Microsoft Access/Jet - Report Schema.mdb
  • IBM DB2 - IBM DB2 Schema.sql
  • Microsoft SQL Server - SQL Server Schema.sql
  • Oracle - Oracle Schema.sql
  • MySQL - MySQL Schema.sql

Please use them for creating the database/schema.

Tables

TReport - this is the primary table; each module belongs to only one report.

TModule - this groups data by module; each item belongs to only one module.

TClass - this is optional, only for 3rd level modules; each class belongs to only one module.

TDevice - this is optional, only for 2nd and 3rd level modules; each device belongs to either a class or directly to a module.

TItemGroup - this groups items logically, and is used by most modules; each item group belongs to either a class, device or directly to a module.

TItem - this is the data tuple itself and holds the actual data; each item belongs to an item group or directly to a module in special cases.

Relationships

As discussed above there is more than one relationship link depending on module type:

Simple: TReport -> TModule -> TItem

1st Level: TReport -> TModule -> TItemGroup -> TItem

2nd Level: TReport -> TModule -> TDevice -> TItemGroup -> TItem

3rd Level: TReport -> TModule -> TClass -> TDevice -> TItemGroup -> TItem

Generally the keys present in the tuple can determine the type of module:

Simple: GroupID key of TItem table is null.

1st Level: ClassID and DeviceID keys of TItemGroup table are null.

2nd Level: ClassID key of TItemGroup table is null.

3rd Level: Both ClassID and DeviceID keys of TItemGroup table are valid.

There are also a couple of bits that let you determine the type of module:

Simple: as per above.

1st Level: Class & Device bits are not set.

2nd Level: Device bit is set.

3rd Level: Neither bits are set.

Query Tips

Due to the multiple types of relationships, queries that need to return the data for any module may need to use multiple selects, using union statements to merge the results together. Generally this can be avoided if the data from the intermediary tables (i.e. Class, Device, ItemGroup) is not needed, thus go from Module -> Item directly.

For performance reasons, it is recommended to avoid the unions or at least manage to do with non-unique unions. As most queries will select on text columns, make sure you set up indexes on those columns, preferably compound indexes on the specific joins you are using.

SQL Query Examples

See the SQL Example Queries.txt file in the \Examples folder for example SQL queries.


Developers Information

This document provides information for developers: interfacing with Sandra, getting SDKs and other programming information.

Open the Developers Information document on the Internet [image].


Program Information

The latest information about SiSoftware Sandra, and the index of the documentation.

Open Program Information document on the Internet [image].


What's New

The latest information on Sandra and other utilities.

Open Latest News document on the Internet [image].


Program Requirements

Find out what you need to have in order to run SiSoftware Sandra at peak performance and how to get the most out of it.

Open Requirements on the Internet [image].


E1

Error E1: Module execution has failed. The error is in the message.

Fix: The error message should give you some information as to how to diagnose the problem. Each module has different requirements, see the

Related Topics


E3

Error E3: No modules have been selected.

Fix: For this wizard to work you need to select at least one module. Re-start the wizard and select one or more modules.


E4

Error E4: This hardware device has a problem. The problem is in the message itself.

Fix: The error message should give you some pointers as to what has gone wrong. You can also use the Help and Support Windows help for more information about this specific device problem. Use the Troubleshooters to attempt to diagnose the problem.


E5

Error E5 - Connection to PDA / Smart Phone could not be established. Check that the device is in its cradle or connected to the PC and the link is active.

Fix: Make sure that Active Sync (Windows Mobile) / Hot Sync (Palm) have the PDA / Smart Phone device is correctly set-up and connected.


E6

Error E6 - Connection to PDA / Smart Phone has failed. Check that the PDA / Smart Phone is in its cradle or connected to the PC and the link is still active.

Fix: Make sure that Active Sync (Windows Mobile) / Hot Sync (Palm) connection to the PDA / Smart Phone device is still active.


E7

Error E7 - Undocumeted or unknown error. Please contact us.

Fix: Please contact us. (you should never see this)


E8

Error E8 - Interface mismatch between PC and PDA.

Fix: Try uninstalling any and all copies of Sandra and just install the latest version. Otherwise, please contact us. (you should never see this)


E206

Error E206 - Your Pentium CPU has the infamous FPU (co-processor) bug.

Fix: Contact Intel Corp. for a free replacement.


E300

Error E300: Failed to initialise OpenGL.

Fix: Check that the OpenGL drivers are correctly installed. It is possible the OpenGL driver does not support the current video mode, you may need to reduce resolution, colour depth or refresh rate. Try the OpenGL screen-savers to see if they work correctly.


E301

Error E301: Failed to create OpenGL test window.

Fix: The OpenGL driver may not support the current video mode, you may need to reduce resolution, colour depth or refresh rate. Try the OpenGL screen-savers to see if they work correctly. This may also denote a low-memory condition.


E400

Error E400: Failed to open/connect to printer.

Fix: Check that the printer is correctly installed and the printer is on-line. You can try deleting and reinstalling the printer. If it is a network printer make sure the print server is on-line and that your current credentials allow you to connect to and query the printer.


E401

Error E401: Failed to allocate buffer for the printer information.

Fix: Check that the printer is correctly installed and the printer is on-line. You can try deleting and reinstalling the printer. If it is a network printer make sure the print server is on-line and that your current credentials allow you to connect to and query the printer.


E402

Error E402: Cannot get printer information.

Fix: Check that the printer is correctly installed and the printer is on-line. You can try deleting and reinstalling the printer. If it is a network printer make sure the print server is on-line and that your current credentials allow you to connect to and query the printer.


E500

Error E500: Winsock library has failed.

Fix: Check the network adapter configuration, the protocols (i.e. TCP/IP) and bindings. If you have updated it make sure it has been updated correctly.


E501

Error E501: No hosts have been detected on the network.

Fix: If there are other hosts on the specified network (aka domain/workgroup/IP net) make sure that they are operational and visible from Network Neighbourhood. Some hosts require valid credentials to query their presence/information, other are hidden on purpose.


E1000

Error E1000: No game controllers are present.

Fix: If you do have game controllers (joystick, game-pad, etc.) check that they are properly connected to the right port. Some require drivers – make sure the drivers are appropriate for the operating system you are using.


E1001

Error E1001: Failed while querying game controller. The error code is in the message.

Fix: Depending on the error code displayed attempt to resolve the issue. You may need to use the device manual for more information.


E1200

Error E1200: PCI/AGP initialisation failed.

Fix: Check that the program has initialised its device driver successfully; if correctly installed make sure you have administrator permissions that allow device driver registration/execution. Otherwise ask the administrator to set up the driver to load at boot.

On old systems it is possible the PCI interface is not working correctly or it has not been enabled.


E1400

Error E1400: Cannot open port.

Fix: If you are using a device (e.g. modem, direct-cable networking) that currently uses the port this is normal. Otherwise please close as many applications as you can, especially communication programs.


E1500

Error E1500: No MCI devices seem to be present or are responding.

Fix: All systems generally contain some MCI devices (multi-media device control interface). Unless you have explicitly deleted them make sure the registry is valid. Check the MCI panel within Control Panel for more details.


E1600

Error E1600: Cannot find the process, process no longer exists.

Fix: The process may have disappeared between the time the list of processes has been created and the time the process was queried.


E1601

Error E1601: Cannot get the list of processes.

Fix: Generally this denotes a low-memory condition. Alternatively your credentials may not allow you to list processes running although this is unusual.


E1800

Error E1800: Drive access error – not present.

Fix: If the drive is removable make sure there is formatted media into it. If the drive is fixed make sure the drive is on-line – it may be in power-save mode.


E2200

Error E2200: DirectInput error. The error string is included in the message.

Fix: This depends on the error string shown and should give you a good idea as to what has gone wrong.


E2201

Error E2201: DirectPlay error. The error string is included in the message.

Fix: This depends on the error string shown and should give you a good idea as to what has gone wrong.


E2202

Error E2202: Memory allocation for buffer(s) has failed.

Fix: Generally this denotes a low-memory condition. Please close as many of open applications as you can. If this does not help and the system has been running for many days, consider rebooting.


E2203

Error E2203: DirectSound error. The error string is included in the message.

Fix: This depends on the error string shown and should give you a good idea as to what has gone wrong.


E2204

Error E2204: DirectDraw error. The error string is included in the message.

Fix: This depends on the error string shown and should give you a good idea as to what has gone wrong.


E2205

Error E2205: Direct3D error. The error string is included in the message.

Fix: This depends on the error string shown and should give you a good idea as to what has gone wrong.


E2300

Error E2300: Could not detect port of the modem.

Fix: Generally all modems use a port (either physical or virtual) to interface with the system. The only exception are advanced modems (ISDN/DSL) that emulate network adapters – but they should not appear in this category. Check that the drivers are correctly installed and configured.


E2301

Error E2301: Port is in use.

Fix: Generally this is fine as another application is currently using the port. If you are currently connected using the modem then the modem/port are in use and thus cannot be queried. Try again after you disconnect.


E2302

Error E2302: Cannot initialise port data buffers.

Fix: Check that the port is correctly configured in the BIOS and in Windows. You may need to delete the port and allow Windows to re-detect it if you’ve made modifications to its configuration in the BIOS. In a few cases this may also denote a low-memory condition – close some open applications


E2303

Error E2303: Could not set port state and timeouts.

Fix: Check that the port is correctly configured in the BIOS and in Windows. You may need to delete the port and allow Windows to re-detect it if you’ve made modifications to its configuration in the BIOS. Some older ports may not support this functionality.


E2304

Error E2304: Modem/terminal adapter did not reply.

Fix: Check that the modem/terminal adapter is turned on and connected correctly. If has multiple connections, check that there are no active connections. You could reboot it if it still does not reply after these checks.


E2600

Error E2600: SCSI interface query has failed.

Fix: Make sure the ASPI drivers are installed correctly. For Windows NT/2000/XP/2003 you do not need nor should you install any ASPI drivers.


E2601

Error E2601: No SCSI devices found on SCSI channel.

Fix: If there are no SCSI devices installed on the channel this is fine. If there are devices connected, check that they are on-line and correctly configured for the channel.


E2700

Error E2700: Font no longer exists.

Fix: Generally this means that the font enumerated is not actually present in the system. It may not be installed (anymore) even if it is registered. If you have removed the font, the un-registration may still be active until a reboot or it has not been actually executed.


E2701

Error E2701: Could not create device DC to render font.

Fix: Check that there is plenty of free system and video memory; you may need to close other open applications or reboot.


E2900

Error E2900: Cannot enumerate dial-up (RAS) connections.

Fix: Check that there are RAS connections defined and that the database is valid. It is also possible that your credentials do not allow you to enumerate the RAS connections.


E2901

Error E2901: Cannot allocate buffer for RAS connection query data.

Fix: Check that the program supports the operating system you are using. You may have to update the program.


E2902

Error E2902: Failed to query RAS connection.

Fix: Check that the RAS connection defined is valid. It is also possible that your credentials do not allow you to enumerate the RAS connection.


E3000

Error E3000: Could not connect to database server.

Fix: Make sure the database connection settings are correct (check spelling). Check server is on-line and reachable by using the database test utilities supplied. Check that the credentials specified are correct and allow remote connection.


E3001

Error E3001: Functionality not supported (list types, tables, procedures, etc.)

Fix: Make sure the credentials allow you to list/query the specified functionality (e.g. can view tables, procedures, etc.). It is also possible there are no tables, procedures, etc. defined yet. You can double-check by connecting with the database test utilities supplied.


E3100

Error E3100: This hardware device has a problem. The problem is in the message itself.

Fix: The error message should give you some pointers as to what has gone wrong. You can also use the Help and Support Windows help for more information about this specific device problem. Use the Troubleshooters to attempt to diagnose the problem.


E3106

Error E3106 - SMART has detected a possible problem with the drive. It is best to close all programs and back up all the data on the disk. The disk may fail.

Fix: Contact the drive manufacturer’s technical support. Usually they will replace the drive or at least test it and return it if it is a false alarm.


E3200

Error E3200: Failed to open event log.

Fix: Check that the event log is not corrupted and that your credentials allow you to open logs on the system


E5200

Error E5200: Cannot create/write to drive. Check permissions.

Fix: Check that the drive can be written to so that it can be benchmarked.


E5201

Error E5201: Cannot allocate memory data buffer.

Fix: The benchmarks need a lot of resources to run. Please close as many applications as possible to give more memory to the application.


E5202

Error E5202: Not enough free space on the drive. The size is specified in the message.

Fix: The benchmark needs a certain free space to create the test file. Please free as much space as required to benchmark the drive.


E5203

Error E5203: Test file is missing.

Fix: This is an unexpected error message. It may be a problem with the drive or the file system on the drive.


E5204

Error E5204: Read error.

Fix: Run a disk-check on the drive and specify surface scan.


E5205

Error E5205: Seek error.

Fix: Check that the drive is correctly configured by the BIOS.


E5206

Error E5206: Write error.

Fix: Run a disk-check on the drive and specify surface scan.


E5300

Error E5300: The test files on the media are too small. The drive cannot be benchmarked proparly with this media. The size is specified in the message.

Fix: Please use a media with larger files as instructed in the message itself. Consider purchasing the SiSoftware Sandra official test media.

Generally:

  • CD-ROM: 600MB or larger.
  • DVD: 4GB if single layer, 7GB if dual layer.
  • HD DVD: 10GB if single layer, 25GB if dual layer.
  • Blu-ray: 10GB if single layer, 25GB if dual layer.


E5408

Error E5408 - Out of memory or resources, the framework was unable to initialise.

Fix: Try rebooting the system and running the program just after boot.


E5409

Error E5409 - Thread initialisation has failed, the framework was unable to initialise.

Fix: Try rebooting the system and running the program just after boot.


E5600

Error E5600: Cannot get IP address of the host.

Fix: Check that TCP/IP protocol is correctly installed and bound to the network interface. Also check that WINS or DNS servers are available on the network. Check that you can ping the host by name from a command prompt.


E5601

Error E5601: No reply from host.

Fix: Check that the host is on-line and connected to the network. Check that the host is configured to reply to ICMP packets – especially if a firewall is installed on the host.


E5602

Error E5602: Transfer packet too large for host/network.

Fix: Generally this is a driver issue. Modern network cards and driver support fragmentation of ICMP packets but some older devices and drivers do not. If you are using the built-in drivers try installing updated drivers from the manufacturer’s website.


E5700

Error E5700: Cannot initiate Internet connection.

Fix: Make sure you are connected to the Internet; if using dial-up either manually initiate a connection or set it up so that the system automatically dials-up when a connection is required.


E5701

Error E5701: Cannot connect to the server.

Fix: Make sure the server name is correct (check spelling). If it is, try pinging it from a command-line prompt. If look-up fails, try using its IP address. If it is a web server, try to connect to it using your browser. If it is a FTP server, try to connect to it using an FTP program.


E5702

Error E5702: The path/folder or file specified was not found.

Fix (path/folder): Make sure the path/folder entered is correct (check spelling) and that it exists on the server. If you want to create it make sure you have permissions to create folders on the server. Some systems do not allow you to create more than one level in one go.

Fix (file): Make sure the file entered is correct (check spelling) and that it exists on the server. If you want to create it make sure you have permissions to create files in the path/folder specified on the server.


E5703

Error E5703: The request to the server failed. The error code of the failure is in the message.

Fix: This depends on the error code returned by the server. Generally either your credentials do not allow you to execute the request (check login) or the request made is incorrect (check request) or not supported by the server (check server config).


E5704

Error E5704: Failed to create local file.

Fix: Check whether you have permissions to create files in the path/folder specified and that the name is valid. If a file with the same name already exists in the path/folder specified check that it can be overwritten.


E5705

Error E5705: Download has failed. The error code of the failure is in the message.

Fix: Generally other errors displayed previously tell you what has gone wrong with the download. If there are no other errors displayed, use the error code to diagnose what is amiss. Generally the transfer itself has failed (timeout/corruption); try again.

For more information, please see the (FAQ).


E5706

Error E5706: Failed to create remote file.

Fix: Check whether you have permissions to create files in the path/folder specified and that the name is valid on the server. If a file with the same name already exists in the path/folder specified on the server check that it can be overwritten.


E5707

Error E5707: Upload has failed. The error code of the failure is in the message.

Fix: Generally other errors displayed previously tell you what has gone wrong with the upload. If there are no other errors displayed, use the error code to diagnose what is amiss. Generally the transfer itself has failed (timeout/corruption); try again.


E8000

 Error E8000: Temporary folder not set; cannot create temporary file.

Fix: Make sure a temporary folder is set (check TMP and TEMP environment variables) and that there is plenty of space on the drive it points to.


E8100

Error E8100: Cannot create printer device context.

Fix: Make sure the printer selected is correctly installed and it is on-line. You can try deleting and re-installing the printer.


E8101

Error E8101: Printer object creation has failed.

Fix: Generally this is a program error; check that the program is valid.


E8102

Error E8102: ADO error; the error code is in the message itself.

Fix: Depending on the error code and message displayed take appropriate action to correct the problem. Generally it is a connection problem. Also make sure the latest version of MDAC (2.5 or later) is installed.


E8103

Error E8103: Cannot initialise ODBC interface.

Fix: Check that ODBC is correctly installed. You may need to re-install MDAC or a later version of it to correct the problem.


E8104

Error E8104: Failed to connect to database.

Fix: Make sure the database connection settings are correct (check spelling). Check server is on-line and reachable by using the database test utilities supplied. Check that the credentials specified are correct and allow remote connection.


E8105

Error E8105: Report creation failed. The error code is in the message.

Fix: Depending on the error code and message displayed you can get a good idea as to what went wrong.

If you have aborted the operation yourself this message is normal.


E8106

Error E8106: Failed to send e-mail by MAPI.

Fix: Check that a MAPI client is installed and configured as the default MAPI provider. Generally this would be your e-mail client. Make sure an account is set-up and correctly configured.


E8107

Error E8107: Failed to send e-mail by SMTP.

Fix: Check that the details of SMTP server entered are correct and that the server is on-line. Try pinging it from a command prompt or try sending an e-mail through it using your normal e-mail client. It is also possible that your credentials do not allow e-mail relaying or that the message does not satisfy the relay criteria defined by the administrator.


E8108

Error E8108: Failed to post message by NNTP.

Fix: Check that the details of NNTP server entered are correct and that the server is on-line. Try pinging it from a command prompt or try sending a message through it using your normal news client. It is also possible that your credentials do not allow news posting or that the message does not satisfy the post criteria defined by the administrator.


E8109

Error E8109: Failed to post message to the queue.

Fix: Check that the details of MSMQ server entered are correct and that the server is on-line. Try pinging it from a command prompt and check that the queue exists. It is also possible that your credentials do not allow posting to that queue or that server.


E8110

Error E8110: File upload failed.

Fix: Generally other errors displayed previously tell you what has gone wrong with the upload. If there are no other errors displayed, use the error code to diagnose what is amiss. Generally the transfer itself has failed (timeout/corruption); try again.


E8111

Error E8111: Unknown or undocumented error.

Fix: This is an unexpected error thus no further information is available.


E8112

Error E8112: Generic error.

Fix: This is an unexpected error thus no further information is available.


E8113

Error E8113: Not enough free disk space.

Fix: Clear up the drive on which the file is being created and make more free space available. Alternatively create the file on a different drive/partition.


E8114

Error E8114: Not enough free memory.

Fix: Close down as many applications as possible to give more memory to the application. Alternatively increase the swap file size or install more memory.


E8115

Error E8115: The operation has been aborted.

Fix: Nothing, you have aborted the operation yourself.


E8116

Error E8116: The operation has been aborted.

Fix: Nothing, you have aborted the operation yourself.


Environment Monitor - Step 1

You can adjust the parameters of the environment monitor to suit your needs before proceeding:

Time interval (minutes): Enter the number of minutes you want the sample to be taken, or 0 if only specifying seconds.

Time interval (seconds): Enter the number of seconds you want the sample to be taken, or 0 if only specifying minutes


Opens the SiSoftware website

Starts up your default web browser and loads up the SiSoftware website:

  • SiSoftware UK
  • SiSoftware EU
  • SiSoftware US

If this does not work, try entering the address manually in your web browser. See Technical Support and Points of Contact for more information.


Help Topics

Help Contents

Displays the SiSoftware Sandra’s help topics.


Help Using Help Command

Context Help command

Use the Context Help command to obtain help on some portion of the program. When you choose the Toolbar's Context Help button, the mouse pointer will change to an arrow and question mark.

Then click somewhere in the application window, such as another Toolbar button. The Help topic will be shown for the item you clicked.

Shortcut

Keys: SHIFT+F1


Firewire/1394 Controller

Firewire/1394 Controller Information

The Firewire/1394 controller provides a fast serial bus (400/800MHz) that allows a fast, automatically configurable, data link between your system and other high-speed devices like digital camcorders, storage devices and even other systems.

While most controllers offer a limited number of ports (2 or 3) by using a hub, many more devices can be connected, although the bandwidth is be shared by all the devices on a port.

For more information see Wiki: FireWire


AGP Bus

AGP Bus Information

AGP (Advanced Graphics Port) is an extension to PCI (though not slot compatible) allowing graphic adapters to use system memory, as well as being faster at 66MHz and above. Using 2x, 4x or 8x data rates, even more throughput is possible (133 & 266 data transfer rate respectively). With DIME, graphics cards can texture from AGP memory using textures much larger than would fit in local video memory.

For more information see Wiki: AGP


APIC

APIC Information

This device provides multi-processor interrupt management as well as interrupt distribution across processors. In a uni-processor system, the APIC’s dedicated bus reduces latencies compared with the standard PIC. The APIC communicates with the CPU’s local APIC through a dedicated APIC or IMB bus.

For more information see Wiki: APIC


BIOS Information

The BIOS (Basic Input Output System) contains the start-up code that initialises and starts your PC. It also serves as an interface between hardware and software.

For more information see Wiki: BIOS


Buses

Buses Information

A bus is a set of wires (lines on boards, etc.) that allow devices to communicate. Generally this is done in parallel fashion to make the exchange of bytes faster. Modern systems have many buses that connect the various chips and devices together as well as providing data links to peripherals.

For more information see Wiki: Computer Bus


Cache Memory

Fast but small memory used by the CPU or Chipset to hold recently accessed data and greatly speed up the system. Size varies between 1KB to 8MB, the more you have the better. Very important especially if a lot of system memory is installed.

Internal Code/Data Cache - Very fast but rather small memory built-in the processor that holds recently accessed data. Also called L1 cache. Some processors have separate code & data caches, others have a unified cache. The size varies between 1kB to 64kB. The bigger the better but depends on processor type so you can’t add more. The L1 cache runs at processor speed.

L2/L3 Cache - Some processors have a second/third levels of cache, larger than the L1 cache (64kB to 2MB) but slower. The caches can either be built-in (thus running at processor speed) or on-board (thus running at a fraction of processor speed or even FSB speed).

For more information see Wiki: Cache


Chipset

Chipset Information

The ancillary chips on the mainboard that complete the computer by connecting the processor(s), memory and the devices through various buses. Modern systems have integrated chipsets of only one or two (North-bridge and South-bridge) that supply all the required functionality; older designs may contain a multitude of chips to supply all the required functionality. The two are connected through the hub interface or by a PCI bus.

For more information see Wiki: Chipset

The North-bridge communicates with the processor(s) through the FSB and usually contains the memory controller(s), AGP controller and other high-speed bus interfaces (PCI-X, PCI-66). See Wiki: Northbridge

The South-bridge usually contains the controllers, e.g. ATA/ATAPI, USB, FireWire/1394, SMBus, Network, etc. See Wiki: Southbridge


Cooler/Heat Sink/Thermal Solution

???


CPU/Processor Information

The processor (also called CPU, i.e. Central Processing Unit) is the heart or brain of the system, executing the software running on your PC.

For more information see Wiki: CPU

Performance Rating - How fast a Pentium Classic processor must run to be as fast as your processor. This is useful when comparing different processors. Generally it is the score obtained by running WinStone (a system benchmark using real applications) on a test machine.

For more information see Wiki: PR rating


CPU Features Support

Modern processors support new features that allow increased performance in applications that specifically use the features in question. Here are the most important:

MMX is an extension to the x86 instruction set that allows multiple bytes of data to be packed together in a single register and operated on simultaneously. MMX consists of 57 new instructions for speeding multimedia tasks. The trick to these new instructions is that they operate on many different data elements at once, which increases the overall amount of work the processor can do. Examples range from operating on multiple pixels in a bitmapped image to multiple sound channels in an audio stream. MMX is not intrinsically a graphics or multimedia acceleration technology, but those are the types of applications that stand to benefit most. MMX will provide a substantial performance boost for some new applications that are coded to use MMX (more so for home rather than for business applications).

3DNow! Technology - this is a set of instructions added by AMD to speed-up 3D multimedia applications using the processor. Unlike MMX, it works with floating point data. Support is included in DirectX 6 and later.

Enhanced 3DNow! Technology - this is a set of instructions added by AMD to speed-up 3D multimedia applications using the processor. It adds further instructions to the original 3DNow! Support is included in DirectX 7 and later.

SSE is an extension to the MMX instruction set designed to accelerate software performance in application that use 3D graphics, 3D geometry, signal processing, simulation, video and 3D software rasterisation, video encoding/decoding (e.g. MPEG, MPEG2).

SSE2 is a superset of SSE set of instructions added by Intel to speed-up multimedia applications by using SIMD (single instruction multiple data) type operation like multi-processor arrays. While SSE works with single float data, SSE2 works double float data.

For more information see Wiki: SIMD (Single Instruction, Multiple Data)


CPU Clock Multiplier

This is the internal processor multiplier that governs the speed of the processor w.r.t. to FSB speed. The speed of the processor is simply the multiplier * FSB speed (MHz).

To overclock, you can just increase the multiplier thus increasing the CPU’s speed. However, most modern processors have locked/fixed multipliers; thus only increasing the FSB is the only option.

For more information see Wiki: Clock Multiplier


SMBIOS / DMI

SM (System Management) or Desktop Management Interface (DMI) is an interface through which software can obtain very detailed asset/system information either from local or remote workstations.

For more information see Wiki: SMBIOS


Environment/Hardware Monitor

Environment/Hardware Monitor Information

This is a chip designed to help manage the system by monitoring critical system parameters, diagnose the system, report errors and signal other devices to recover from critical states.

Usually such a chip monitors the temperatures, fan speeds, voltages and electrical drawn currents in the system and alerts the user/etc. of out-of-range errors and thus preventing system/data damage.


FPU/Co-Processor

FPU/Co-Processor Information

The co-processor (also called FPU, i.e. Floating Point Unit) is a special processor that does floating-point calculations directly, much faster than the processor would have done. While today this is integrated in the processor, in the past it was a separate chip that you had to buy if you used mathematical intensive programs/computations.

For more information see Wiki: Floating point unit


FSB (Front-Side Bus)

The FSB is the connection between the processor(s) and the chipset. The data rate (i.e. the amount of data transferred) may be higher than the actual speed.

To overclock, the FSB can be increased, thus increasing the CPU speed; however, increasing FSB speed may result in increased speed of other devices that may not work at the increased speed.

For more information see Wiki: Front side bus


LPC Hub Controller

LPC Hub Controller Information

Also known as the Super I/O controller, this provides a higher performance ISA/X-Bus that is compatible with existing devices. It usually includes all the legacy interfaces, e.g. keyboard controller, floppy disk controller, serial/parallel ports controllers, power management controller and possibly a built-in environment monitor.

For more information see Wiki: Super I/O


Hub Interface

Also known as the I/O controller hub, this is the interface between modern North Bridge and the South Bridge that provides I/O access to the rest of the system. While older designs used the standard PCI bridge to connect the two, the hub interface ensures that the I/O sub-system, both PCI and integrated controllers receive adequate bandwidth for peak performance.

For more information see Wiki: Computer bus


LPC Legacy Controller

LPC Legacy Controller Information

ISA (Industry Standard Architecture) is the original bus used in the 1st PC. It started with 8-bits at 8MHz, moving to 16-bit at 8-9MHz with the 286 processor. Even today it is still present in PCs to cater for modems, sound cards, I/O boards, etc. PC99 specification calls for the ISA bus to be absent from systems.

For more information see Wiki: Industry Standard Architecture


Mainboard

Mainboard Information

This is the primary board inside the system in which all the other components plug into (CPU, FPU, memory, cards, etc.) and also holds the Chipset, the on-board Controllers, any on-board Devices and their associated Buses.

For more information see Wiki: Motherboard


Memory Banks

Memory Banks Information

Lists the memory installed, size and read/write speed in each logical banks on the mainboard. There are various RAM technologies, with RDRAM (Rambus DRAM) the fastest, SDRAM (Synchronous Dynamic RAM), BEDO (Burst EDO), EDO (Extended Data Out), FPM (Fast Page Mode) being the classic type.

Your chipset must specifically support that type of memory so check before you buy.

For more information see Wiki: Computer storage


Memory Controller

Memory Controller Information

The memory controller is the part of the chipset that manages the system memory. The cache controller interfaces between it and the CPU in order to speed-up the process.

For more information see Wiki: Memory controller


Memory Modules

Memory Modules Information

This information represents settings used to drive the memory modules by the memory controller. They should represent the memory modules' capabilities when running at the current speed. They may not represent the recommended settings.

The encoding is based on the industry standards and thus is compatible with the information printed on the modules, displayed by the BIOS, etc. This information is gathered directly from the memory controller.

  • SDRAM/DDR/DDR2/DDR3 read/write/CL latency specification
    a-b-b-bR c-d-d-dW e-f-g-hCL
    1. a - read page hit clocks for first item
    2. b - read page hit clocks for follow-up items
    3. c - write page hit clocks for first item
    4. d - write page hit clocks for follow-up items
    5. e - CL (CAS latency)
    6. f - SDRAM tRCD (RAS to CAS delay)
    7. g - SDRAM tRP (RAS precharge)
    8. h - SDRAM tRAS (Active-to-Precharge Delay)

  • RDRAM read/write/CL latency specification
    a-b-b-bR c-d-d-dW e/fCL
    1. a - read page hit clocks for first item
    2. b - read page hit clocks for follow-up items
    3. c - write page hit clocks for first item
    4. d - write page hit clocks for follow-up items
    5. e - RDRAM tRCD (Row to Column delay)
    6. f - RDRAM tCAC (Channel to Channel delay)

This information represents the memory modules characteristics. The encoding is based on the industry standards that should tally with what is printed on the memory modules' label. This information is gathered directly from the SPD/EEPROM chip of the memory module.

  • DDR2 SDRAM specification - Version 4.0
    gggg eRxff PC2-wwwwm-abc-dd (e.g. 1GB 1Rx4 PC2-3200F-333-10)
    1. gggg - Module size in MB.
    2. e - Number of ranks present.
    3. ff - Bit width of memory chips.
    4. wwww - Memory bandwidth (MB/s). Memory bus speed should be 1/16 or lower.
    5. m - Module Type (E = Unbuffered DIMM with ECC, F = Fully Buffered DIMM, M = Micro-DIMM, N = Mini-Registered DIMM no parity, P = Registered DIMM w/parity, R = Registered DIMM no parity, S = SODIMM, T = Mini-Registered DIMM w/parity, U = Unbuffered DIMM).
    6. a - CAS latency (CL cycles) at maximum frequency. Lower the better (faster), but more expensive.
    7. b - RAS to CAS delay (tRCD cycles) at maximum frequency. Lower the better.
    8. c - Row precharge (tRP cycles) at maximum frequency. Lower the better.
    9. dd - SPD chip revision. 10 corresponds to SPD 1.0.

  • DDR2 SDRAM specification - Version 1.0
    PC2-wwwwm-aabcd (e.g. PC2-3200U-25330)
    1. wwww - Memory bandwidth (MB/s). Memory bus speed should be 1/16 or lower.
    2. m - Module Type (R = RDIMM, U = Unbuffered, S = SODIMM).
    3. aa - CAS latency (CL cycles) at maximum frequency. Lower the better (faster), but more expensive.
    4. b - RAS to CAS delay (tRCD cycles) at maximum frequency. Lower the better.
    5. c - Row precharge (tRP cycles) at maximum frequency. Lower the better.
    6. d - SPD chip revision. 0 corresponds to SPD 1.0.

  • DDR SDRAM specification - Version 1.0
    PCwwwwm-aabc-dde (e.g. PC1600R-2533-750)
    1. wwww - Memory bandwidth (MB/s). Memory bus speed should be 1/16 or lower.
    2. m - Module Type (R = Registered, U = Unbuffered, B = Buffered).
    3. aa - CAS latency (CL cycles) at maximum frequency. Lower the better (faster), but more expensive.
    4. b - RAS to CAS delay (tRCD cycles) at maximum frequency. Lower the better.
    5. c - Row precharge (tRP cycles) at maximum frequency. Lower the better.
    6. dd - Read data access time (tAC ns). 54 corresponds to 5.4ns. Lower the better.
    7. e - SPD chip revision. 0 corresponds to SPD 1.0.

  • RDRAM Rambus specification - Version 1.0
    xMB/a b c PCwww-e (e.g. 256MB/16 ECC PC800-45)
    1. x - Module size in Mbytes on the module.
    2. a - Number of RDRAM devices on the module.
    3. b - Error correcting support (e.g. ECC)
    4. c - Reserved.
    5. www - Speed (Mega data transfers per second, Mt/s). Memory bus speed should be 1/2 or lower.
    6. e - Response Time (ns).

  • PC100/133+ SDRAM specification - Version 1.2b+
    PCwww-abc-ddeefm (e.g. PC100-322-54122R) where:
    1. www - Speed rating (MHz). Memory bus speed should be equal/lower.
    2. a - CAS latency (CL cycles) at maximum frequency. Lower the better (faster), but more expensive.
    3. b - RAS to CAS delay (tRCD cycles) at maximum frequency. Lower the better.
    4. c - Row precharge (tRP cycles) at maximum frequency. Lower the better.
    5. dd - Read data access time (tAC ns). 54 corresponds to 5.4ns. Lower the better.
    6. ee - SPD chip revision. 12 corresponds to SPD 1.2.
    7. f - Design revision. The current is 2 corresponding to Rev 1.2.
    8. m - R for registered DIMMS. 256MB and bigger modules need to be registered.

  • PC133+ H/E/VC/SDRAM specification - Version 2.0
    PCwwwm-abc-dde (e.g. PC133U-222-452, PC133R-333-542)
    1. www - Speed rating (MHz). Memory bus speed should be equal/lower.
    2. m - Module Type (R = Registered, U = Unbuffered, B = Buffered).
    3. a - CAS latency (CL cycles) at maximum frequency. Lower the better (faster), but more expensive.
    4. b - RAS to CAS delay (tRCD cycles) at maximum frequency. Lower the better.
    5. c - Row precharge (tRP cycles) at maximum frequency. Lower the better.
    6. dd - Read data access time (tAC ns). 54 corresponds to 5.4ns. Lower the better.
    7. e - SPD chip revision. 2 corresponds to SPD 2.0.

  • PC66/100 SDRAM specification - Version 1.0 to 1.2
    PCwww-abc-defm (e.g. PC100-322-622R) where:
    1. www - Speed rating (MHz). Memory bus speed should be equal/lower.
    2. a - CAS latency (CL cycles) at maximum frequency. Lower the better (faster), but more expensive.
    3. b - RAS to CAS delay (tRCD cycles) at maximum frequency. Lower the better.
    4. c - Row precharge (tRP cycles) at maximum frequency. Lower the better.
    5. d - Read data access time (tAC ns). Lower the better.
    6. e - SPD chip revision. 2 corresponds to SPD 1.2.
    7. f - Design revision. 2 corresponds to Rev 1.2.
    8. m - R for registered DIMMS. 256MB and bigger modules need to be registered.

For more information see Wiki: Random access memory


PCI Bus

PCI Bus Information

PCI (Peripheral Component Interconnect) is a local bus capable of self-arbitration. Current versions (2.XX) are 32-bit at 33MHz with 64-bit 66MHz and faster available.

For more information see Wiki: Peripheral Component Interconnect


PCI-X Bus

PCI-X Bus Information

PCI-X is a new, faster version of the PCI Bus with 64-bit data width running at 133MHz for much faster data transfer.

For more information see Wiki: Peripheral Component Interconnect


PC Card/CardBus/PCMCIA Controller

PC Card/CardBus/PCMCIA Controller Information

The PCMCIA (16-bit) or CardBus (32-bit) controllers provide an automatically configurable high-speed bus for connecting high-speed devices to laptops including network adapters, modems and other controllers like USB or FireWire.

For more information see Wiki: PC card


System Clock Generator (PLL IC)

System Clock Generator (PLL IC) Information

Also known as the timing generator, this chip provides the base timing (aka frequency clock) as well as customised timing for all the on-board devices, including CPU, Chipset, Controllers, etc. Modern versions can be programmed to change the timing and thus change the frequency the devices run at.

For more information see Wiki: Clock generator


Plug & Play

Plug & Play is a resource management interface that allows automatic configuration of add-in cards to avoid resource conflicts. Some buses like PCI, PCMCIA, EISA take care of this themselves so Plug & Play must act as a liaison between them.

For more information see Wiki: Plug-and-play


SMBus, BMBus, i2c Controller

SMBus, BMBus, i2c Controller Information

The SMBus, BMBus and i2c controllers provide a simple, slow, serial bus (10-100kHz) for devices on the mainboard to communicate with each other as well as with the system itself. Generally environment monitor chips, memory modules EEPROM and other EEPROM devices use this bus.

For more information see Wiki: System Management Bus

For more information see Wiki: I²C

For more information see Wiki: Serial Peripheral Interface Bus


USB Controller

USB Controller Information

The USB controller provides a medium (USB 1.x @ 24/48MHz) or fast (USB 2.x @ 480MHz), automatically configurable, data link between your system and most type of peripherals like keyboards, mice, printers, scanners, digital cameras, etc.

This bus has eliminated the need for different buses (serial, parallel, X-bus, SCSI) and connectors (serial, parallel, PS/2, external SCSI) that plagued legacy systems.

While most controllers offer a limited number of ports (2 or 3) by using a hub, many more devices can be connected, although the bandwidth is be shared by all the devices on a port. Modern computers generally include multiple USB controllers as well thus offering many ports.

For more information see Wiki: Universal Serial Bus


Processor Cache and Memory

Benchmark the processors' caches and memory access (transfer speed). Shows how your processors' caches and memory sub-systems compare to other computers in terms of access.

The benchmark is based on the Memory Bandwidth test.

  • Multi-Processor (SMP) support for up to 32/64 CPUs & SMT.
  • Floating-point Operations Benchmark (assignment, scaling, addition, triad)
  • Close all programs before running it especially if you have less than 16MB.
  • Test takes about 10 minutes on P6-class machines with 64MB.
  • Test takes about 5 to 10 times longer than the Memory Bandwidth test.
  • Command Line Switch: CacheBwBench
  • Requirements: None
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win32 CE) Support: Windows Mobile 2003/SE, 5
  • OS (Win64) Support: Windows XP/2003

Explanations

See also Questions and Answers document for full information.

See List of Acronyms for more information.

Acknowledgements

FPU Memory Tests - Based on the C STREAM benchmark by Dr. John D. McCalpin. Optimised P6 assembler by C. Adrian Silasi

I/F SSE Memory Tests - by C. Adrian Silasi FPU tests.

I/F SSE2 Memory Tests - by C. Adrian Silasi FPU tests.

MP/MT harness - by C. Adrian Silasi.

See Acknowledgements topic for more information.

Options

Include Extra System Information - show some more details about tested system.

Enable MP/MT Benchmarks - if disabled, run single-threaded even on MP systems.

Use Static MP Load Balance - if disabled, calibrate on each CPU before executing and use variable work units.

Include DMI/SMBIOS Information - query the system through the DMI/SMBIOS interface.

Disable Enhanced MMX (Float) Benchmark - if enabled, do not use the Enhanced MMX benchmark.

Disable SSE (Float) Benchmark - if enabled, do not use the SSE benchmark.

Disable SSE2 (Float) Benchmark - if enabled, do not use the SSE2 benchmark.

Enable SMT/HyperThreading Benchmark - enable SMT support in harness.

Include Memory Banks Information - show memory banks arrangement.

Use buses by PCI-to-PCI bridge configuration - get bus information by bridges; otherwise get by OS.

Include CPU MSR Information - get CPU info by MSR.

Include Performance Enhancing Tips - if disabled, do not display any tips.

Explanations

The in the graphical window the Cache/Memory Bandwidth (y axis) is plotted as a function of the file size (x axis). The y axis can be toggled between linear and logarithmic scale. Please note that the x axis scale is non-linear and somewhat distorted for ease of comprehension. The chart is intended for easy to use "one-glance" comparison, and it should NOT to be used for data readout.

Combined Index: is a composite figure representing the overall performance rating of the entire Cache-Memory performance in terms of MB/s. The value is the logarithmic average of all the results for the entire address space. (Higher is better, i.e. better performance)

For block sizes that could not been tested - the average of previous blocks is used, thus the size of the memory (as long as it is not comparable to largest cache size) is not significant; all cache sizes are significant - larger caches will result in a higher index.

Speed Factor: is a figure representing the speed differential between the CPU’s cache and memory. The value is the ratio of the fastest cache (i.e. L1) bandwidth to the main memory bandwidth. (Lower is better, i.e. the memory is not very much slower than CPU’s cache)

As the factor is a ratio, it is useful only in comparing different CPUs and memory sub-systems rather than having a direct, physical interpretation associated to its numerical value.

Tips

Tips (Performance) List


CD-ROM and DVD

Benchmark CD-ROM, DVD, HD DVD an Blu-ray drives. Shows how your CD-ROM, DVD, HD DVD and Blu-ray drives and storage hosts compare to other drives in a typical computer.

The test is analogous to the Physical Disks benchmark but designed for CD-ROM and DVD drives.

  • Read Test: Sequential across disk
  • Write Test: Sequential across disk
  • Seek Test: random, full stroke, 1/3 stroke

For these tests, the Sandra Test CD and DVD disks are recommended as they are pressed and use the full capacity of the disks. You can use other disks that are close to being full or burn your own disks.

Test takes about 5 minutes on P6-class machines with 32x CD-ROM.

Note 1: Pressed disks are recommended for testing unless you want to test the performance with write once or re-writtable disks; most drives yield lower performance with non-burned disks.

Note 2: You cannot use copy-protected DVD, HD DVD or Blu-ray disks as they are encrypted and cannot even be read.

Drive Index: is a composite figure representing an overall performance rating based on the highest read or write speed across the whole disk. Thus the higher the better.

Access Time: is the average time to read a random sector on the disk, analogous to latency response time. Thus the lower the better.

  • Command Line Switch: CDROMBench
  • Requirements: CD-ROM, DVD, HD DVD or Blu-ray drive; Sandra CD and DVD test disks
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win64) Support: Windows XP/2003

Explanations

See Drives Information topic for more information.

See also Questions and Answers document for full information.

See List of Acronyms for more information.

Options

Bypass Windows Cache - use write-through mode to bypass cache. If disabled, use normal mode.

Include Extra Disk Information - show some more information about the drive.

Include Performance Enhancing Tips - if disabled, do not display any tips.

Acknowledgements

See Acknowledgements topic for more information.

Tips

Tips (Performance) List


Processor Arithmetic

Benchmarks the ALU and FPU processor units. Shows how your processors handle arithmetic and floating point instructions in comparison to other typical processors.

Such operations are used by software in typical tasks.

  • Multi-Processor (SMP) support for up to 32/64 CPUs & SMT.
  • Test takes about 1 minute on P6-class PCs.
  • Command Line Switch: CPUAABench
  • Requirements: None
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win32 CE) Support: Windows Mobile 2003/SE, 5
  • OS (Win64) Support: Windows XP/2003

Explanations

  • MP Dhrystone (MIPS) CPU (Arithmetic) Benchmark
  • MP Whetstone (MFLOPS) FPU (Floating Point) Benchmark
  • MP Whetstone (MFLOPS) SSE2 (Floating Point) Benchmark
  • MP Whetstone (MFLOPS) SSE3 (Floating Point) Benchmark

See Computer (CPU/Bus/BIOS/Chipset) Information topic for more information.

See also Questions and Answers document for full information.

See List of Acronyms for more information.

Acknowledgements

Dhrystone Benchmark - Based on the original C Dhrystone 2.1 by Reinhold P. Weicker, Siemens AG.

Whetstone Benchmark - Based on the original C Whetstone 2.0 translated from the original Algol program by H. J. Curnow and B. A. Wichman.

SSE2 Whetstone Benchmark - Written by Intel/Srinivas L based on the Whetstone C 2.0 benchmark.

SSE3 Whetstone Benchmark - Written by Intel/Ronen Z based on the Whetstone SSE2 benchmark.

MP/MT harness - by C. Adrian Silasi.

See Acknowledgements topic for more information.

Options

Include Extra System Information - show some more details about tested system.

Enable MP/MT Benchmarks - if disabled, run single-threaded even on MP systems.

Include DMI/SMBIOS Information - query the system through the DMI/SMBIOS interface.

Use Static MP Load Balance - if disabled, calibrate on each CPU before executing and use variable work units.

Enable SSE2 (Float) Benchmark - if disabled, do not use the floating-point SSE2 benchmark.

Enable SSE3 (Float) Benchmark - if disabled, do not use the floating-point SSE3 benchmark.

Enable SMT/HyperThreading Benchmark - enable SMT support in harness.

Include CPU MSR Information - get CPU info by MSR.

Enable Parallel Execution - enable PE support in harness.

Include Performance Enhancing Tips - if disabled, do not display any tips.

Tips

Tips (Performance) List


File Systems

Benchmark mounted file systems (i.e. volumes). Shows how your file systems connected to storage adapters and storage hosts compare to other devices in a typical computer.

This is not the raw disk performance that other benchmarks test - but the speed of the volume itself that depends on many more factors like file system, operating system cache, position on disk, etc. Thus this is the performance you get at the file system level.

  • Read Test: Buffered, Random, Sequential
  • Write Test: Buffered, Random, Sequential
  • Seek Test
  • Test needs up to 512KB or more free space on the floppy disk tested.
  • Test needs up to System Memory Size or more free space on the hard-drive tested.
  • Test needs up to 10MB or more free space on the remote/network drive tested.
  • Test needs up to 4MB or more free space on the memory-drive tested.
  • Please ensure that any important information is backed up prior to starting the test.
  • Test takes about 5 minutes on P6-class machines with 8GB or larger hard disks.

Drive Index: is a composite figure representing an overall performance rating based on the average of the read, write, and seek tests, and file and cache size. The Drive Index is intended to represent drive performance under typical use in a PC. A larger number means better performance. The weighting of the results is not equal it represents the distribution of different files sizes as used on these devices (obtained through field research).

  • Command Line Switch: FSBench
  • Requirements: None
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win32 CE) Support: Windows Mobile 2003/SE, 5
  • OS (Win64) Support: Windows XP/2003

Explanations

All devices referenced include a device description this can be found in ( ) for example (15Krpm, 8M cache) this means that the drive tested run at 15,000 rpm and has 8MB of drive cache.

All devices referenced include a file system description this can be found in [ ] for example [FAT16, WinXP] this means that the test was carried out on a file system with FAT16 on Windows XP.

See Drives Information topic for more information.

See also Questions and Answers document for full information.

See List of Acronyms for more information.

Options

Bypass Windows Cache - use write-through mode to bypass cache. If disabled, use normal mode.

Include Extra Disk Information - show some more information about the drive.

Include Write Benchmark - do the write tests as well.

Benchmark Floppy Drives - if disabled, ignore floppy drives.

Benchmark Removable Drives - if disabled, ignore removable drives.

Benchmark Hard Disks - if disabled, ignore hard disks.

Benchmark All Hard Disk Partitions - if disabled, benchmark the first partition of the hard disk only.

Benchmark Memory Drives - if disabled, ignore memory drives.

Benchmark Network Drives - if disabled, ignore network drives.

Enable MP/MT Benchmarks - if disabled, run single-threaded even on MP systems.

Use Static MP Load Balance - if disabled, calibrate on each CPU before executing and use variable work units.

Enable SMT/HyperThreading Benchmark - enable SMT support in harness.

Include Performance Enhancing Tips - if disabled, do not display any tips.

Acknowledgements

See Acknowledgements topic for more information.

Tips

Tips (Performance) List


Removable Storage Benchmark

Benchmark removable and flash devices. Shows how your removable storage and flash memory devices compare to other typical devices.

Such devices are typically small, portable media devices. They are connected into a computer typically via USB (however there are other interface alternatives). These devices are increasing in popularity as users are searching for small (key ring or pen sized devices), which they can use for transferring and backing up the users templates, pictures, documents and more. When Sandra refers to such devices it is referring to the two integrated parts the controller and the memory typically flash internal to the device.

As with many tests there are other external factors that may effect the results and may cause a repeat test to produce a slight difference these include but are not limited in motherboard chipset / architecture, USB hub, interface or controller.

Note: All reference results have been made using an Intel EHCI USB controller (USB 2.0).

  • Test needs a minimum free space of 16MB with the optimal free space being 50MB on the device to be tested.
  • Please ensure that any important information is backed up prior to starting the test.
  • If the device to be tested requires a specific interface port then this is required i.e. USB 2.0 for a USB 2.0 device.
  • Test takes about 5 minutes on P6-class machines with 64MB flash device.
  • Command Line Switch: FlashBench
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win32 CE) Support: Windows Mobile 2003/SE, 5
  • OS (Win64) Support: Windows XP/2003

Explanations

The typical usage model for these devices is file operations, such as writing a file to the device, reading a file from it, and deleting a file, this benchmark exercises the devices in terms of these operations.

To measure the "raw" cluster level performance of the device, it is recommended to also test it by means of the File Systems module.

The following characteristics are measured for each of the four representative files sizes of 512 Bytes (representing a minimal single data cluster file), 32kB, 256kB, 2MB and 64MB. The weighting of the results is not equal it represents the distribution of different files sizes as used on these devices (obtained through field research):

Read Performance: expressed both in terms of Operations per Minute (i.e. the number of files read per minute) and the corresponding net transfer rate in kB/second.

Write Performance: similarly expressed both in terms of Operations per Minute (i.e. the number of files written in a minute) and the corresponding net transfer rate in Kbytes/second.

Delete Performance: measuring the number of files deleted per minute.

For each of the four file sizes a Combined Index is then calculated, stating the combined performance in terms of Combined Operations Per Second, with respect to a mix of write, read and delete operations.

Combined Device Index: is a composite figure representing an overall performance rating based on the average of the Combined Index figures over the four file sizes. (Higher is better, i.e. better performance)

The in the graphical window the Combined Index (y axis) is plotted as a function of the file size (x axis). The y axis can be toggled between linear and logarithmic scale. Please note that the x axis scale is non-linear and somewhat distorted for ease of comprehension. The chart is intended for easy to use “one-glance” comparison, and it should NOT to be used for data readout.

Endurance Factor: is a figure representing the Wear and Life Expectancy of flash devices; this is obtained by dividing the average performance (normal condition, i.e. sequential write) to the lowest performance (high-stress condition, i.e. same block re-write).

It measures the relative improvement of endurance caused by the wear levelling or flash management algorithm; the absolute endurance of a device (i.e. its expected life-time) is directly dependent, in addition to this Endurance Factor, on the nominal manufacturer rating of maximum erase/reprogram cycles, which is typically 100,000+ for SLC and 10,000+ for MLC devices. (Higher is better, i.e. longer life-time for the device)

As the factor is a ratio, it is useful only in comparing devices rather than having a direct, physical interpretation associated to its numerical value.

See Drives Information topic for more information.

See also Questions and Answers document for full information.

See List of Acronyms for more information.

Acknowledgements

See Acknowledgements topic for more information.

Options

This module has no options to set.

Tips

Tips (Performance) List


Internet Connection

Benchmark the bandwidth and latency of the Internet connection of your computer. Shows how fast your Internet connection and ISP are compared to other typical Internet connections and ISPs.

The test attempts to measure the bandwidth and latency of the connection to your ISP's gateway computer; this should be the maximum transfer rate of the link (i.e. between your computer and ISP gateway).

NB: As the test needs to detect the ISP's gateway - not your Internet gateway - the results vary with network topology. In some cases, the incorrect gateway may be tested.

  • Command Line Switch: InetConnBench
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win32 CE) Support: Windows Mobile 2003/SE, 5
  • OS (Win64) Support: Windows XP/2003

Explanations

Gateway / Router - The benchmark first attempts to detect the first gateway/router at the ISP end in order to benchmark the Internet link. This should work in most networks, except some networks where the Internet connection is at the end of a VPN link.

ADSL / Asymmetric Links - It is important to note that this is the aggregated of the send and receive rates, thus the result will be approximately the average of the send and receive rates.

Lantecy - The average link latency is also determined by repeatedly pinging the gateway/router.

Packet loss - While benchmarking the Internet connection, a count is kept of any un-acknowledged packets and the corresponding packet loss calculated. This determines the quality of the link that is as important as the speed of the link.

Burn-in Note: In order to prevent the possible misuse of this test in a DOS (Denial of Service) attack, this module is not burn-in capable. This is by design.

See List of Acronyms for more information.

Acknowledgements

Benchmark Idea - C. Adrian Silasi; additional input by Craig Hart.

See Acknowledgements topic for more information.

Options

This module has no options to set.

Tips

Tips (Performance) List


Internet Peerage Benchmark

Benchmark the peerage of the Internet connection. Shows how well your Internet connection and ISP are peered compared to other typical Internet connections and ISPs. By peered we mean how well (speed and latency) your ISP is connected to other ISPs and major Internet backbones.

The test measures the bandwidth and latency from your computer to major sites on the Internet. The sites are chosen at random from the list of most popular sites of the Internet. This list is updated with each version and kept up-to-date.

  • Command Line Switch: InetPeerBench
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win32 CE) Support: Windows Mobile 2003/SE, 5
  • OS (Win64) Support: Windows XP/2003

Explanations

Site Issues - While all sites chosen are high-traffic sites and designed to serve a huge number of users, and the home pages designed to load as quickly as possible, site utilisation does play a part in the transfer speed.

Lantecy - The average link latency is also determined by pinging the Internet sites.

Packet loss - While benchmarking the Internet sites, a count is kept of any un-acknowledged packets and the corresponding packet loss calculated. This determines the quality of the link that is as important as the speed of the link.

Burn-in Note: In order to prevent the possible misuse of this test in a DOS (Denial of Service) attack, this module is not burn-in capable. This is by design.

See List of Acronyms for more information.

Acknowledgements

Benchmark Idea - Mark Gaffney/Demon Internet; additional input by Craig Hart.

See Acknowledgements topic for more information.

Options

This module has no options to set.

Tips

Tips (Performance) List


Memory Latency

Benchmark the latency (response time) of processors' caches and memory. Shows how your processors' caches and memory sub-systems compare to other computers in terms of latency.

The latency of caches is measured in processor clocks (i.e. how many clocks it takes for the data to be ready) as it is dependent on the processor clock speed.

The latency of memory is measured in nanoseconds as it is typically independent on processor clock speed.

  • Each CPU unit (core, SMT unit) can be individually benchmarked; can determine transport latencies in NUMA systems.
  • Random Memory Access: access the memory at random within the range.
  • Linear Memory Access: access the memory sequentially within the range.
  • Test needs 64MB of free physical memory free for best performance.
  • Close all programs before running it especially if you have less than 16MB.
  • Test takes about 2 minutes on P6-class machines with 64MB.
  • Command Line Switch: MemLatency
  • Requirements: None
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win32 CE) Support: Windows Mobile 2003/SE, 5
  • OS (Win64) Support: Windows XP/2003

Explanations

See also Questions and Answers document for full information.

See List of Acronyms for more information.

Acknowledgements

Original Tests - by Ronen Z.

x86, x64 Port - by Ronen Z.

IA64, ARM Port - by C. Adrian Silasi.

See Acknowledgements topic for more information.

Options

Include Extra System Information - show some more details about tested system.

Enable MP/MT Benchmarks - if disabled, run single-threaded even on MP systems.

Include DMI/SMBIOS Information - query the system through the DMI/SMBIOS interface.

Include Memory Banks Information - show memory banks arrangement.

Include CPU MSR Information - get CPU info by MSR.

Include Performance Enhancing Tips - if disabled, do not display any tips.

Tips

Tips (Performance) List


Multi-Core Efficiency

Benchmark the multi-core efficiency of the processors. Shows how efficient the processor cores and their inter-connects are in comparison to other types to other typical processors.

The ability of the cores to process data blocks and pass them to another core for processing (producer-consumer paradigm) of different sizes and different chain sizes is measured. The efficiency of the inter-connect between cores is thus benchmarked; however, the number of cores (and processors) also counts as more data buffers can be processed simultaneously (aka "in flight").

True multi-core processors that have shared L2/L3 caches will thus perform much better than cores that have separate caches and are connected by the traditional FSB.

  • Multi-Processor (SMP) support for up to 32/64 CPUs & multi-core (MC)
  • Test takes about 1 minute on Core-class PCs.
  • Command Line Switch: CPUCoreBench
  • Requirements: Multi-Core processor
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win32 CE) Support: no
  • OS (Win64) Support: Windows XP/2003

Explanations

See Computer (CPU/Bus/BIOS/Chipset) Information topic for more information.

See also Questions and Answers document for full information.

See List of Acronyms for more information.

Acknowledgements

Original Idea by Ronen Z.

Multi-Core Management harness - by C. Adrian Silasi.

See Acknowledgements topic for more information.

Options

Include Extra System Information - show some more details about tested system.

Enable MP/MT Benchmarks - if disabled, run single-threaded even on MP systems.

Include DMI/SMBIOS Information - query the system through the DMI/SMBIOS interface.

Enable SMT/HyperThreading Benchmark - enable SMT support in harness.

Include CPU MSR Information - get CPU info by MSR.

Include Performance Enhancing Tips - if disabled, do not display any tips.

Tips

Tips (Performance) List


Memory Bandwidth

Benchmark the memory bandwidth of your computer. Shows how your memory sub-systems compare to other computers in terms of bandwidth.

The benchmark is based on the well-known STREAM memory benchmark.

  • Multi-Processor (SMP) support for up to 32/64 CPUs & SMT.
  • Arithmetic Operations Benchmark (assignment, scaling, addition, triad)
  • Floating-point Operations Benchmark (assignment, scaling, addition, triad)
  • Test needs at least 50% or more of free physical memory free.
  • Close all programs before running it especially if you have less than 16MB.
  • Test takes about 2 minutes on P6-class machines with 64MB.
  • Command Line Switch: MemBwBench
  • Requirements: None
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win32 CE) Support: Windows Mobile 2003/SE, 5
  • OS (Win64) Support: Windows XP/2003

Explanations

See also Questions and Answers document for full information.

See List of Acronyms for more information.

Acknowledgements

ALU/FPU Memory Tests - Based on the C STREAM benchmark by Dr. John D. McCalpin. Optimised P6 assembler by C. Adrian Silasi

I MMX Memory Test - by C. Adrian Silasi based on ALU test.

I/F SSE Memory Tests - by C. Adrian Silasi based on SGI memory bandwidth paper.

I/F EMMX/SSE Memory Tests - by AMD/Mike W. based on AMD bandwidth paper.

I/F SSE2 Memory Tests - by C. Adrian Silasi/Ronen Z based on ALU/FPU tests.

MP/MT harness - by C. Adrian Silasi.

See Acknowledgements topic for more information.

Options

Include Extra System Information - show some more details about tested system.

Enable MP/MT Benchmarks - if disabled, run single-threaded even on MP systems.

Use Static MP Load Balance - if disabled, calibrate on each CPU before executing and use variable work units.

Include DMI/SMBIOS Information - query the system through the DMI/SMBIOS interface.

Disable MMX (Integer) Benchmark - if enabled, do not use the MMX benchmark.

Disable Enhanced MMX (Integer) Benchmark - if enabled, do not use the Enhanced MMX benchmark.

Disable SSE (Integer) Benchmark - if enabled, do not use the SSE benchmark.

Disable SSE2 (Integer) Benchmark - if enabled, do not use the SSE2 benchmark.

Disable MMX (Float) Benchmark - if enabled, do not use the MMX benchmark.

Disable Enhanced MMX (Float) Benchmark - if enabled, do not use the Enhanced MMX benchmark.

Disable SSE (Float) Benchmark - if enabled, do not use the SSE benchmark.

Disable SSE2 (Float) Benchmark - if enabled, do not use the SSE2 benchmark.

Use 50% of Memory for Test - if enabled, use 50% of memory; if disabled, attempt to use all free memory for test.

Enable SMT/HyperThreading Benchmark - enable SMT support in harness.

Include Memory Banks Information - show memory banks arrangement.

Use buses by PCI-to-PCI bridge configuration - get bus information by bridges; otherwise get by OS.

Include CPU MSR Information - get CPU info by MSR.

Enable Buffering/Block Prefetch Benchmarks - use advanced benchmarks instead of linear benchmarks where possible; enable buffering & BP in harness.

Include Performance Enhancing Tips - if disabled, do not display any tips.

Tips

Tips (Performance) List


Processor Multi-Media

Benchmark the (W)MMX, SSE/2/3/4 processor units. Shows how your processors handle multi-media instructions and data in comparison to other typical processors.

Such operations are used by more specialised software, e.g. image manipulation, video decoders/encoders, games.

  • Multi-Processor (SMP) support for up to 32/64 CPUs & SMT.
  • Test takes about 1 minute on P6-class PCs.
  • Command Line Switch: CPUMMBench
  • Requirements: (Wireless) MMX (Enhanced) or SSE(2/3/4) recommended
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win32 CE) Support: Windows Mobile 2003/SE, 5
  • OS (Win64) Support: Windows XP/2003

Explanations

The test involves the generation of Mandelbrot Set fractals that are used to realistically describe and generate natural objects such as mountains or clouds. By using various multi-media extensions (Wireless) MMX, 3DNow!, SSE(2/3/4) better performance is achieved.

The test has two parts:

Integer test - using integer data:

  • MP SSSE3, SSE3, SSE2 is used for better performance if supported.

  • MP SSE (Streaming SIMD) is used for better performance if supported.

  • MP Enhanced MMX is used for better performance if supported.

  • MP (Wireless) MMX is used for better performance if supported.

  • MP ALU is used otherwise.

Floating-point test - using floating point data:

  • MP SSE2 is used for better performance if supported.

  • MP SSE (Streaming SIMD) is used for better performance if supported.

  • MP FPU is used is used otherwise.

See Computer (CPU/Bus/BIOS/Chipset) Information topic for more information.

See also Questions and Answers document for full information.

See List of Acronyms for more information.

Acknowledgements

ALU Integer Benchmark - Written by C. Adrian Silasi, based on Intel's Mandelbrot application note.

MMX Integer Benchmark - Written by Paul Hsieh based on his Mandelbrot 4x engine.

Wireless MMX Integer Benchmark - Written by Gottumukkala, Sivaji R based on the MMX benchmark.

MMX Enhanced Integer Benchmark - Written by C. Adrian Silasi based on the MMX benchmark.

SSE Integer Benchmarks - Written by C. Adrian Silasi/Ronen Z based on the MMX benchmark.

SSE2 Integer Benchmarks - Written by Ronen Z based on the SSE benchmark.

SSSE3 Integer Benchmarks - Written by Ronen Z based on the SSE2 benchmark.

FPU Float Benchmark - Written by C. Adrian Silasi, based on Intel's Mandelbrot application note.

SSE Float Benchmark - Written by C. Adrian Silasi/Ronen Z based on 3DNow! benchmark.

SSE2 Float Benchmark - Written by Ronen Z based on the SSE benchmark.

Original Mandelbrot Engine - by Paul Hsieh.

MP/MT harness - by C. Adrian Silasi.

See Acknowledgementstopic for more information.

Options

Include Extra System Information - show some more details about tested system.

Enable MP/MT Benchmarks - if disabled, run single-threaded even on MP systems.

Use Static MP Load Balance - if disabled, calibrate on each CPU before executing and use variable work units.

Include DMI/SMBIOS Information - query the system through the DMI/SMBIOS interface.

Enable (Wireless) MMX (Integer) Benchmark - if disabled, do not use the (Wireless) MMX benchmark.

Enable Enhanced MMX (Integer) Benchmark - if disabled, do not use the Enhanced MMX benchmark.

Enable SSE (Integer) Benchmark - if disabled, do not use the SSE benchmark.

Enable SSE2 (Integer) Benchmark - if disabled, do not use the SSE2 benchmark.

Enable SSSE3 (Integer) Benchmark - if disabled, do not use the SSSE3 benchmark.

Enable SSE (Float) Benchmark - if disabled, do not use the SSE benchmark.

Enable SSE2 (Float) Benchmark - if disabled, do not use the SSE2 benchmark.

Enable SMT/HyperThreading Benchmark - enable SMT support in harness.

Include CPU MSR Information - get CPU info by MSR.

Enable Parallel Execution - enable PE support in harness.

Include Performance Enhancing Tips - if disabled, do not display any tips.

Tips

Tips (Performance) List


Network Bandwidth Benchmark

Benchmark the network bandwidth of your computer. Shows how your networks/LANs and hosts/devices on i compare to other networks, hosts or devices.

The test uses the ICMP (ping/echo) interface to measure the response time and transfer bandwidth to a host.

  • Test takes about 10 seconds on P6-class machines with 10Mbps network adapters.
  • Command Line Switch: LANBwBench
  • Requirements: TCP/IP protocol installed and bound to Microsoft Client/Sharing services, WinSock v2
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win32 CE) Support: Windows Mobile 2003/SE, 5
  • OS (Win64) Support: Windows XP/2003

Explanations

See Network Information or Winsock Information topics for more information.

See also Questions and Answers document for full information.

See List of Acronyms for more information.

Options

Include Ping Information - use ping to query host for connection status.

Include Transfer Information - show transfer statistics.

Include IPX/SPX Information - query host through IPX/SPX if installed.

Include All Domains/Workgroups Information - if disabled, query only current domain/workgroup.

Include Performance Enhancing Tips - if disabled, do not display any tips.

Acknowledgements

See Acknowledgements topic for more information.

Tips

Tips (Performance) List


Mobile Device Transfer Benchmark

Shows how the connection between your computer and your mobile device compares (speed and latency wise) with other devices.

Mobile devices have greatly increased in popularity as users are searching for small, multi-purpose devices to hold their calendar, e-mails, music, pictures, videos and even documents. As the amount of memory on devices increases and the data transfered or synchronised increases, the speed of transfer becomes important.

As with many tests there are other external factors that may effect the results and may cause a repeat test to produce a slight difference these include but are not limited to connection interface or controller.

Note: All reference results have been made using an Intel EHCI USB controller (USB 2.0).

  • Test needs a minimum free space of 16MB with the optimal free space being 50MB on the device to be tested.
  • Please ensure that any important information is backed up on the device prior to starting the test.
  • If the device to be tested requires a specific interface port then this is required i.e. USB 2.0 for a USB 2.0 device.
  • Test takes about 5 minutes on P6-class machines to a PDA with 64MB memory.
  • Command Line Switch: PdaBench
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win32 CE) Support: Windows Mobile 2003/SE, 5
  • OS (Win64) Support: Windows XP/2003

Explanations

The typical usage model for data transfer is file operations, such as writing a file to the device, reading a file from it, and deleting a file. This benchmark exercises the devices in terms of these operations.

The following characteristics are measured for each of the four representative files sizes of 512 Bytes (representing a minimal single data cluster file), 32kB, 256kB, 2MB and 64MB. The weighting of the results is not equal it represents the distribution of different files sizes as used on these devices (obtained through field research):

Read Performance: expressed both in terms of Operations per Minute (i.e. the number of files read per minute) and the corresponding net transfer rate in kB/second.

Write Performance: similarly expressed both in terms of Operations per Minute (i.e. the number of files written in a minute) and the corresponding net transfer rate in Kbytes/second.

Delete Performance: measuring the number of files deleted per minute.

For each of the four file sizes a Combined Index is then calculated, stating the combined performance in terms of Combined Operations Per Second, with respect to a mix of write, read and delete operations.

Combined Device Index: is a composite figure representing an overall performance rating based on the average of the Combined Index figures over the four file sizes. (Higher is better, i.e. better performance)

The in the graphical window the Combined Index (y axis) is plotted as a function of the file size (x axis). The y axis can be toggled between linear and logarithmic scale. Please note that the x axis scale is non-linear and somewhat distorted for ease of comprehension. The chart is intended for easy to use “one-glance” comparison, and it should NOT to be used for data readout.

Average latency: expressed in ms, denotes the average time to call a function on the device with no data sent and no data received (save the status of the call itself). This represents the overhead of calling functions on the device without any data transfer which measures the latency of both the connection (e.g. USB(2), Wi-fi, Bluetooth, etc.)

See also Questions and Answers document for full information.

See List of Acronyms for more information.

Acknowledgements

See Acknowledgements topic for more information.

Options

This module has no options to set.

Tips

Tips (Performance) List


Physical Disks

Benchmark hard disks (i.e. the disk itself, not the file system). Shows how your physical disks connected to the storage adapters or hosts compare to other disks in a typical computer.

As the test measures raw performance it is independent on the file system the disk uses and any volumes mounted off the disk.

  • Read Test: Sequential across disk
  • Write Test: Sequential across disk
  • Seek Test: random, full stroke

Test takes about 5 minutes on P6-class machines with ATA100 HDs.

Drive Index: is a composite figure representing an overall performance rating based on the highest read or write speed across the whole disk. Thus the higher the better.

Access Time: is the average time to read a random sector on the disk, analogous to latency response time. Thus the lower the better.

  • Command Line Switch: DiskBench
  • Requirements: Empty disk for write test
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win64) Support: Windows XP/2003

Explanations

See Drives Information topic for more information.

See also Questions and Answers document for full information.

See List of Acronyms for more information.

Options

Bypass Windows Cache - use write-through mode to bypass cache. If disabled, use normal mode.

Include Extra Disk Information - show some more information about the drive.

Include Performance Enhancing Tips - if disabled, do not display any tips.

Acknowledgements

See Acknowledgements topic for more information.

Tips

Tips (Performance) List


Power Management Efficiency

Benchmark the power management efficiency of the processors. Shows how efficient the power management of your processors is in comparison to other typical processors.

The ability of the processors to step-down in frequency and voltage at different workloads is measured. The more a processor steps down in both frequency and voltage the better the score at the specific workload. The test stops when the workload is too great the processor even at 100% efficiency.

The ALU/FPU score is a geometric mean based on the whole range of workloads; thus the power of the processors does matter in obtaining a higher score.

The Power Efficiency score is a geometric mean based on the supported workloads only. Thus the power of the processors does not matter.

  • Multi-Processor (SMP) support for up to 32/64 CPUs & SMT.
  • Test takes about 5 minutes on P4-class PCs.
  • Command Line Switch: CPUPowerBench
  • Requirements: Mobile version of processor
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win32 CE) Support: Windows Mobile 2003/SE, 5
  • OS (Win64) Support: Windows XP/2003

Explanations

  • MP Dhrystone (MIPS) CPU (Arithmetic) Benchmark
  • MP Whetstone (MFLOPS) FPU (Floating Point) Benchmark

See Computer (CPU/Bus/BIOS/Chipset) Information topic for more information.

See also Questions and Answers document for full information.

See List of Acronyms for more information.

Acknowledgements

Original Idea by Ronen Z.

Power Management harness - by C. Adrian Silasi.

See Acknowledgements topic for more information.

Options

Include Extra System Information - show some more details about tested system.

Enable MP/MT Benchmarks - if disabled, run single-threaded even on MP systems.

Include DMI/SMBIOS Information - query the system through the DMI/SMBIOS interface.

Enable SMT/HyperThreading Benchmark - enable SMT support in harness.

Include CPU MSR Information - get CPU info by MSR.

Include Performance Enhancing Tips - if disabled, do not display any tips.

Tips

Tips (Performance) List


2D and 3D Video

This module is deprecated, i.e. it has been removed. A meaningful 3D benchmark in the current environment is beyond the scope of this software.

Acknowledgements

See Acknowledgements topic for more information.

Options

No options.

Tips

Tips (Performance) List


Dump Registry Settings

Dump the registry settings for installed devices, programs and applications.

  • Command Line Switch: DumpRegistry
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win64) Support: Windows XP/2003

Options

This module has no options to set.

Tips

Tips (Performance) List


Dump Hardware Registers

Dump the hardware registers of CPUs, BIOS, CMOS, NVRAM, PCI(e), AGP and SMBus/i2c devices.

  • Command Line Switch: DumpHWRegs
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win64) Support: Windows XP/2003

Options

This module has no options to set.

Tips

Tips (Performance) List


Physical Disks

Information about the ATA, ATAPI, SATA physical disks connected to your computer.

  • ATA/SATA Controller Information
  • ATA/ATAPI Device Information
  • Device State Information
  • Command Line Switch: Disks
  • Requirements: ATA/SATA Controller, devices and 32/64-bit drivers.
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win64) Support: Windows XP/2003

Explanations

See List of Acronyms for more information.

Options

Include ATA/SATA Devices Information - query ATA/SATA devices.

Include ATAPI Devices Information - query ATAPI devices.

Include Hosts Information - query the controller.

Include Transfer Mode(s) Information - show the transfer mode(s) supported and enabled.

Include SMART Information - show SMART details.

Include SMART Data Information - show the drive’s SMART parameters.

Include Temps, Fans and Voltages Information - query the environment monitor for temperature, cooling and voltage sensors.

Include Performance Enhancing Tips - if disabled, do not display any tips.

Tips

Tips (Performance) List


Mainboard Configuration

Information about your computer's BIOS and configuration settings sored in the CMOS or NVRAM.

  • System BIOS Information
  • BIOS Properties
  • Time, Date, Alarm
  • System Status
  • Equipment Installed
  • Floppy Disks and Hard Disks
  • Memory Size & Type
  • Command Line Switch: BIOS
  • OS (Win32) Support: Windows 2000, XP, 2003

Explanations

This information is only useful to programmers and therefore is beyond the scope of this document. You can get information about this settings from your BIOS manual or an advanced computer book that deals with this topic.

See List of Acronyms for more information.

Options

This module has no options to set.

Tips

Tips (Performance) List


Processors

Information about the your computer's processors CPU(s), FPU(s), cache(s) and other related devices.

  • CPU/FPU Information & Performance Rating(s)
  • CPU Upgrading Information
  • CPU Settings
  • CPU Health Monitoring
  • Command Line Switch: CPU
  • Requirements: Modern BIOS, CPU, Bus
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win32 CE) Support: Windows Mobile 2003/SE, 5
  • OS (Win64) Support: Windows XP/2003

Explanations

Please see individual tips for explanations.

See List of Acronyms for more information.

Options

Include DMI/SMBIOS Information - query the DMI/SMBIOS hive of the system.

Include System BIOS Information - query the BIOS of the system.

Include System BIOS Properties Information - show the characteristics of the BIOS.

Include CPU Information - show information about the CPU model.

Include CPU Socket Information - show upgrading information, i.e. about the CPU Socket.

Include CPU Feature Flags Information - show the features supported by the CPU.

Include Temps, Fans and Voltages Information - query the environment monitor for temperature, cooling and voltage sensors.

Include CPU(s) MSR(s) Information - query the CPU by accessing its MSRs.

Include Advanced CPU Information - show specific CPU status/settings.

Include CPU(s) EEPROM(s) Information - query the CPU by accessing its EEPROMs.

Use temperature compensation for external sensors - add temperature compensation for the external temperature sensors.

Include CPU Serial Number Information - show the CPU’s serial numbers.

Include System Bus(es) Information - query the buses on the system.

Include CPU Micro-Code Information - show CPU micro-code properties.

Enable Disabled HW Monitors - enable the environment monitors if they are not enabled.

Ignore Disabled Hosts - if disabled, attempt to enable the controllers.

Detect Bus Multiplexors - if enabled, attempt to detect and enable any bus multiplexors.

Include CPU MTRR Information - show memory type range registers settings.

Include CPU PAT Information - show page attribute table settings.

Use bridges by PCI-to-PCI bridge configuration - get no/type of busses through bridges; otherwise get through OS.

Include Performance Enhancing Tips - if disabled, do not display any tips.

Tips

Tips (Performance) List


Services and Drivers

Information about the services and other device drivers installed on your computer.

  • Service/Device Driver Information
  • Service/Device Driver Configuration Information
  • File Information
  • Command Line Switch: Services
  • Requirements: services and device drivers.
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win32 CE) Support: Windows Mobile 2003/SE, 5
  • OS (Win64) Support: Windows XP/2003

Explanations

See List of Acronyms for more information.

Name - the registered unique name of the service

Full Name - the description of the service

Type - the type of service (process) device driver (kernel driver)

File Name - the full file name and parameters of the service

Current Status - whether the service is active or not

Start-up Type - how does the service start and stop

Error Control - how the service reports errors

Dependencies - the services this service needs in order to operate

Log on As - the user under which the service runs

File Information - the process file name, properties and information.

Options

Include Windows Services Information - query the Windows services.

Include Device Drivers Information - query device drivers.

Include Active Services Information - query only the active services/device drivers.

Include Inactive Services Information - query only the inactive services/device drivers.

Include Service File Information - query the service’s file.

Include Performance Enhancing Tips - if disabled, do not display any tips.

Tips

Tips (Performance) List


DirectX

Information about the DirectX interface (display, sound, music, input, network) and other devices installed in your computer.

  • DirectDraw Video Devices Information
  • Direct3D Hardware 3D Accelerators Information
  • DirectSound Sound Card Information
  • DirectSound Capture (Emulation) Information
  • DirectMusic Information
  • DirectPlay Connections Information
  • DirectInput Interface Information
  • Command Line Switch: DirectX
  • Requirements: DirectX drivers installed
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win32 CE) Support: PocketPC 2002/2003, SmartPhone 2002, 2003
  • OS (Win64) Support: Windows XP/2003

Explanations

DirectX - Microsoft developed DirectX so that the performance of applications running in the Windows operating system can rival or exceed the performance of applications running in the MS-DOS operating system or on game consoles. Developers of these games had to conform to a number of hardware implementations for a variety of cards. With DirectX, games developers get the benefits of device independence without losing the benefits of direct access to the hardware. The primary goals of DirectX are to provide portable access to the features used with MS-DOS today, to meet or improve on the performance of MS-DOS console-based applications, and to remove the obstacles to hardware innovation on the personal computer. Additionally, Microsoft developed DirectX to provide Windows-based applications with high-performance, real-time access to available hardware on current and future computer systems. DirectX provides a consistent interface between hardware and applications, reducing the complexity of installation and configuration and using the hardware to its best advantage. By using the interfaces provided by DirectX, software developers can take advantage of hardware features without being concerned about the implementation details of that hardware.

DirectDraw - is a software interface that provides direct access to display devices while maintaining compatibility with the Windows graphics device interface (GDI). It is not a high-level application-programming interface (API) for graphics. DirectDraw provides a device-independent way for games and Windows subsystem software, such as 3-D graphics packages and digital video codecs, to gain access to the features of specific display devices. DirectDraw works with a wide variety of display hardware, ranging from simple SVGA monitors to advanced hardware implementations that provide clipping, stretching, and non-RGB colour format support. The interface is designed so that applications can enumerate the capabilities of the underlying hardware and then use any supported hardware-accelerated features. DirectX emulates features that are not implemented in hardware.

Direct3D - Direct3D is designed to enable world-class game and interactive three-dimensional (3-D) graphics on a computer running Windows. Its mission is to provide device-dependent access to 3-D video-display hardware in a device-independent manner. Simply put, Direct3D is a drawing interface for 3-D hardware.

DirectSound - The Microsoft DirectSound application programming interface (API) is the audio component of the DirectX. DirectSound provides low-latency mixing, hardware acceleration, and direct access to the sound device. It provides this functionality while maintaining compatibility with existing device drivers.

DirectPlay - The Microsoft DirectPlay application programming interface (API) for Windows is a software interface that simplifies application access to communication services. DirectPlay has become a technology family that not only provides a way for applications to communicate with each other, independent of the underlying transport, protocol, or online service, but also provides this independence for matchmaking servers and game servers. Applications (especially games) can be more compelling if they can be played against real players, and the personal computer has richer connectivity options than any game platform in history.

DirectInput - Microsoft DirectInput provides support for input devices including the mouse, keyboard, and joystick, as well as for force-feedback (input/output) devices.

See List of Acronyms for more information.

Options

Include DirectDraw Information - query the DirectDraw Interface.

Include DirectDraw Capabilities Information - show the DirectDraw capabilities.

Include DirectDraw Video Modes Information - show supported video modes.

Include Direct3D Information - query the Direct3D Interface.

Include Direct3D Capabilities Information - show the Direct3D capabilities.

Include Direct3D Line Capabilities Information - show the Direct3D line capabilities.

Include Direct3D Triangle Capabilities Information - show the Direct3D triangle capabilities.

Include DirectSound Information - query the DirectSound interface.

Include DirectSound Capabilities Information - show the DirectSound capabilities.

Include DirectPlay Information - query the DirectPlay interface.

Include DirectPlay Capabilities Information - show the DirectPlay capabilities.

Include DirectSoundCapture Information - query the DirectSoundCapture interface.

Include DirectSoundCapture Capabilities Information - show the DirectSoundCapture capabilities.

Include DirectInput Information - query the DirectInput interface.

Include DirectInput Capabilities Information - show the DirectInput capabilities.

Include Texture Support Information - show the texture capabilities of Direct3D.

Include DirectMusic Information - query the DirectMusic interface.

Include DirectMusic Capabilities Information - show the DirectMusic capabilities.

Include Performance Enhancing Tips - if disabled, do not display any tips.

Tips

Tips (Performance) List


Logical Drives

Information about the drive(s) that are available to your computer: removable, local or remote.

  • Drive & Controller Information
  • Volume Information & Properties
  • Logical Drive Information
  • Disk Cache Information
  • Physical Drive Information
  • Extended Information
  • Partition Information
  • Drive Statistics & Slack Information
  • Command Line Switch: Drives
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win32 CE) Support: Windows Mobile 2003/SE, 5
  • OS (Win64) Support: Windows XP/2003

Explanations

Drive Class - the type of drive: floppy, fixed, CD-ROM, memory, etc.

Drive Device - the full name of the drive type.

Drive Type - extra type information about the drive, e.g. fixed drives can be ATA/ATAPI/SCSI/RLE, etc.

Disk Controller - the name of the disk controller the drive is attached to.

ATA Device Configuration - if the drive is ATA, whether this drive is a master or slave.

DMA Transfers Enabled - whether this drive uses DMA transfers or PIO. DMA is faster, especially if Ultra-DMA is supported.

Total Space - the total space on the drive in MB.

Free Space - the total amount of free space on the drive in MB.

Volume Name - the name of the drive label.

File System - the type of file system used by the drive, e.g. FAT, FAT32, NTFS, etc.

Serial Number - the drive’s serial number.

Maximum Filename Length - the maximum size a filename can have. Older drives allow only 11 (8.3) characters, while new ones support 255.

Preserves Filename Case - whether the filename case is preserved.

Supports Case Sensitive Search - whether filename case is important..

Supports Unicode Filenames - whether UNICODE is supported.

Supports Access Control Lists - whether access control security is supported.

Volume is Compressed - whether this drive is compressed.

Supports Individual File Compression - whether individual files or folders can be compressed.

Sectors Per Cluster - the number of sectors in one cluster.

Bytes Per Sector - the number of bytes in one sector. Usually this number is 512 bytes.

Cluster Size - the size of the cluster. This should be as low as possible to minimise wasted space.

Total Clusters - the total number of clusters on this drive.

Total Free Clusters - the total number of available clusters on this drive.

Current Disk Cache - the current size of the disk cache in MB. This should be as high as possible but not at the expense of system memory.

Maximum Disk Cache - the maximum size the disk cache can grow to.

Minimum Disk Cache - the minimum size the disk cache can shrink to.

Typical Role - the typical role of your computer. The disk cache is optimised according to this role.

Physical Drive ID - the physical disk ID number if ATA/RLE.

CMOS Disk No - the CMOS physical disk type. Drives no. 1-45 are pre-defined, while types 46 & 47 can be defined by user or auto-detected by the BIOS.

Cylinders - the number of cylinders of the physical disk.

Heads - the number of heads of the physical disk.

Sectors Per Track - the number of sectors in one track/cylinder.

Bytes Per Sector - the number of bytes in one sector. Usually this number is 512 bytes.

Cylinders - the number of cylinders belonging to this drive out of all the cylinders on the physical disk.

Heads - the number of heads belonging to this drive out of all the heads of the physical disk.

Sectors Per Track - the number of sectors in one track/cylinder.

Bytes Per Sector - the number of bytes in one sector. Usually this number is 512 bytes.

Copies of FAT - the number of FATs (File Allocation Table) the drive keeps. This number should be 2 (1 for backup) unless the drive is guaranteed not to fail (e.g. memory, CD-ROM).

Sectors Per FAT - the number of sectors that make up a FAT.

Media Descriptor - the media ID number for this drive.

Max. Root Entries - the maximum numbers of files & folders on the root of the drive.

Sectors Per Cluster - the number of sectors in one cluster.

Reserved Sectors - the number of sectors that are reserved (e.g. boot sector).

Hidden Sectors - the number of sectors that are hidden (e.g. partition info).

No. Files - the total number of files on this drive.

No. Folders - the total number of folders on this drive.

Space Used - the exact total space taken by the files and folders, not rounded.

Space Allocated - the actual total space taken by the files and folders, rounded to the cluster size.

Slack - the percentage of disk space wasted due to large cluster size. This number should be as small as possible, preferably under 10-20%.

Last Backup - the date you last backed up the drive. You should do it at least every week.

Last Scan - the date you last checked the drive for errors. You should do it at least every week.

Last Optimised - the date you last optimised the drive. You should do it at least monthly.

Last Image - the date you last imaged the drive. You should do it at least weekly.

See List of Acronyms for more information.

Options

Include General Drive Information - show generic information.

Include Volume Information - query the drive’s volumes.

Include Volume Properties Information - show volume properties.

Include Logical Drive Information - query the logical drive device.

Include Disk Cache Information - query the disk cache driver.

Include Physical Disk Information - query the physical disk of the drive.

Include Extended Drive Information - show the extended drive properties.

Include Drive Statistics Information - show the drive’s statistics.

Include Removable Drives Information - if disabled, ignore removable drives.

Include Fixed Drives Information - if disabled, ignore fixed drives.

Include Memory Disks Information - if disabled, ignore memory disks.

Include Network Drives Information - if disabled, ignore network drives.

Include CD-ROM/DVD Information - if disabled, ignore CD-ROM/DVD drives.

Include Performance Enhancing Tips - if disabled, do not display any tips.

Tips

Tips (Performance) List


Fonts

Information about the fonts and font systems current installed in your computer.

  • Font Class & Type
  • Font Script (language)
  • Logical Font Attributes
  • Physical Font Attributes
  • Command Line Switch: Fonts
  • Requirements: None
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win32 CE) Support: Windows Mobile 2003/SE, 5
  • OS (Win64) Support: Windows XP/2003

Explanations

Font - A collection of characters and symbols that share a common design.

Font Family - One of two attributes used to organise OpenType fonts. Family names include Courier New, Arial, and Times New Roman.

Font Style -One of two attributes used to organise OpenType fonts. Style names include extra-bold, bold, and italic.

Font Mapper - An algorithm that Windows uses to determine which available font most closely matches a requested font.

OpenType Font - A font whose glyphs are stored as a collection of line and curve commands plus a collection of hints. Windows uses the line and curve commands to define the outline of the glyph's bitmap. Windows uses the hints to adjust the length of the lines and shapes of the curves. These hints and the respective adjustments are based on the amount of scaling used to reduce or increase the size of the bitmap.

Height - Specifies the height, in logical units, of the font’s character cell or character. The character height value is the character cell height value minus the internal-leading value.

Ascent - Specifies the ascent (units above the base line) of characters.

Descent - Specifies the descent (units below the base line) of characters.

Escapement - Specifies the angle, in tenths of degrees, between the escapement vector and the x-axis of the device. The escapement vector is parallel to the base line of a row of text.

Orientation - Specifies the angle, in tenths of degrees, between each character’s base line and the x-axis of the device.

Width - Specifies the average width, in logical units, of characters in the font.

Internal Leading - Specifies the amount of leading (space) inside the bounds set by the height. Accent marks and other diacritical characters may occur in this area.

External Leading - Specifies the amount of extra leading (space) that the application adds between rows.

Weight - Specifies the weight of the font in the range 0 through 1000. For example, 400 is normal and 700 is bold.

Pitch - Specifies whether all the characters have the same width or different widths.

Recommended Aspect Ratio - The aspect ratio of the device for which the font was designed.

See List of Acronyms for more information.

Options

Include Raster Fonts Information - query raster/display fonts.

Include Vector Fonts Information - query vector fonts.

Include OpenType Fonts Information - query OpenType fonts.

Include Logical Font Information - show the logical font properties.

Include Physical Font Information - show the physical font properties.

Include Performance Enhancing Tips - if disabled, do not display any tips.

Tips

Tips (Performance) List


IP Network

Information about the workstation(s) and server(s) on the IP network(s) your workstation is connected to.

  • Interfaces
  • List of Hosts
  • Host Information
  • IP Services of each Host
  • Command Line Switch: IPNetwork
  • Requirements: TCP/IP protocol installed, WinSock v2.
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win32 CE) Support: Windows Mobile 2003/SE, 5
  • OS (Win64) Support: Windows XP/2003

NB. Since this module scans the entire IP range of the host’s interface and pings each address in turn, it may take some time to execute. Please allow it plenty of time before giving up.

Explanations

IP Address - the IP address of the host

Host Name - the DNS name of the host

IP Services List - the list of IP supported services

Options

Include Point-to-Point Networks Information - if disabled, do not query PTP networks.

Include IP Services Information - query the host for active IP services.

Include SNMP Information - query host through the SNMP interface.

Assume all hosts are on Local LAN - if disabled, increase discovery/ping timeout by 10.

Include Network Adapter(s) Information - show network adapters details.

Include Performance Enhancing Tips - if disabled, do not display any tips.

Tips

Tips (Performance) List


Game Controllers

Information about the game controller(s) connected to your computer and the game controller driver software.

  • Game Controller Driver Characteristics
  • Game Controller General Characteristics
  • Game Controller Current Status Information
  • Game Controller Calibration Settings
  • Command Line Switch: Joysticks
  • Requirements: Joystick, game-pad, game port and joystick driver
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win64) Support: Windows XP/2003

Explanations

Name - the name and make of the game controller.

Manufacturer - the manufacturer of the game controller driver.

Driver ID - the filename of the joystick driver.

Support - the maximum number of game controllers supported by the driver.

Buttons - the number of buttons on the game controller.

Z-Coordinate - the game controller supports depth.

Rudder - the game controller supports rudder style use.

U-Coordinate - the game controller supports U-axis.

V-Coordinate - the game controller supports V-axis.

Point-Of-View - the game controller supports point-of-view hat or mode.

Continuous Degree Bearings - the game controller supports rotation.

State - specifies whether the device is plugged-in or not.

Min/Max X-Position - the range of values possible for X-axis.

Min/Max Y-Position - the range of values possible for Y-axis.

Min/Max Polling Interval - the range of time intervals the device can be polled at. This determines the responsiveness of the controller.

Options

Include Game Controller Driver Information - query the controller driver.

Include Game Controller Device Information - query the game device.

Include Game Controller Status Information - query for the status of the device.

Include Calibration Information - show the calibration device settings.

Include Performance Enhancing Tips - if disabled, do not display any tips.

Tips

Tips (Performance) List


Keyboards and Tablets

Information about the keyboards, tablets and other primary input devices connected to your computer.

  • Keyboard Information
  • Keyboard Driver Information
  • Configuration Settings
  • Accessibility Features
  • Command Line Switch: Keyboard
  • Requirements: Keyboard present
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win64) Support: Windows XP/2003

Explanations

Type - the name and type of the keyboard.

Type/Sub Type - the hardware type and sub-type assigned to this type of keyboard.

Function Keys - the number of function keys available on the keyboard. Modern keyboards have 12 function keys, F1 to F12.

Intercept Support - whether the keyboard controller supports a special function used to change various settings.

Get/Set Typematic Rate - an enhanced functionality of some keyboards. This enables you to modify the Repeat Speed and Repeat Delay. These two variables can be changed usually from the BIOS.

Keyboard Controller - the controller built-in your keyboard. Usually this is an Intel 8042 or compatible. However, some keyboards may have different controllers that support different functions.

Layout ID - the ID number assigned to this keyboard layout.

Layout Type - the country this keyboard was designed for.

Driver ID - the filename of the keyboard driver.

Version - the version of the keyboard driver.

Code Page - the code page the keyboard uses. Code pages specify characters used by different countries.

Repeat Delay - shows how long the computers waits after you press and hold down a key. For example 2 is a medium repeat delay (nearly the default) while 0 is fast, i.e. the computer will not wait at all.

Repeat Speed - shows how fast a key repeats when you press and hold it down. Roughly it means characters/second. For example 16 is a medium repeat speed; 22 is fast where 9 is slow

Accessibility Features - various settings used to make Windows more accessible for disabled users. Must be installed and configured specifically.

See List of Acronyms for more information.

Options

Include Accessibilities Features Information - query the accessibility features driver.

Include Performance Enhancing Tips - if disabled, do not display any tips.

Tips

Tips (Performance) List


Mainboard

Information about your computer's mainboard, chassis, chipset(s), bus(es), system memory(es), cache(s) and other related devices.

  • System information
  • Chassis information
  • Mainboard information
  • Multi-processor information
  • Chipset information
  • Memory controller(s) & banks information
  • Memory modules information
  • Buses information
  • Expansion slots & ports information
  • System health & monitoring information
  • System clock information
  • Command Line Switch: Mainboard
  • Requirements: Modern BIOS (SMBIOS/DMI 2.0+)
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win64) Support: Windows XP/2003

Explanations

Please see individual tips for explanations.

See List of Acronyms for more information.

Options

Include System Information - show information about the whole system.

Include Chassis Information - show information about the system’s chassis.

Include Main board Information - show information about the installed main board.

Include Memory Controller Information - query the memory controller of the system.

Include Chipset Information - query the system chipset.

Include Memory Slots Information - query the memory slots and show what’s installed in them.

Include System Bus(es) Information - query the buses on the system.

Include DMI/SMBIOS Information - query the DMI/SMBIOS hive of the system.

Include Expansion Slots Information - query the expansion slots and show what’s installed in them.

Include Port Connectors Information - query what ports the main board has.

Include On-Board Devices Information - query what on-board devices are installed.

Include Temps, Fans and Voltages Information - query the environment monitor for temperature, cooling and voltage sensors.

Include CPU(s) MSR(s) Information - query the CPU by accessing its MSRs.

Include Memory Module SPD Information - query the memory modules by accessing their EEPROM SPD.

Include CPU(s) EEPROM(s) Information - query the CPU by accessing its EEPROMs.

Use temperature compensation for external sensors - add temperature compensation for the external temperature sensors.

Include PLL IC Information - query the Programmable Clock Generator of the main board.

Ignore Unknown PLL IC - do not query PLL IC if it is not supported.

Auto-detect PLL IC - attempt to detect what PLL IC is installed.

Enable Disabled HW Monitors - enable the environment monitors if they are not enabled.

Ignore Disabled Hosts - if disabled, attempt to enable the controllers.

Detect Bus Multiplexors - if enabled, attempt to detect and enable any bus multiplexors.

Include IRQ APIC Information - query the system APIC if enabled.

Include X-Bus LPC Information - detect the legacy X-Bus and legacy LPC.

Include (S)MP Information - show MP system information (MP systems).

Use bridges by PCI-to-PCI bridge configuration - get no/type of busses through bridges; otherwise get through OS.

Include Performance Enhancing Tips - if disabled, do not display any tips.

Tips

Tips (Performance) List


Media Devices (MCI)

Information about the Media Control Devices (MCI) registered and active in your computer.

  • AVI, MPEG, VideoCD, Motion Video
  • Animation
  • Video Cassette Recorder (VCR)
  • Laser Disc
  • Wave Audio
  • MIDI Sequencers
  • CD Audio
  • Command Line Switch: MCInfo
  • Requirements: Multimedia drivers installed
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win64) Support: Windows XP/2003

Explanations

MCI - Media Control Devices are device drivers that handle various aspects of the Windows system by providing a simple generic interface that lets you play multimedia files (audio, video, animation, MIDI, etc.). Sandra cannot (sometimes) detect devices released after this release of Sandra! Update your copy of Sandra if this happens.

Name - the name and make of the device.

Type - the type of device.

Alias - the shortened name that uniquely identifies this device.

Full Name - the complete name and interface type of this device.

Driver ID - the file name of the device driver.

Version - the version of the device driver.

Device Capabilities - lists the various generic functions the device supports. This depends on the type of device. A device does not need to support all the functions, some are not required. The performance has nothing to do with the number of functions supported - only usability is affected.

Specific Device Capabilities - lists the various specific functions the device supports. This depends on the type of device. A device does not need to support all the functions, some are not required. The performance has nothing to do with the number of functions supported - only usability is affected.

See List of Acronyms for more information.

Options

Include Device Capabilities Information - show the capabilities of the MCI device.

Include Performance Enhancing Tips - if disabled, do not display any tips.

Tips

Tips (Performance) List


Communication Devices

Information about the communication devices (modems / terminal adapters) connected to your computer.

  • General Device Information
  • Modem Driver Settings
  • Built-in Modem Information
  • Connection Test
  • Command Line Switch: Modems
  • Requirements: Modem or terminal adapter installed
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win32 CE) Support: Windows Mobile 2003/SE, 5
  • OS (Win64) Support: Windows XP/2003

Explanations

Manufacturer - the modem manufacturer.

Modem - the type and name of the modem.

Serial Number - the modem driver serial number.

Plug & Play Version - the version of the PnP standard the modem adheres to.

Port - the port ID the modem is connected to.

Port Configuration - the settings used as default for the port. Do note that modems and other hardware using the port re-configure these settings when they become active, so this list if just a guideline.

Modem Information - the actual modem information and configuration.

Name & Type - the name of the modem manufacturer and type.

Plug & Play ID - the unique ID number for this modem.

Configuration Settings - the list of current modem settings.

Product Code - the modem product code. This is a unique number for this model that may be required by technical support staff.

Memory Checksum - the result of the memory checksum.

Self-Diagnostic Result - the result of self-diagnostic tests. This should be OK.

Modem Settings - the current configuration including internal registers.

NVRAM Settings - the settings stored in modem’s NVRAM (Non-Volatile RAM).

Diagnostics Results - the result of self-diagnostic tests.

Dialling Information - information about the dialled numbers, errors, time connected, etc.

Link Diagnostic Results - information about the modem to modem connection.

FAX Classes - the classes supported by this modem. Most modems should support classes 1.0 and 2.0.

Connection Test - the result of the loop-back connection test.

See List of Acronyms for more information.

Options

Include Performance Enhancing Tips - if disabled, do not display any tips.

Tips

Tips (Performance) List


Modules

Information about the modules loaded in your computer. Tasks, processes, drivers, libraries, etc. and modules themselves.

  • Libraries (DLL, OCX, etc.)
  • Processes (EXE)
  • Device Drivers (DRV)
  • Command Line Switch: Modules
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win32 CE) Support: Windows Mobile 2003/SE, 5
  • OS (Win64) Support: Windows XP/2003

Explanations

File Name - the module file name.

Module Usage - the number of processes and modules that use this module.

Expected Windows Version - the version of Windows this process was designed for. For Windows 9X/Me/NT4 this number should be 4.0. For Windows 2000, XP, 2003 this number should be 5.0.

Module is a Library - whether the module is a library or not.

Module Type - whether this module is 64, 32 or 16-bit.

Self-Loading Module - whether this module is loaded by Windows by default.

Implicit-Loading Module - whether this module is implicitly loaded by Windows.

Module Has Shared Data - whether this module uses shared data.

Module Has Auto Data - whether this module uses automatic data.

File Information - the module file name, properties and information.

See List of Acronyms for more information.

Options

Include Module Information - query the module itself.

Include Module Usage Information - show module usage by this module.

Include Heaps Information - show module’s heaps.

Include File Information - query file of the module.

Include Performance Enhancing Tips - if disabled, do not display any tips.

Tips

Tips (Performance) List


Mice and Track-balls

Information about the mice, track-balls, pens and pointing devices connected to your computer.

  • Mouse Information
  • Mouse Driver Information
  • Configuration Settings
  • Windows for Pens Support
  • Accessibility Features
  • Command Line Switch: Mouse
  • Requirements: Mouse or pen present
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win64) Support: Windows XP/2003

Explanations

Name - the type and make of the mouse.

Buttons - the number of buttons the mouse has and is supported by the mouse driver.

Type - the way the mouse is connected to the PC. Most mice today are PS/2 type, but there are also USB, Serial and Bus mice.

Port - the port the mouse is connected to.

Interrupt - if the mouse requires a specific interrupt, the number of the hardware interrupt used by the mouse.

COM Port Address - if the mouse is connected through a serial (COM) port, the hardware address of the I/O ports used by the serial port.

Plug & Play Version - the version of plug & play the mouse supports.

Driver ID - the filename of the mouse driver.

Version - the version of the mouse driver.

Button Configuration - specifies whether the user uses the mouse with the right or the left hand.

Pointer Trails - specifies whether the pointer trails are active. Pointer trails improve mouse pointer visibility on laptop displays.

Tracking Speed - the index of tracking speed.

X/Y Threshold - the X/Y-axis movement threshold, i.e. no of units of movement that the mouse must be moved in order to register a movement.

Double Click Speed - the maximum time between 2 mouse clicks that are taken to represent a double-click instead of 2 separate clicks.

Accessibility Features - various settings used to make Windows more accessible for disabled users. Must be installed and configured specifically.

See List of Acronyms for more information.

Options

Include Accessibilities Features Information - query the accessibility features driver.

Include Performance Enhancing Tips - if disabled, do not display any tips.

Tips

Tips (Performance) List


Network (LAN)

Information about the networks your computer is connected to and the network resources available to you.

  • List of Networks
  • List of Domains/Workgroups
  • Network Information
  • Network Protocols
  • Workstation Information
  • Resources Information
  • Command Line Switch: LAN
  • Requirements: TCP/IP protocol installed and bound to Microsoft Client/Sharing services.
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win32 CE) Support: Windows Mobile 2003/SE, 5
  • OS (Win64) Support: Windows XP/2003

Explanations

Network Version - the version of the network driver for this type of network.

Network Status - the current status of the connection to this network. Usually this should be running.

Network Driver - whether the network driver is 16/32/64-bit.

Network Protocols - the list of all networking protocols supported by your computer.

Capabilities - the list of supported capabilities for each protocol. Some protocols guarantee delivery, support compression, encryption, broadcasting, fragmentation, etc.

Workstations - the list of all workstations in this network workgroup/domain, including its name, type and list of resources available.

IP Address - the TCP/IP address of the workstation.

MAC Address - the MAC (e.g. Ethernet) address of the workstation.

Folders - the list of all shared drives or folders for this workstation.

Printers - the list of all shared printers for which this workstation acts as a print server.

See List of Acronyms for more information.

Options

Include All Domains/Workgroups Information - if disabled, query only current domain/workgroup.

Include Connection/Link Information - query the link layer for connection statistics.

Include IP Services Information - query the host for active IP services.

Include SNMP Information - query host through the SNMP interface.

Include Server Information - query host for active server services.

Include Hidden Resources Information - show hidden server resources.

Include Open Files/Resources Information - show open files and taken resources.

Include Network Adapter(s) Information - show network adapters details.

Include Performance Enhancing Tips - if disabled, do not display any tips.

Tips

Tips (Performance) List


Data Sources

Information about the (ODBC) data sources set-up on your computer and the database drivers installed.

  • ODBC Settings
  • Supported ODBC Functions
  • Supported ODBC Data Types
  • Tables & Views in Database (full description)
  • Procedures & Functions in Database (full description)
  • Command Line Switch: ODBC
  • Requirements: ODBC version 3.50 or higher
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win64) Support: Windows XP/2003

Explanations

Settings - complete list of ODBC parameters and their current settings. Please refer to ODBC v3 documentation for more information on the parameters and the values; a list and explanation is beyond the scope of this document.

Function Conformance - the current status of the function in v3 ODBC.

Function Support - whether the data source supports the function in question.

Data Type - name, type, precision, characteristics of each supported data type.

Tables/Views - type, permission, list of fields and their name, type, comments.

Procedures/Functions - type, permission, list of parameters and their name, type, comments.

Options

Include System Data Sources - list system data sources.

Include User Data Sources - list user specific data sources.

Include ODBC Information - list ODBC parameters and their values.

Include Supported ODBC Functions Information - show list of supported functions.

Include Supported ODBC Types Information - show list of supported data types.

Include Table/Views Information - show list of tables & views.

Include Procedures/Functions Information - show list of procedures & functions.

Ask for Login to Connect in Display Mode - ask user to login if cannot connect using current/default credentials.

Include Performance Enhancing Tips - if disabled, do not display any tips.

Tips

Tips (Performance) List


Components and Objects

Information about the ActiveX/OLE objects registered. These are the objects that you can embed in a document for example.

  • OLE Object Information
  • OLE Server Information
  • Command Line Switch: OLE
  • Requirements: OLE servers installed
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win32 CE) Support: Windows Mobile 2003/SE, 5
  • OS (Win64) Support: Windows XP/2003

Explanations

OLE - or Object Linking & Embedding is a method of exchanging information between running applications. You can create a document that includes information such as charts, graphics, and spreadsheet data created by other applications. You can embed objects created by applications that support Windows and object embedding. You must have enough memory to run all of the applications you are using at once. All the information used to create the object is kept with the document that contains it. To edit the object, you simply select it. The server is started so you make the editing or formatting changes you want. When you switch back, the object is updated with the changes you made.

Class ID - the ID number that identifies this OLE server.

Object ID - the ID name (or nickname) that identifies this OLE server.

DDE Suport - DDE or Dynamic Data Exchange is a set of procedures that are used by applications to communicate with one another using defined protocols that may not be application specific. Information contained in a document created by another application, for example, can be updated automatically when it changes - ensuring information synchronisation. Here, it means that the server has defined the DDE commands that can be used to communicate with it. The available commands vary from application to application, but there is a set of main functions.

Insertable - specifies whether the object can be inserted (as a container) in an OLE client.

OLE 2 Object - specifies whether the server supports the OLE 2.0 standard which enables in-situ editing of objects, i.e. the server application takes over the client application - which makes easier editing. All new Software Suites support this for better integration

Server Application Information - the server file name, properties and information.

See List of Acronyms for more information.

Options

Include Legacy Objects Information - query legacy (OLE1) objects.

Include Server File Information - query file of the object server.

Include Server Application Information - show OLE server details.

Include Performance Enhancing Tips - if disabled, do not display any tips.

Tips

Tips (Performance) List


OpenGL Information

Information about OpenGL 2D & 3D graphics support of your computer.

  • Video board/driver manufacturer
  • Video renderer information
  • OpenGL Extensions Supported
  • Command Line Switch: OpenGL
  • Requirements: OpenGL compatible board
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win64) Support: Windows XP/2003

Explanations

OpenGL - is an industry standard 2D & 3D rendering only graphics interface, vendor and operating system independent. It is highly versatile, and includes support for all advanced features (texture mapping, fog, alpha blending, motion blur, etc.) as well as the standard functions any graphics interface needs to contain. It has been integrated in Windows NT/2000/XP/2003 although a OpenGL ICD/MCD is needed for best performance.

OpenGL Extensions - a mechanism that allows vendors to add additional capabilities to the implementation that can be used by programs to access performance and technological innovations.

Manufacturer - the company that wrote the OpenGL renderer (i.e. OEM maker).

Renderer - the type of renderer, generally video board name.

Version - full version of renderer.

Acceleration - whether the OpenGL driver is hardware accelerated.

Options

This module has no options to set.

Tips

Tips (Performance) List


Buses and Devices

Information about the devices and cards connected to the PCI(e), AGP, PC-Card buses of your computer.

  • PCI, AGP, CardBus, PCMCIA Bus Interface Information
  • Device Information & Capabilities
  • Command Line Switch: Buses
  • Requirements: PCI, AGP, CardBus system, version 2.00 or higher
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win64) Support: Windows XP/2003

Explanations

Interface Version - the version of the PCI standard this implementation complies with. However, while the 2.20 specifications include 66MHz support this does not mean that 2.20 compliant buses and adapters will actually run at 66MHz. Similar for other features. Also, note that ALL adapters must support a feature for it to be enabled, so don’t use very old cards.

Windows Device Name - the name of the device Windows thinks this device is. This is the name of the product and not the name of the actual chipset/device. Same device sold by multiple vendors may use different names and different drivers.

OEM Device Name - the real name of the chipset/device. This includes the name of the real manufacturer (OEM) and not that of the re-seller. This determines the driver used for this device by Windows. Sandra cannot detect devices released after this release of Sandra! Update your copy of Sandra if this happens.

Hardware ID - the unique PCI identifier for this device. No two different devices have the same id. Every new PCI device/chipset must be registered with the PCI Standards Organisation and assigned a unique id.

Product Device Name - the name of the product and that of the product manufacturer. This should tally with the Windows Device Name unless you’re using different drivers. This was introduced to differentiate between products using the same chipset. Sandra cannot detect devices released after this release of Sandra! Update your copy of Sandra if this happens.

Product Hardware ID - the unique PCI identifier for this device. No two different devices have the same id. Every new PCI device/chipset must be registered with the PCI Standards Organisation and assigned a unique id.

Revision - the revision of the device (silicon mask version). 0 means the very first version. Usually, later versions contain bug fixes and maybe performance enhancements.

AGP Version - the version of the AGP standard the device complies with. The latest is 2.00.

Command Queue Length - the length of the command queue determines the number of outstanding requests that can be buffered. The more commands buffered the more time the CPU has to do other work - while the AGP device is busy.

Side Band Addressing Support - whether the device supports side banding. It allows the overlapping of commands and data and thus improving performance.

Data Transfer Support - all AGP devices must support 1x. This mode is similar to the PCI data mode. Advanced AGP devices support 2x or 4x.

Power State D1-D2 Support - which power management modes (if any) the device supports. In these modes part of the device’s systems are shut-down thus reducing power consumption.

Device Properties - lists the various generic characteristics of the device. This depends of the type of device. A device does not need to support all the functions but sometimes the more it supports the better. Also the performance may vary to the actual setting of some of these variables.

Line Cache Size - the size of the buffer-cache in bytes. A small cache can speed-up some transactions, and some devices have a 8-byte (2 32-bit words) cache.

Latency Timer - specifies the maximum length of a bus transfer in cycles set-up for this device. Higher numbers means this device can use more of the bus bandwidth but this can slow-down other devices. You can set modify this value from the BIOS, higher numbers (up to a point) are better. The range is between 32-255.

I/O Access - specifies whether this device uses I/O ports.

Memory Access - specifies whether this device uses system memory.

Bus-Master Capable - specifies whether this device can take control of the bus and transfer data without outside support - which is generally faster.

Special Cycle Recognition - the device recognises and can transmit messages to all the other devices on the bus using special broadcast cycles.

Memory Write & Invalidate - whether this device supports a caching algorithm similar to write-back caching used by system caches.

VGA Palette Snoop - whether the device allows access to its palette registers by other cards. Typically PCI video cards must allow snooping by ISA overlay cards for the ISA card to use the correct palette.

Parity Error Response - whether the device supports parity generation and detection.

Wait Cycles - whether this device uses wait cycles in order to operate correctly. If all signals can become active simultaneously, wait cycles are not used, resulting in higher performance.

System Error Line - whether the system error line is active. This line must be active if the system is to detect parity errors reported by the devices.

Fast back-to-back Transactions - specifies whether this device can coalesce transactions and execute them in less time, one after another, in less time than if done normally. This compression can result in higher performance if many transactions need to be done.

66MHz Bus Support - whether this device can run at 66MHz. A PCI bus runs at 66MHz only if all devices can run at this speed.

User Defined Features Support - whether this device supports user defined features.

Device Select Timing - specifies the timing used for this device. This does not specify the actual speed of the device, but rather what timing is used to identify this device on the bus.

Interrupt Line -the actual hardware IRQ used by this device, if any. If the device uses a PCI interrupt line, this must be mapped to a hardware interrupt (e.g. ISA). However, modern chipsets and the newest Windows 98/Me and 2000/XP/2003 uses PCI IRQ Steering to use only one hardware interrupt (shared) for all the PCI cards. Otherwise, there would not be enough hardware interrupts.

Interrupt Pin - the PCI interrupt line used by this device. There are 4 interrupt pins for PCI (A to D) assigned to each PCI adapter. If the device requires an interrupt, generally INT A is assigned; the other 3 are used for the other functions in a multi-function device.

See List of Acronyms for more information.

Options

Include Bus Capabilities Information - query the bus for capabilities.

Include Device Capabilities Information - query the device for capabilities.

Include Device Special Capabilities Information - show the specific capabilities of device.

Include Hardware Resources Information - show the hardware resources allocated to each device.

Uses buses by PCI-to-PCI Bridge Configuration - build bus schema by querying the PCI-to-PCI bridges on the main bus. Disable if some busses do not show.

Include CardBus Buses/Device Information - show CardBus busses and devices attached to them.

Include PCMCIA Buses/Device Information - show PCMCIA busses and devices attached to them.

Include Performance Enhancing Tips - if disabled, do not display any tips.

Tips

Tips (Performance) List


Ports

Information about the parallel (LPT), serial (COM), USB and 1394 (Firewire) port(s) of your computer and the device(s) attached to them.

  • Port Device Information
  • Port Driver Information & Settings
  • Device(s) Connected to Port
  • Port Configuration
  • Provider Capabilities
  • Command Line Switch: Ports
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win32 CE) Support: Windows Mobile 2003/SE, 5
  • OS (Win64) Support: Windows XP/2003

Explanations

Port ID - the port name.

Port Type - the port type, e.g. serial or parallel.

Port UART - serial ports use an UART (Universal Asynchronous Transmitter) chip that is a converter that transforms data from parallel 8-bit to the required standard and vice-versa. It also manages the COM port and the connections. This is very important for communications throughput and all modern computers use at least a 16550A or better.

Driver ID - the port driver file name.

Driver Version - the port driver file version.

Devices Connected to Port - the list of devices connected to this port.

Packet Version - the version of the send/receive packets.

Packet Size - the maximum size of a data packet.

Provider Type - the type of port hardware.

Receive Buffer - the size of the receive buffer in bytes.

Transmit Buffer - the size of the transmit buffer in bytes.

Provider Capabilities - the list of supported functions provided by the port driver. Not all functions need to be supported although most usually are. The performance of the port does depend on the supported functions although this depends on port type, usage, etc.

Default Port Configuration - the settings used as default for the port. Do note that modems and other hardware using the port re-configure these settings when they become active, so this list if just a guideline.

See List of Acronyms for more information.

Options

Include Port Information - query the port itself.

Include Port Driver Information - query port driver.

Include Device(s) Connected to Port Information - query for devices connected to the port.

Include Port Properties Information - show the port capabilities.

Include Provider Capabilities Information - show the provider capabilities.

Include Port Configuration Information - show current port settings.

Include USB Ports Information - query USB controller/hubs if present.

Include Connected USB Devices Information - query for devices connected to the USB port.

Include FireWire/1394 Ports Information - query FireWire/1394 controller/hubs if present.

Include Connected FireWire/1394 Devices Information - query for devices connected to the FireWire/1394 port.

Include Performance Enhancing Tips - if disabled, do not display any tips.

Tips

Tips (Performance) List


Power Management

Information about your computer's power status as well as other power related settings (APM, ACPI, PMBus).

  • ACPI Interface Information
  • Power Status
  • Battery Status
  • System Status
  • Command Line Switch: Power
  • Requirements: ACPI BIOS, ACPI support enabled
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win32 CE) Support: Windows Mobile 2003/SE, 5
  • OS (Win64) Support: Windows XP/2003

Explanations

ACPI - The Advanced Configuration and Power Interface (ACPI) specification is the key element in Operating System Directed Power Management (OSPM). OSPM and ACPI both apply to all classes of computers, explicitly including desktop, mobile, home, and server machines. ACPI evolves the existing motherboard configuration interfaces to support these advanced architectures in a more robust, and potentially more efficient manner.

Generally if ACPI enabled, APM should be disabled as it may interfere with normal ACPI operation.

ACPI Version - the version of the ACPI BIOS interface. Latest version is 1.00.

ACPI Manufacturer - the company that wrote the ACPI BIOS interface.

Battery Status - whether a battery is currently plugged-in and if so whether it is charging.

Battery Life - the percentage of the full capacity that is still available.

Battery Remaining Time - an estimation of the time left before no more power is left based on the current rate of consumption or based on recent history.

Clock slow-down - whether APM can reduce the CPU frequency in order to conserve power.

Global stand-by - whether the computer can enter stand-by mode.

Time Wake-up - whether the computer can wake-up at a certain time automatically

Ring Wake-up - whether a telephone ring can wake up the computer using a modem.

PCMCIA Ring Wake-up - whether a telephone ring can wake up the computer using a PCMCIA modem.

See List of Acronyms for more information.

Options

Include DMI/SMBIOS Information - query the DMI/SMBIOS hive of the system.

Include ACPI Information - query the ACPI system.

Include APM System Information - query the system APM interface.

Include Drives Power Management Information - query the drives for PM settings.

Include BIOS SMBus Information - query the BIOS SMBus interface.

Include Performance Enhancing Tips - if disabled, do not display any tips.

Tips

Tips (Performance) List


Printer and Faxes

Information about the printers and faxes available to your computer, either local or remote.

  • Printer Information
  • Printer Settings
  • Printer Driver Support
  • Printer Driver Settings
  • Printer Device Characteristics
  • Command Line Switch: Printers
  • Requirements: Printer or Fax & drivers installed
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win64) Support: Windows XP/2003

Explanations

Printer Name - the type and make of the printer.

Printer Status - the status of the printer. The printer can be idle, printing documents or in an error mode. The error type is specified if known.

Printer Type - the printer can be either local or remote (i.e. on a network).

Shared As - the name of the shared resource that represents this printer.

Port - the port the printer is connected to.

Comments - user defined comments for this printer.

Print Processor - the print engine that the printer driver uses. Generally it is Windows but there are other specialised print processors, especially on a network.

Data Type - the format in which printing information is stored on your disk. Generally EMF (Enhanced Metafile Format) is faster as it is smaller and is printer independent. RAW format is printer specific and takes more space but some printers (e.g. faxes) cannot use EMF.

Default Printer - indicates whether this is the default printer.

Shared Printer - indicates whether this printer can be shared with other users on a network.

Spooler Priority - the process priority of the print spooler. Maximum prints faster but the machine becomes very slow since most time is spent printing. The default is minimum.

Driver Version - the version of the printer driver.

Supported Windows Version - the version of Windows the driver was designed for. For Windows 9X/Me/NT4 this should be 4.0 and 5.0 for Windows 2000, XP, 2003.

Print Driver ID - the filename of the print driver.

Printer Driver Version - the file version of the print driver.

Print Technology - the technology used by the printer. Most printers are raster printers (i.e. deal with dots) - only plotters use vector-printing technology.

Printer Mode - the resolution in dpi (dots per inch) and monochrome/colour depth.

Print Quality - the print quality either as a term (e.g. Draft, Proof) or specified in dpi.

Paper Size - the paper type used and its dimensions.

Page Orientation - can either be portrait or landscape.

Paper Source - the bin used for printing.

ICM Colour Matching - the system used to optimise the printing of colours or grey scales.

True Type Font Support - specifies whether the printer can download the fonts (i.e. the printer does the rendering) or print them as graphics (i.e. rendered by the computer).

Printer Bins - the list of paper bins supported by the printer.

Paper Types - the list of paper types and dimensions supported by the printer.

Printer Modes - the list of supported printer resolutions and monochrome/colour depths.

Printer Device Mode - various characteristics of the video mode that are self-explanatory.

Printer Capabilities - lists the various functions the printer supports natively. Windows will emulate functions not supported. Very fast printers implement most of the listed capabilities and, generally, this is why there can be a large difference between two printers even if the same hardware is used. The printer driver can be more important then the hardware itself!

Printer Clipping Capabilities - lists the clipping capabilities of the printer.

Printer Raster Capabilities - lists the drawing capabilities of the printer.

Printer Curve Capabilities - lists the curve drawing capabilities of the printer.

Printer Line Capabilities - lists the line drawing capabilities of the printer.

Printer Polygonal Capabilities - lists the polygon/triangle capabilities of the printer.

Printer Text Capabilities - lists the text drawing capabilities of the printer.

Printer Drive Escapes - lists the specialised functions the printer driver supports.

See List of Acronyms for more information.

Options

Include General Printer/Fax Information - show the basic device information.

Include Printer/Fax Driver Information - query the driver for information.

Include Printer/Fax Device Information - query the device for information.

Include Printer/Fax Device Capabilities Information - show the device capabilities.

Include Paper Bins Information - show the installed paper bins.

Include Paper Types Information - show the supported paper types.

Include Print Modes Information - list the modes supported.

Include Performance Enhancing Tips - if disabled, do not display any tips.

Tips

Tips (Performance) List


Processes

Information about the processes, i.e. jobs, running in your computer. A process can create many threads and tasks.

  • Process Information
  • Module Information
  • Threads Owned Information
  • Modules Used Information
  • Memory Footprint Information
  • Command Line Switch: Processes
  • OS (Win32) Support: 2000, XP, 2003
  • OS (Win32 CE) Support: Windows Mobile 2003/SE, 5
  • OS (Win64) Support: Windows XP/2003

Explanations

Window Class - the name of the class the window of this process belongs to. Each window belongs to a class that holds the windows attributes, settings, etc.

Module Name - the name of the module in the system.

File Name - the file name of the module in the file system.

Process Type - the type of process, e.g. 16/32/64-bit.

Process Priority - the priority of the process. All processes, except special system processes should run at the normal priority. VIP processes run at higher priorities and idle processes run at lower priorities.

Expected Windows Version - the version of Windows this process was designed for. For Windows 9X/Me/NT4 this number should be 4.0. For Windows 2000, XP, 2003 this number should be 5.0.

Total Threads - the number of threads that belong to this process.

Usage Count - the number of processes that use this process.

Process / Glocal Count - the number of instances of this process.

Started By - the name of the process that started this process.

Memory Used - the amount of memory used by this process (excluding libraries).

Modules Used - the list of libraries used by this process, including their name, type (16/32/64-bit), number of processes that use that library and amount of memory used by the library.

Threads - the list of threads created by this process and their priorities.

Heaps - the list of heaps used by this process (dynamic data allocation), their size and the total amount of memory used by all the heaps.

Total Process Memory Used - the total amount of memory used by this process, including libraries, threads, heaps, stacks and other memory.

File Information - the process file name, properties and information.

See List of Acronyms for more information.

Options

Include Process Window Information - query the process’s window.

Include Process Information - query the process itself.

Include Module Usage Information - show module usage by this process.

Include Threads Information - show process’s threads.

Include Heaps Information - show process’s heaps.

Include File Information - query file of the process.

Include Performance Enhancing Tips - if disabled, do not display any tips.

Tips

Tips (Performance) List


Remote Access Connections

Information about the Remote Access Service connections (RAS) set-up on your computer to connect to other networks including the Internet.

  • Dial-up phone number
  • Addressing information
  • Security settings
  • Network protocols
  • Connection devices
  • User/System Credentials
  • Command Line Switch: RAS
  • Requirements: Communication adapter, RAS installed
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win32 CE) Support: Windows Mobile 2003/SE, 5
  • OS (Win64) Support: Windows XP/2003

Explanations

Country Code - the international phone code for the country.

Area Code - the local area code for the zone.

Phone Number - the local phone number for the computer to dial-in to.

Script Filename - the full filename of the script that automates the log-in process.

IP Address - the IP address for this connection.

DNS Servers - the IP address(es) of the DNS (Domain Name Servers) for the connection. These servers resolve remote (Internet) machine names into IP addresses.

WINS Servers - the IP address(es) of the WINS (Windows Name Servers) for the connections. These servers resolve local (Intranet) machine names into IP addresses.

IP Header Compression - whether this type of compression is used or not.

Software Compression - whether this type of compression is used or not.

Use Remote Gateway - whether IP traffic is routed to the remote gateway or not.

Disable PPP/LCP Extensions - whether this extensions should be used or not.

Encrypted Password Required - whether only encrypted passwords are exchanged between computers for added security.

Microsoft Encrypted Password Required - whether only Microsoft encrypted passwords are exchanged between computers for added security.

Data Encryption Required - whether only encrypted data is exchanged between computers.

Log onto Network - whether you are logged on the remote network after connection.

Use Log-on Credentials - whether you are logged on the remote network using the credentials for the current session.

Network Protocols - the enabled network protocols over this connection.

Framing Protocol - the framing protocol used. PPP is the currently most popular protocol for PCs.

Device Type - the type of device used for the connection. Generally a modem or TA (terminal adapter) is used.

Device Name - the name of the device used for the connection.

User Name - the user name used for log-on.

Password - the password used for log-on. (Sandra will not display it for security reasons).

Domain - the domain to connect to.

Options

Include Connection Data Information - show connection type and characteristics.

Include Connection Settings Information - show connection settings.

Include GUI Connection Settings Information - show the GUI-mode settings.

Include Network Security Settings Information - show security settings.

Include Network Protocols Information - list supported protocols.

Include Connection Device Information - show device (through which connection is made) settings.

Include Credentials Information - show user credentials information.

Include Performance Enhancing Tips - if disabled, do not display any tips.

Tips

Tips (Performance) List


SCSI Devices

Shows Information about the SCSI host adapters, buses and the SCSI devices connected to your computer.

  • SCSI Host Information
  • SCSI Device Information
  • SCSI Block Devices Extra Information
  • Command Line Switch: SCSI
  • Requirements: SCSI Host Adapter, SCSI devices and 32/64-bit ASPI drivers.
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win64) Support: Windows XP/2003

Explanations

See List of Acronyms for more information.

Note: Windows uses drivers that make ATAPI devices look like SCSI devices for consistent management. This is done since ATAPI is in many ways quite similar to SCSI. Therefore, some of your ATA devices may appear as SCSI devices as well. This is not a bug - but a feature of the operating system.

Host - The host is the controller that manages the SCSI bus. Most SCSI controllers support up to 7 devices (8 including the controller itself). Each device on the SCSI bus has a unique address.

Device - The devices that can be connected to the SCSI bus are varied and include the usual hard disks, CD-ROMs, backup devices, tape drives, scanners, optical disks and many others.

Device Type - the type of the device.

Manufacturer - the company that manufactured the device.

Product - the full name of the product.

Version - the product version or revision.

Extra Information - extra information about the device, generally either a serial number or the release date.

Removable Device - whether the media of the device is fixed or removable.

Target ID - SCSI devices occupy (i.e. respond to) one address on the SCSI bus. Generally, the SCSI device provides a means (e.g. switches, jumpers) to select one of the eight available addresses (0 through 7). This address is used during bus arbitration and selection or re-selection of SCSI devices. Each device on the SCSI bus is assigned a unique address.

Logical Unit Number - Each target has one or more logical units, beginning with logical unit zero. There is a maximum of eight logical units. These logical units are usually mapped directly to peripheral devices, but they may be a portion of a peripheral device or may comprise multiple peripheral devices.

Device Currently Connected - Whether this device is currently on-line or not. Some devices can disconnect from the bus.

Bus Width - The SCSI bus width. Usually it is 8-bit but Wide SCSI supports 16-bit for faster data transfer. Some SCSI implementations even support 32-bit.

SCSI ANSI Version - The device complies to this version of SCSI. This code designates this standard upon approval by ANSI.

Supports Relative Addressing Mode - device supports the relative addressing mode for this logical unit.

Supports Synchronous Transfers - device can transfer data synchronously.

Supports Command Queues - device supports queued commands.

Supports Linked Commands - device supports command linking.

Supports Soft Reset - device can be soft reset in addition to the hard reset.

Supports Terminate I/O - device can terminate a I/O transaction.

Int 13h Drive No. - if the device is a hard disk, this is the BIOS ID for the drive. With an ID the BIOS and DOS can use the drive without specific drivers.

Heads - the number of heads (tracks) for the device.

Sectors - the number of sectors per track for this device.

Options

Include General Properties Information - show generic SCSI device data.

Include Drive Information - query the drive device.

Include Disk/Media Information - query the installed media of drive.

Include Performance Enhancing Tips - if disabled, do not display any tips.

Tips

Tips (Performance) List


Smart Cards and SIMs

Information about the SIMs, Smart Cards and readers connected to your computer.

  • Supported Smart Cards & SIM Cards list
  • Smart Card Readers Information
  • Smart Card Readers Capabilities
  • Smart Card / SIM Card Information
  • ATR String Information
  • Card and Cryptographic Providers
  • Command Line Switch: SmartCard
  • Requirements: Smart Card Reader, Smart Card / SIM Card
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win64) Support: Windows XP/2003

Explanations

Please see individual tips for explanations.

See List of Acronyms for more information.

Options

This module has no options to set

Tips

Tips (Performance) List


Audio Devices

Information about the sound card(s) and other audio devices installed in your computer.

  • Wave Devices - Recording and Playback
  • MIDI Devices - Control (input/output) and Playback
  • Mixer Devices
  • Auxiliary Devices
  • Command Line Switch: Audio
  • Requirements: Sound card, multi-media drivers installed
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win32 CE) Support: Windows Mobile 2003/SE, 5
  • OS (Win64) Support: Windows XP/2003

Explanations

Wave Devices - are the digital audio devices present in your system. They are used for voice playback and special effects in games.

MIDI Devices - are the music devices present in your system. MIDI is an interface allowing the connection of various musical devices for playback or recording purposes.

Mixer/Auxiliary Devices - are mixer channels that handle the mixing of the audio, MIDI, Video, line-in, line-out, CD, microphone, etc. devices.

Name - the name of the device. Sandra cannot (sometimes) detect devices released after this release of Sandra! Update your copy of Sandra.

Manufacturer - the name of the company that wrote the driver for the device.

Version - the version of the device driver.

Product ID - the unique ID number assigned to this device.

Sampling Bits - the maximum number of sampling bits used for playback or recording. Current devices use 16-bits which convey higher quality music than older 8-bit devices.

Sampling Rate - the maximum sampling rate supported by the device in kHz. This is the number of times the sound is sampled in one second. Latest devices can sample at 44.1kHz.

Channels - the number of supported channels.

MIDI Device Type - the type of MIDI device the device implements, generally the type of synthesiser implemented.

Auxiliary Device Type - the type of input/output device this mixer channel deals with.

Voices - the maximum number of voices that can play at any one time.

Notes - the maximum number of notes that can play at any one time.

Device Capabilities - lists the various functions the device supports. This depends on the type of device. A device does not need to support all the functions, some are not required. The performance has nothing to do with the number of functions supported - only usability is affected.

See List of Acronyms for more information.

Options

Include Device Capabilities Information - show the capabilities of the sound device.

Include Performance Enhancing Tips - if disabled, do not display any tips.

Tips

Tips (Performance) List


Computer Overview

Complete overview of your computer. A summary of your computer's characteristics. You can find detailed information in the other modules.

  • Computer Type, Description
  • CPUs
  • BIOS
  • System Bus Types
  • Memory Installed
  • Monitor & Video Adapter(s) Installed
  • Sound Card Installed
  • Communication device(s) Installed
  • Floppy Disks, Hard Disks, CD-ROM/DVD & other drives
  • Ports (serial/parallel/USB)
  • Input Devices - Keyboard, Mouse, Game controller(s)
  • Windows Information
  • Network(s) Support
  • Command Line Switch: Summary
  • Requirements: See elsewhere
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win32 CE) Support: Windows Mobile 2003/SE, 5
  • OS (Win64) Support: Windows XP/2003

Explanations

See the following topics for explanations:

  • Communication Devices
  • Processors
  • Physical Disks
  • Keyboards and Tablets
  • Mainboard
  • Mice and Track-balls
  • Buses and Devices
  • Ports
  • Printers and Faxes
  • Audio Devices
  • Displays and Display Adapters
  • Operating System
  • Memory Usage
  • List of Acronyms

Options

Include DMI/SMBIOS Information - query the DMI/SMBIOS hive of the system.

Include System Bus(es) Information - query the buses on the system.

Include Peripherals Information - query the attached peripherals.

Include Drive(s) Information - query the attached drives and controllers.

Include Operating System(s) Information - query the operating systems installed.

Include Network Information - query the attached networks.

Include BIOS Information - query the BIOS of the system.

Include Chipset Information - query the system chipset.

Include CPU(s) MSR(s) Information - query the CPU by accessing its MSRs.

Include CPU(s) EEPROM(s) Information - query the CPU by accessing its EEPROMs.

Ignore Disabled Hosts - if disabled, attempt to enable the controllers.

Detect Bus Multiplexors - if enabled, attempt to detect and enable any bus multiplexors.

Include IRQ APIC Information - query the system APIC if present (SMP generally).

Include X-Bus Information - detect legacy X-Bus through LPC.

Use bridges by PCI-to-PCI bridge configuration - get no/type of busses through bridges; otherwise get through OS.

Include Performance Enhancing Tips - if disabled, do not display any tips.

Tips

Tips (Performance) List


System Resources

IRQ, DMA, I/O and Memory system resource settings. Lists the system resources and the hardware device that uses each setting.

  • Command Line Switch: SystemResources
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win64) Support: Windows XP/2003

Explanations

DMA - DMA or Direct Memory Access is a method of transferring data between a device and memory without CPU involvement. This way is faster. Also, the CPU can do other computation in the mean-time.

Channels - There are 2 DMA controllers in a PC, each providing 4 channels. Since one channel is used to connect the master DMA controller to the slave DMA controller there are 4 8-bit and 3 16-bit available channels. One channel can be used by one hardware device only.

DMA Ch. No. - the channel number used by a hardware device.

Hardware Interrupts (Irq) - are the interrupts generated by hardware. There are 16 in total in today’s PC. However most of them are used before you add any devices. Most hardware devices (keyboard, mouse, modem, disk controller) need an interrupt to interface to the CPU.

Channels - There are 2 interrupt controllers in today’s PC, each providing 8 channels. One channel is used to connect the master interrupt controller to the slave interrupt controller, leaving 15 free interrupts. However, the chipset itself uses many interrupts (about 11) leaving only about 3-6 free. Until recently no two devices could share and interrupt (in most cases) since the software could not tell them apart, but new BIOSes & OSes have implemented a resource sharing protocol since there are just not enough free interrupts for all the hardware to use.

Irq. No. - The number of the hardware interrupt that is used by a device or more.

I/O Ports - are ports that can be used by software to talk to hardware directly without using interrupts and the BIOS. There are 65 thousand ports, but each hardware device may use as many as 20-40, i.e. a range. Some are input only, some are output only and some are input/output depending on hardware. No two devices may share one port, so ranges must not overlap.

I/O Port - the port range used by the hardware device.

Memory - a 32-bit processor (386, 486, Pentium, etc.) has an address range of 4GB (00000000 -FFFFFFFF in hexadecimal); a 36-bit PAE processor (Pentium Pro/II/III) has an address range of 64GB (000000000-FFFFFFFFF in hexadecimal);a 64-bit processor (Alpha, Opteron, MIPS, Itanium, etc.) has an address range of 16,384 PB (0000000000000000 -FFFFFFFFFFFFFFFF in hexadecimal).

The installed physical memory, the video adapter memory, BIOSes can be mapped somewhere in this address space. While the address range is huge, there may still be conflicts since most devices try to use the same lower addresses.

Memory Range - the memory address range used by the hardware device.

Device - the name and type of hardware device that uses the DMA channel.

See List of Acronyms for more information.

Options

This module has no options to set.

Tips

Tips (Performance) List


Displays and Display Adapters

Information about the monitor(s), display(s) connected to your computer and video adapter(s) and video driver(s) installed.

  • Monitor/LCD Information, Characteristics
  • Monitor/LCD established/programmed Timings
  • Video Adapter Characteristics
  • Video Driver Information
  • Video BIOS Information
  • VESA Video BIOS & VESA Extensions Information
  • Video Device Characteristics
  • Command Line Switch: Displays
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win32 CE) Support: Windows Mobile 2003/SE, 5
  • OS (Win64) Support: Windows XP/2003

Explanations

Monitor Name - the type and make of your monitor if known.

Maximum Resolution - the maximum resolution supported by your monitor. Usually you use a lower resolution since the very top one has low refresh rate.

Horizontal Scan Range - the horizontal scan range in kHz. It is dependent on horizontal scan range and resolution.

Vertical Refresh Range - or the refresh in Hz is the range of the number of times the screen can be repainted in one second - typically stated at a low resolution, not the top one. Higher numbers are better.

DPMS Energy Star Support - indicates whether your monitor can go to sleep mode, i.e. reduce its power. VESA DPMS (Display Power Management Signalling) is an interface through which the video adapter can power down the monitor.

Energy Star - is a programme administered by U. S. EPA (Environmental Protection Agency) to reduce the power consumed by computers and peripherals.

Video Adapter - the name and make of the video adapter if known.

Total Memory - the amount of memory installed on the video adapter.

Video Memory - the amount of local (on the card) memory installed.

AGP Memory - if the adapter supports AGP, the amount of system memory allocated to AGP. This depends on the size of the system memory.

DIME Support - DIME (Direct Memory Execution) AGP cards can texture directly from AGP memory. Otherwise textures must either be stored in local memory or copied using DMA or PIO from system memory to local memory when texturing is to be done.

Hardware Revision - the silicon revision of the chipset on the video adapter.

VESA/DDC Support - indicates whether the video driver/adapter supports VESA DDC (Display Data Channel) which is an interface through which the video adapter can communicate with the monitor to optimise video parameters.

Current Video Mode - the current resolution and colour depth of the display.

Vertical Refresh Rate - the number of times the screen is painted every second. This number should be over 70Hz if you don’t want to see flickering or over 85Hz if you’re using a high resolution.

If you’re using a flat-panel (LCD) display, the refresh rate is not relevant anymore and 60Hz is good enough, although high-performance LCDs support 75Hz or more.

Supported Refresh Rates - the list of supported refresh rates at this resolution. Flat-panel (LCD) displays may support only one refresh rate.

Video Driver ID - the file name of the video driver.

Video Driver Version - the version of the video driver.

Supported Windows Version - the version of Windows the driver was designed for. For Windows 9X/Me/NT4 this should be 4.0. For Windows 2000, XP, 2003 this should be 5.0.

Plug & Play Video Driver - indicates whether the driver is plug & play compliant. Nowadays all drivers should support plug & play.

Video Acceleration - indicates the amount of acceleration you want out of the video adapter. Full acceleration is the fastest and recommended for most computers. If you’re having trouble with the video and you suspect the video driver/adapter reduce the acceleration until the problems disappear.

Screen Saver Active - indicates whether the screen saver is set-up.

Screen Saver Time-out - indicates the amount of idle time after which the screen saver will become active.

Supported Video Modes - list of all video modes, colour depths and refresh rates supported by your adapter. High performance display adapters support many video modes. Flat-panel (LCD) displays may support only one native video mode - although lower resolutions may still be used.

Video BIOS - the BIOS (Basic Input Output System) contains the start-up code that initialises and starts your video adapter. It also serves as an interface between hardware and software.

Video BIOS Manufacturer - company that wrote the BIOS code.

Video BIOS Date - the date the BIOS was released.

Video BIOS Version - the software version of the BIOS.

DirectX - DirectX is a video support library from Microsoft that caters especially for multi-media applications and games, including 3D, sound, music, input and multi-player capability.

DirectX- DirectDraw Support - indicates the version of DirectDraw display driver interface. DirectDraw is a Windows software interface that allows programs to take control of the display directly, bypassing the GUI. This is important for multi-media games and full-motion video.

DirectX Direct3D Support - indicates the version of the Direct3D display drivers interface. Direct3D is a set of libraries that handle 3D rendering for games and other multi-media applications.

OpenGL Support - indicates the version of the OpenGL libraries. OpenGL is a set of standard multi-platform software libraries offering sophisticated 3D rendering. Can be used on a SGI, PC, MAC, etc. unlike DirectX.

Animation Effects - indicates whether window animation is on.

Full Windows Drag - indicates whether while moving/resizing a window the contents of the window is updated in real-time.

Font Smoothing - indicates whether screen fonts will be anti-aliased. This method reduces font jaggies and makes the display look better but reduces performance.

Video Device Mode - various characteristics of the video mode that are self-explanatory.

Video Capabilities - lists the various functions the video adapter/driver support natively. Windows will emulate functions not supported. Very fast video adapters implement most of the listed capabilities and, generally, this is why there can be a large difference between two adapters even if the same chipset is used. The video driver can be more important then the chipset itself!

Video Clipping Capabilities - lists the clipping capabilities of the video adapter.

Video Raster Capabilities - lists the drawing capabilities of the video adapter.

Video Curve Capabilities - lists the curve drawing capabilities of the video adapter.

Video Line Capabilities - lists the line drawing capabilities of the video adapter.

Video Polygonal Capabilities - lists the polygon/triangle capabilities of the video adapter.

Video Text Capabilities - lists the text drawing capabilities of the video adapter.

See List of Acronyms for more information.

Options

Include Monitor(s) Information - show information about the monitors.

Include Video Adapter(s) Information - show information about the video adapters.

Include Video Driver Information - query the video driver.

Include Supported Video Modes Information - list the modes supported.

Include Video BIOS Information - query the video BIOS of the adapter.

Include Special Capabilities Information - show the advanced capabilities of the driver.

Include Video Device Information - query the video device.

Include Video Device Capabilities Information - show the capabilities of the device.

Include DirectX Information - query the DirectX video interface.

Include Temps, Fans and Voltages Information - query the video environment monitor for temperature, cooling and voltage sensors.

Use temperature compensation for external sensors - add temperature compensation for the external temperature sensors.

Enable Disabled HW Monitors - enable the environment monitors if they are not enabled.

Ignore Disabled Hosts - if disabled, attempt to enable the controllers.

Use bridges by PCI-to-PCI bridge configuration - get no/type of busses through bridges; otherwise get through OS.

Include Performance Enhancing Tips - if disabled, do not display any tips.

Tips

Tips (Performance) List


Operating System

Information about your operating system (OS), Windows, or the emulation operating system.

  • Windows Information
  • Key Applications
  • Auto-Update & Windows Update
  • DEP Status
  • Regional Settings
  • Command Line Switch: OS
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win32 CE) Support: Windows Mobile 2003/SE, 5
  • OS (Win64) Support: Windows XP/2003

Explanations

General Information – name, version, architecture (x86, x64, IA64, etc.), number of supported CPUs, product ID and key ID and registered owner & organisation.

Activation Status – whether activation is required, grace period left and time left until expiration if any.

Data Execution Prevention (DEP) Status – whether DEP is supported by CPU and whether applications and drivers are protected.

Default Key Applications – list of the default key applications for each category (web, e-mail, news reader, media player, address book, anti-virus, firewall, etc.)

Session Settings – host name, user name, domain/workgroup name, time since start-up.

Operating System Properties – whether OS is debug, has C2 security, is remote terminal session.

Automatic Update Status – whether Windows will check for patches and updates and will install them.

Installed Windows Updates – list of installed Windows updates.

Available Windows Updates - list of available Windows updates.

Regional Settings – locale information, code pages, time zone.

Windows Folders – list of key folders and their location.

See List of Acronyms for more information.

Options

Include Login Information - query system for logins information.

Include OS Properties Information - show operating system properties.

Include OS Folders Information - show the location of system folders.

Include OS Regional Settings Information - show the regional settings.

Include Product IDs Information - show the serial numbers and product IDs.

Include Default Key Applications Information – show the default key applications registered.

Include Auto-Update Information – query Auto-Update status.

Include Windows Update Information – query Windows Update for updates.

Include Activation Status – query the activation status.

Include Installed Windows Updates – list the installed Windows updates.

Include Available Windows Updates – list the available Windows updates.

Do NOT connect to Windows Update – do not connect to the Internet to find out whether there are new updates, just use the last log.

Include DEP Information – query the Data Execution Protection status.

Include Performance Enhancing Tips - if disabled, do not display any tips.

Tips

Tips (Performance) List


Memory Usage

Information about your computer's operating system memory, resources, memory drivers, status and other memory related information.

  • Physical and Virtual (Swap File) Information
  • Heaps Information
  • Windows Base Memory Information
  • Command Line Switch: OSMemory
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win32 CE) Support: Windows Mobile 2003/SE, 5
  • OS (Win64) Support: Windows XP/2003

Explanations

Total System Memory - the total amount of memory (physical & virtual) that is available to Windows.

Free System Memory - the total amount of memory (physical & virtual) that is currently unused.

Total Physical Memory - the amount of physical memory installed in your computer.

Free Physical Memory - the amount of unused physical memory. This can be zero most of the time as Windows tries to use all available physical memory to improve performance.

Maximum Swap File - the maximum size that the swap file (virtual memory) can grow to. Generally this is somewhat less than the free space on the drive that contains the swap file.

Current Swap File - the current size of the swap file. This should be as low as possible, since virtual memory is very slow compared to physical memory.

Free Page File - the current size of unused space in the swap file. Too high a number may mean that the swap file is too large; too low a number may mean that you need to add more physical memory or increase the size of the swap file.

Page File Drive - the drive that contains the swap file.

NB - Unless you know what you are doing you should let Windows manage the swap file.

True Allocated Memory Load - the percentage of allocated memory with respect to the installed physical memory. This is almost always over 100% since Windows utilities all physical memory as well as a bit of the swap file even when it does not need any.

Total Windows Base Memory - the total size of DOS memory available to Windows programs. This should always be 640K unless special memory managers are used or special cards.

Free Windows Base Memory - the total size of DOS memory that is available to use by Windows programs. While Windows programs don’t use base memory, some need it to communicate with DOS programs, device drivers or legacy hardware.

Largest Free Base Memory Block - the size of the largest contiguous block of free base memory available. Due to fragmentation this is less than the free base memory.

See List of Acronyms for more information.

Options

Include System Memory Extra Information - show extended memory status.

Include Statistics Information - show memory statistics.

Include Performance Enhancing Tips - if disabled, do not display any tips.

Tips

Tips (Performance) List


Network Adapters

Information about your network adapters, settings, host details, network services, routing tables and security.

  • Anti-virus scanner Information
  • Firewall information
  • Bluetooth radio Information
  • WinSock Library Information
  • Local Host Information
  • Network Adapters Information
  • (IP) Network Services Information
  • Routing Table Information
  • (ARP) Address Routing Table Information
  • Command Line Switch: NetworkCard
  • Requirements: Internet connection, WinSock v2
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win32 CE) Support: Windows Mobile 2003/SE, 5
  • OS (Win64) Support: Windows XP/2003

Explanations

WinSock Library - Windows programs use a WinSock library to connect to the Internet via IP.

Version Required - the version required by most popular Internet programs. Your library should support at least version 2.0.

Highest Version - the highest version supported by the library. The latest version is 2.02 that adds various new functions and improvements.

Description - the name and version of the WinSock library.

System Status - the current status of the library.

Maximum Sockets - the maximum number of sockets a process can use. This is roughly the number of connections that can be made at any one time.

Maximum UDP datagram size - the maximum size (in KB) of a packet that can be sent by UDP. UDP is a connectionless protocol (resembling the postal service) through which applications can transmit messages.

Host - the fully qualified name (including domain) of your computer and its IP settings.

Network Adapters - list of enabled network adaptors, including their characteristics, status and IP details (address, mask, DNS servers, etc.)

Anti-Virus Programs - list of installed anti-virus scanners and their status.

Firewall Programs - list of installed software firewalls and their status, including the Windows Firewall. A list of network adapters and their firewall status is also included.

Bluetooth Radios - list of installed Bluetooth radio network adapters, including their characteristics, status, etc.

Bluetooth Services Information - list of Bluetooth services, including name and status.

IP Services Information - list of services, including name, port and protocol used. Services include FTP, TELNET, HTTP (web) and many others. You can find a complete list and descriptions in any TCP/IP book.

Routing Table - list of IP address ranges for which packets are routed to a specific IP address and thus a specific network adapter and the number of hops to that IP address.

Address Resolution (ARP) Table - lists the host names/IP addresses and their corresponding hardware address that packets are sent to. The hardware address depends on the network adapter’s type (e.g. Ethernet, Bluetooth, etc.)

See List of Acronyms for more information.

Options

Include WinSock Library Information - query the WinSock library.

Include Local Host Information - query the local host.

Include Network Services Information - query the active IP services running.

Include Routing Table Information - list the IP routing table entries.

Include SNMP Information - attempt to query information by SNMP.

Include Network Adapter(s) Information - list network adapters details.

Include Remote Server Information - query the remote servers the computer is connected to for data.

Include IP Statistics Information - show IP statistics.

Include ARP Table Information - show the ARP table entries.

Include DNS Lookup Information - do DNS lookup on remote servers to obtain their name.

Include Performance Enhancing Tips - if disabled, do not display any tips.

Tips

Tips (Performance) List


Configuration Files

Contents of some of your computer's files, this list is for report saving purposes.

  • Command Line Switch: ConfigFiles
  • OS (Win32) Support: Windows 2000, XP, 2003

Options

This module has no options to set.

Tips

Tips (Performance) List


Environment Variables

The environment variables set and their respective values. Environment variables are used to configure legacy software.

  • Command Line Switch: EnvVar
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win64) Support: Windows XP/2003

Options

This module has no options to set.

Tips

Tips (Performance) List


Event Log

Contents of the event logs of your computer and the events stored in them.

  • Command Line Switch: EventLog
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win64) Support: Windows XP/2003

Options

This module has no options to set.

Tips

Tips (Performance) List


Installed Processes

Shows the installed/registered processes on your computer. These are individual processes, not the suite they may belong to.

  • Command Line Switch: InstalledProgs
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win32 CE) Support: Windows Mobile 2003/SE, 5
  • OS (Win64) Support: Windows XP/2003

Options

This module has no options to set.

Tips

Tips (Performance) List


File Types

List of types of documents and files registered on your computer and the applications associated with them.

  • Command Line Switch: FileTypes
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win32 CE) Support: Windows Mobile 2003/SE, 5
  • OS (Win64) Support: Windows XP/2003

Options

This module has no options to set.

Tips

Tips (Performance) List


Installed Applications

List of applications (suites) and packages installed on your computer. Each may contain one or more individual processes.

  • Command Line Switch: InstalledApps
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win32 CE) Support: Windows Mobile 2003/SE, 5
  • OS (Win64) Support: Windows XP/2003

Options

This module has no options to set.

Tips

Tips (Performance) List


Key Applications

List of all the registered applications on your computer that are vital in operation.

  • Address Book
  • Anti-Virus scanner
  • Calendar/Organiser
  • E-Mail reader
  • Firewall
  • Instant Messaging
  • Internet Call

  • Java Virtual Machine
  • Media Player
  • News Reader
  • Web Browser

In each category, the applications of that type are listed with the following information:

  • Application name
  • Is default in category
  • Protocols supported
  • Program file information
  • Command Line Switch: KeyApps
  • Requirements: None
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win64) Support: Windows XP/2003

Explanations

Please see individual tips for explanations.

See List of Acronyms for more information.

Options

This module has no options to set.

Tips

This module does not generate any tips.


Application Scan

List of all the programs, applications and libraries present on all the local drives of your computer. Even if the application is not registered as installed, has no shortcuts or is damaged it will still be identified by the scan.

This information can be useful when auditing the computer for installed software, e.g. for licence compliance.

NB1: Due to the disk scan, this module may take a significant time to complete, depending on the number of drives, the size and speed of the drives and number of programs and libraries present.

NB2: The amount of data may also be significant, with information on potential hundreds of programs and libraries. Use the module options to cut the information down.

  • Program file information
  • Library file information
  • Command Line Switch: AppScan
  • Requirements: None
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win64) Support: Windows XP/2003

Explanations

Please see individual tips for explanations.

See List of Acronyms for more information.

Options

Include applications (executables): List executables found.

Include libraries (DLLs): List libraries found.

Do not include Windows’ folder: Do not scan Windows’ folders. Uncheck this if you’re also interested in the standard Windows applications and libraries or you think some 3-rd programs or libraries may be present in Windows’ folder(s).

Tips

This module does not generate any tips.


Start Menu Applications

List of applications and programs listed on the Start menu of your computer.

This information can be useful when auditing the computer for installed software, e.g. for licence compliance.

  • Shortcut information
  • Program file information
  • Command Line Switch: StartApps
  • Requirements: None
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win64) Support: Windows XP/2003

Explanations

Please see individual tips for explanations.

See List of Acronyms for more information.

Options

Include groups common to all users: Include menus & groups that are available to all users.

Include current user instead of default user: Include menus & groups that are available to the current user instead of the default user. Uncheck this when there is no user logged in to the computer.

Tips

This module does not generate any tips.


Web Components

Shows the ActiveX and Java web components installed or registered on your computer.

This information can be useful when auditing the computer for installed 3-rd party ActiveX packages or Java classes.

  • ActiveX package information
  • Java classes information
  • Files contained in package/class
  • Server package/class information
  • Command Line Switch: WebPackages
  • Requirements: None
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win64) Support: Windows XP/2003

Explanations

Please see individual tips for explanations.

See List of Acronyms for more information.

Options

Include ActiveX packages: List installed ActiveX packages.

Include Java classes: List installed Java classes.

Tips

This module does not generate any tips.


Benchmarking Modules
Rate the performance of your computer and its individual components.
Processor Arithmetic | Processor Multi-Media
Power Management Efficiency | Multi-Core Efficiency
Physical Disks | File Systems
Removable Storage | CD-ROM and DVD
Memory Bandwidth | Memory Latency
Processor Cache and Memory | Network Bandwidth
Internet Connection | Internet Peerage
Mobile Device Transfer |


Hardware Information Modules

Get detailed information about all the components of your computer.

Computer Overview | Mainboard
Mainboard Configuration | Processors
Plug & Play | Buses and Devices
Power Management | Displays and Display Adapters
Physical Disks | SCSI Devices
Printers and Faxes | Communication Devices
Ports | Game Controllers
Audio Devices | Mice and Track-balls
Keyboards and Tablets | Smart Cards and SIMs
Network (LAN) | IP Network
Network Adapters | System Resources


Software Information Modules

Explore installed applications, processes, modules, services and other software components.

Operating System | Key Applications
Start Menu Applications | Memory Usage
Processes | Modules
Services and Drivers | Components and Objects
Installed Applications | Installed Processes
Fonts | Media Devices
DirectX | OpenGL
Remote Access Connections | Logical Drives
Application Scan | Data Sources
File Types | Web Components
Environment Variables |


Support Modules

Get additional information about your computer.


Testing Modules

Test your computer's components.


Tools (Wizard Modules)

Analyse, monitor, rate or test your computer, its individual components, a remote computer or your PDA / Smartphone.

Maintain, update and register your copy of Sandra.

Add New Module | Connect to Source
Create Report | Burn-in Computer
Performance Index | Analysis and Advice
Environment Monitor | Register Program
Update Program | Upload Results

For more information, see:

  • Tips (Performance) List
  • Report File Formats


Commercial Version Required

Sorry, this module only runs on the commercial versions of Sandra. You will need to purchase one of these versions to get this module.

You can delete the module (click DEL or right-click and choose Delete) to get rid of this message. This is not a nag screen, just an information screen that can be turned off.

To find out how to order the commercial versions, see the Ordering Information topic.


Plug & Play

Information about all the Plug & Play devices installed in your computer, including legacy, plug & play and other devices.

  • Command Line Switch: PnP
  • OS (Win32) Support: Windows 2000, XP, 2003
  • OS (Win64) Support: Windows XP/2003

Explanations

Manufacturer - the manufacturer for this device.

Device Name - the full product name for this device.

Hardware Version - the device version if known.

Resources - the hardware resources this device uses.

Irq. No. - the number of the hardware interrupt that is used by a device or more.

DMA Ch. No. - the channel number used by a hardware device.

I/O Port - the port range used by the hardware device.

Memory Range - the memory address range used by the hardware device.

Driver - the software driver that interfaces this device to Windows.

Driver Date - the date the driver was released.

Driver Version - the version of the driver. For the current version of windows this should be 4.0 or higher.

Information File - the name & path of the information file that was used to install this software driver.

Information File Section - the name of the section within the information file used to install this software driver onto the operating system.

Device Loader - the device driver that installs this driver.

Device Enumerator - the device driver that detects (enumerates) this type of devices.

Miniport Driver - a miniport driver is a generic driver for a specific type of device (e.g. ATA controllers) which interfaces with a specific driver for your hardware. This way the specific driver is simpler and thus easier to write and release.

Universal Driver - an universal driver is similar to a miniport driver, however it is a fully fledged driver which does not need a specific driver to drive your hardware. You will gain better support and stability but some specific functions of your hardware may go unused.

See List of Acronyms for more information.

Options

This module has no options to set.

Tips

Tips (Performance) List


N224

Notice N224 - SMBIOS/DMI information may be inaccurate. This information is reported verbatim and cannot be checked by Sandra. While brand-name companies set this information most generic manufacturers use generic data that is meaningless. This issue generates more technical support queries than all other issues combined.

Fix: If the information is not correct, check for a BIOS update (clear DMI pool) or fix any errors using the DMICFG tool provided with the board. Alternatively, disable Sandra’s DMI/SMBIOS reporting from module Options.


N1321

Notice N1321 - Updates are ready for your Windows operating system.

Fix: Windows update shows that updates are available for your system. Consider applying some of them.


N1323

Notice N1323 - DEP is not enabled for all programs and services just for essential ones.

Fix: Consider enabling it for all programs and services and then add the programs and services that do not work with DEP enabled to the exclusion list. This provides a safer environment than the default option.


N2527

Notice N2527 - A compensation value (calibration constant) was added to external temperature sensors. Depending on the CPU type, a compensating value must be added if the temperature sensor does not actually touch the CPU. This correction is not defined for all CPUs and there are exceptions to the rule. Don't compare the BIOS that is tuned for your board with Sandra which must work on ALL boards!

Fix: Right-click module, select Options and uncheck Use temperature compensation for external sensors. See the System Monitor topic in the FAQ for more information.


N2535

Notice N2535 - The disabled host controllers have been enabled.

Fix: Nothing to fix - keep a lookout for any problems.


N2536

Notice N2536 - The system has no enabled SMBus/i2c/BMB controller or Sandra does not support it. Most modern systems have at least one.

Fix: If Warning W2533 is also issued, see its topic. If not check the manual to check whether such a controller is present; if it is please contact us.


N2539

Notice N2539 - The disable hardware monitors have been enabled.

Fix: Nothing to fix - keep a lookout for any problems.


N5004

Notice N5004 - The benchmark is synthetic and measures one aspect of system performance. It is not meant to indicate real-life performance, whatever the latter means for you. This depends on what specific applications you run, amount of data manipulated, etc. There are other benchmarks (BapCo, WinStone, WinBench) that attempt to measure general application performance.

Fix: As long as you keep this in mind, all should be OK. To find out more about just what the benchmarks measure, refer to Help, the on-line documentation and FAQ. Do not try to infer more than can be inferred from the results.


N5006

Notice N5006 - We make changes to the benchmark code from version to version and generally overhaul them completely when the major version changes (e.g. 9.0 from 8.x). This is unavoidable if we are to keep the benchmarks up-to-date with new technology and optimise the results following feedback from previous releases.

Fix: As long as you keep this in mind, all should be OK.


N5404

Notice N5404 - You may need to run the benchmark a few times to obtain a stable result. While in general the benchmark is stable (as it averages the results internally) and one run is enough, in certain circumstances (e.g. program activity, SMP operation) the results may vary by a certain amount from run to run.

Fix: Run the benchmark until the score does not change from run to run.


N5405

Notice N5405 - System bandwidth appears to be FSB limited. Generally this means that FSB bandwidth is < 50% total memory interface bandwidth, thus memory bandwidth is wasted. Some systems use the additional bandwidth for built-in video (if applicable) if video memory is shared with system memory.

Fix: Attempt to increase FSB (keep memory bus speed constant) to increase FSB bandwidth and thus improve overall bandwidth performance.


N5406

Notice N5406 - System bandwidth appears to be memory limited. Generally this means that memory bandwidth is < 50% FSB bandwidth, thus CPU is starved. This generally indicates a mismatch between memory and system. Note that this does not indicate that memory timings are wrong, but the memory itself is slow.

Fix: Use higher performance memory (e.g. DDR/2/3 or even RDRAM) or use any additional memory channels (if present) to increase memory bandwidth performance.


N5901

Notice N5901 : CD 1x= 150kB/s; As some device makers may use different values exercise caution when comparing measured vs. published ratings.

Fix: Keep in mind that while the raw data rate is 176kB/s, the actual rate is just 150kB/s for 1x CD; this is rate used when comparing CD drives and other devices (e.g. Flash).


N5902

Notice N5902 : DVD 1x= 11.08Mbps; As some device makers may use different values exercise caution when comparing measured vs. published ratings.

Fix: Keep in mind that while the the actual rate is just 11.08Mbps for 1x DVD; this is rate used when comparing DVD drives and other devices (e.g. newer generation).


N5903

Notice N5903 : HD DVD 1x= 36.55Mbps; As some device makers may use different values exercise caution when comparing measured vs. published ratings.

Fix: Keep in mind that while the the actual rate is just 36.55Mbps for 1x HD DVD; this is rate used when comparing HD DVD drives and other devices.


N5904

Notice N5904 : Blu-ray 1x= 36Mbps; As some device makers may use different values exercise caution when comparing measured vs. published ratings.

Fix: Keep in mind that while the the actual rate is just 36Mbps for 1x Blu-ray, 2x for video; this is rate used when comparing Blu-ray drives and other devices.


(Untitled)

No Help Available

No help is available for this message box.


Reset the Module List

If you have played with the module list (swapping icons back and forth) or other module options you can reset them to the default this way:

  1. Open Registry Editor.
  2. Double-click HKEY_USERS
  3. Double-click .Default
  4. Double-click Software
  5. Double-click SiSoftware
  6. Double-click Sandra
  7. Right-click Modules and select Delete
  8. Answer Yes to the confirmation dialogue box
  9. Close Registry Editor


Reset All Sandra Options

If you have played with the Sandra’s options and messed them up, here’s how you can reset them to the built-in defaults (no need to reinstall):

  1. Open Registry Editor.
  2. Double-click HKEY_USERS
  3. Double-click .Default
  4. Double-click Software
  5. Double-click SiSoftware
  6. Right-click Sandra and select Delete
  7. Answer Yes to the confirmation dialogue box
  8. Close Registry Editor


CIM (DMI/SMS) Report Format

CIM Format

The file extension used by the report generator is .mif

The class specified is SiSoftware|SiSoftware Sandra|001

The report uses the Component tag. The start of the report is marked by the Start Component tag and the end of the report is marked End Component.

The module uses the Group tag. The start of the module is marked by the Start Group tag and the end of the module is marked End Group. The module is at level 1.

The device class uses the Group tag. The start of the device class is marked by the Start Group tag and the end of the device class is marked End Group. The device class is at level 2, i.e. within a module group.

The device uses the Group tag. The start of the device is marked by the Start Group tag, and the end of the device is marked End Group. The device is at level 3, i.e. within a device class group.

The information group uses the Group tag. The start of the information group uses the Start Group tag, and the end of the information group is marked End Group. The information group is at level 4, i.e. within a device group.

The information item uses the Attribute tag. The start of the information item uses the Start Attribute tag, and the end of the information item is marked End Attribute. The information item can be found at any levels from 1 to 4.

The useful attributes of an information item are Name and Value. The other can be useful for SMS/DMI systems or compatible.

Here’s an example:

Start Component
  Name = "SiSoftware Sandra"
  Description = "SiSoftware Sandra"

  Start Group
    Name = "Sound Card Information"
    ID = 6
    Class = "SiSoftware|SiSoftware Sandra|001"
    Description = "Sound Card Information"

    Start Group
      Name = "Wave Input Devices (Recording)"
      ID = 1
      Class = "SiSoftware|SiSoftware Sandra|001"
      Description = "Wave Input Devices (Recording)"

      Start Group
        Name = "SB Live! Wave In [D000]"
        ID = 1
        Class = "SiSoftware|SiSoftware Sandra|001"
        Description = "SB Live! Wave In [D000]"

        Start Group
          Name = "General Device Information"
          ID = 1
          Class = "SiSoftware|SiSoftware Sandra|001"
          Description = "General Device Information"

          Start Attribute
            Name = "Device Name"
            ID = 1
            Description = "Device Name"
            Access = Read-Only
            Storage = Common
            Type = String(64)
            Value = "SB Live! Wave In [D000]"
          End Attribute


Web/HTML Report Format

Web/HTML Format

The file extension used by the report generator is .htm not .html.

The HTML file format adheres to HTML 4.0 but only uses HTML 3.0 tags and thus should display on almost all browsers.

The report is one huge table. Thus the browser must support tables – otherwise it will not display correctly.

The page has a built in style definition block, but you can overwrite it by providing a ReportStyle.css style sheet in the same folder as the report.


Report Format

Report/Hierarchical Format

The file extension used by the report generator is .rpt

The format follows the Windows INI file format with special tags to identify modules, device classes, devices, sub-titles and attributes.

A module has the tag [module:{mn}] where mn is the name of the module. Underneath this tag, the classes belonging to this module are listed.

A class tag also contains the module name in the tag name, thus for [class:{cn}module:{mn}] cn is the class name and mn is the module the class belongs to. Every class has a parent module. Underneath this tag, the devices belonging to this class are listed.

A device tag also contains both the module and class names, thus for [device:{dn}class:{cn}module:{mn}] dn is the device name, cn is the class it belongs to and mn is the module it belongs to. Underneath this tag, the attributes are listed.

A sub-title has the tag sn=a,b where sn is the sub-title name, a is the icon ID (internal) and b is the formatting style (internal).

An attribute has the tag an=a,b,vn where an is the attribute name, a is the icon ID (internal), b is the formatting style (internal) and vn is the value of the attribute.

Here’s an example:

[module:{Sound Card Information}]

Wave Input Devices (Recording)=0

[class:{Wave Input Devices (Recording)}module:{Sound Card Information}]

SB Live! Wave In [D000]=0

[device:{SB Live! Wave In [D000]}class:{Wave Input Devices (Recording)}module:{Sound Card Information}]

General Device Information=1,0

Device Name=-1,0,SB Live! Wave In [D000]


Web/XML Report Format

XML Format

The file extension used by the report generator is .xml

The DTD schema for the file is called ReportSchema.dtd and can be found in the \Examples folder within the Sandra folder.

The XML schema for the file is called ReportSchema.xml and can be found in the \Examples folder within the main Sandra folder.

An example XLS style-sheet to convert a XML report into HTML can be found in the \Examples folder – name ReportStyle.xls.

An example of a dynamic HTML page (MS-IE 5.0 or later required) that shows how to generate HTML from XML using a XLS can be found in the \Examples folder – name Dynamic XML Report.htm.

  • The report uses the <TReport> tag and contains at least one module.
  • The module uses the <TModule> tag and contains a title, one or more device class(es), one or more device(s), one or more information group(s) or one or more information item(s).
  • The device class uses the <TDeviceClass> tag and contains a title, an icon ID and one ore more device(s).
  • The device uses the <TDevice> tag and contains a title, an icon ID and one or more information group(s).
  • The information group uses the <TInfoGroup> tag and contains a title, an icon ID and one or more information item(s).
  • The information item uses the <TInfoItem> tag and contains a title, an icon ID, a format specifier and a value tag.
  • The useful tags are <Title> and <Value>, the others are reserved.

Here’s an example:

<TReport>

  <TModule>
    <Title>Sound Card Information</Title>

    <TClass>
      <Title>Wave Input Devices (Recording)</Title>
      <Icon>0</Icon>

      <TDevice>
        <Title>SB Live! Wave In [D000]</Title>
        <Icon>0</Icon>

        <TInfoGroup>
          <Title>General Device Information</Title>
          <Icon>1</Icon>

          <TInfoItem>
            <Title>Device Name</Title>
            <Icon>-1</Icon>
            <Format>0</Format>
            <Value>SB Live! Wave In [D000]</Value>
          </TInfoItem>


Scrollbars

Displayed at the right and bottom edges of the document window. The scroll boxes inside the scroll bars indicate your vertical and horizontal location in the document. You can use the mouse to scroll to other parts of the document.


Status Bar

The status bar is displayed at the bottom of the application window. To display or hide the status bar, use the Status Bar command in the View menu.

The left area of the status bar describes actions of menu items as you use the arrow keys to navigate through menus. This area similarly shows messages that describe the actions of toolbar buttons as you depress them, before releasing them. If after viewing the description of the toolbar button command you wish not to execute the command, then release the mouse button while the pointer is off the toolbar button.

The right areas of the status bar indicate which of the following keys are latched down.


T2

Tip T2 - This tip just reminds you that you can double-click tip or press Enter while a tip is selected for more information about the tip.

Related Topics

If you need more information than a tip provides, please see the (FAQ).


T10

Tip T10 : This module is capable to test connected devices to the current system, i.e. PDA and Smart Phone devices not just the current desktop/notebook.

To test your PDA / Smart Phone instead, use the Switch Test System button on the toolbar. You can then switch back to your desktop/notebook.


T11

Tip T11 : This module can show the benchmark results in two modes, either detailed (generally using a graph) or combined (generally using bars).

You can use the Switch Chart Type toolbar button switch between the two display modes.


T100

Tip T100 - Large memory systems (1GB or greater) should use Registered/Buffered memory, especially if more than 2 are installed on the same channel. This improves signal quality by reducing the load on the chipset channel. While these modules add an extra clock delay due to the on-board buffers (thus CL2 effectively becomes CL3), the stability will be worth it. Server chipsets with many memory slots generally require Registered memory.

Fix: If you plan on adding more memory, consider replacing the modules with Registered/Buffered modules. Do note that you cannot mix Unbuffered and Registered/Buffered modules on the same channel, but you may be able to if the chipset has multiple memory channels.


(Untitled)

Tip T101 - Large memory systems (1GB or greater) should be ECC/Parity. Since the probability that a bit will be corrupt is the same or increases with module density, the bigger the module, the bigger the overall probability that you will get one or more corrupted bits. While these modules add an extra delay on partial writes (e.g. less than data width) as parity for the whole line must be re-calculated, the stability will be worth it.

Fix: If you plan on adding more memory, consider replacing the modules with ECC/Parity modules. Do note that running plain and ECC/Parity modules will turn off ECC/Parity for the whole memory array.


T102

Tip T102 - You are using the ANSI version of Sandra. For Windows NT/2000/XP/2003 systems consider using the Unicode version, native for these platforms.

Fix: Uninstall Sandra; when re-installing select the Unicode version of Sandra. You may need to upgrade if such an option is not available.


T103

Tip T103 - Servers generally use ECC/Parity memory. Since the probability that a bit will be corrupt increases with the operational time and servers are in operation longer than typical workstations/home computers the risk of corruption is greater.

Fix: If you plan on adding more memory, consider replacing the modules with ECC/Parity modules. Do note that running plain and ECC/Parity modules will turn off ECC/Parity for the whole memory array.


T200

Tip T200 - SMBIOS/DMI (System Management or Desktop Management Interface) is not supported. The operating system may not be able to tune the system to maximum performance.

Fix: Try to upgrade (flash) the BIOS if possible. Check whether a BIOS update is available from your mainboard/PC manufacturer.


T201

Tip T201 - The system BIOS is more than 3 years old.

Fix: Try to upgrade (flash) the BIOS if possible. Check whether a BIOS update is available from your mainboard/PC manufacturer.


T202

Tip T202 - Windows needs a 586 class CPU or better for optimum performance. Windows XP/2003 and later needs a 686 class CPU or better for optimum performance.

Fix: You should upgrade to a 585, 686 class machine or better to run at peak performance.


T203

Tip T203 - A Plug & Play BIOS is required for today’s hardware.

Fix: Check whether a BIOS update is available from your mainboard/PC manufacturer.


T205

Tip T205 - Most new games, multi-media software and some applications can run faster and better on MMX CPUs. Since a MMX version also means a new, improved CPU even if MMX is not used you will still get 10-20% faster performance.

Fix: You need to upgrade to a MMX processor. If your mainboard supports MMX (dual-voltage) then you can buy a normal processor, otherwise you’ll need an OverDrive.


T207

Tip T207 - A SMBIOS/DMI 2.3 compliant BIOS can allow the operating system and special programs to tune-up your system.

Fix: Try to upgrade (flash) the BIOS if possible. Check whether a BIOS update is available from your main board/PC manufacturer.


T208

Tip T208 - The BIOS does not support the Enhanced Disk Drive Specification. You may not be able to use the latest disk drives and technologies (e.g. 4-8GB and larger).

Fix: Try to upgrade (flash) the BIOS if possible. Check whether a BIOS update is available from your main board/PC manufacturer.


T209

Tip T209 - The BIOS is not NEC PC98 compliant. All Japanese computers sold in 1998 and later should be.

Fix: You cannot have a NEC PC98 compliant system by upgrading the BIOS only - your peripherals must support certain advanced functions as described in the specification. This applies only to Japanese systems.


T210

Tip T210 - The main board supports faster CPUs so you don’t need to upgrade the main board when you decide to install a new CPU. However, a new main board will yield faster performance with a new CPU simply because it will use a new chipset.

Fix: Nothing to fix.


T211

Tip T211 - The BIOS can be updated (flashed) using a special program. This is a very important feature to keep your system up-to-date with new hardware.

Fix: Nothing to fix.


T212

Tip T212 - The BIOS can be shadowed. Shadowing is a technique of copying the BIOS program from slow EPROM or EEPROM to RAM. This may yield some increase in performance.

Fix: Go to BIOS set-up and make sure that System BIOS is both shadowed and cached.


T213

Tip T213 - The BIOS cannot be updated (flashed). The only way is to buy a replacement chip. All new computers should have a BIOS that can be flashed.

Fix: You cannot fix this - but keep it in mind when your buy your next main board.


T217

Tip T217 - ECC is not enabled for the L2 cache. Modern CPUs have ECC L2 cache. Any cache errors can be detected and corrected (2 & 1 bit respectively).

Fix: This option should always be enabled for stability.


T218

Tip T218 - Most new games and multi-media software can run faster and better on 3Dnow! or Enhanced 3DNow! CPUs. 3DNow! is a powerful development of the original MMX technology although it has been made obsolete by SSE/SSE2.

Fix: You need to upgrade to a 3DNow! Processor. If your main board supports CPU voltage setting then you can buy such a processor. Check with the manual.


T219

Tip T219 - Most new games and multi-media software run faster and better on Streaming SIMD (SSE/SSE2) CPUs. SSE is a powerful development of the original MMX technology; SSE2 is an even more powerful instruction set.

Fix: You need to upgrade to a SSE/SSE2 processor. If your main board supports such a processor you just need to upgrade the CPU. Otherwise you will need a new board also. Check with the manual.


T229

Tip T229 - ECC is not enabled for the L3 cache. Modern server CPUs have ECC L3 cache. Any cache errors can be detected and corrected (2 & 1 bit respectively)

Fix:. This option should always be enabled for stability.


T232

Tip T232 - You are using the 32-bit version of Sandra on a 64-bit IA64 system. Consider using the 64-bit IA64 version of Sandra, native for this system.

Fix: Uninstall Sandra; when re-installing select the 64-bit IA64 Unicode version of Sandra. You may need to upgrade if such an option is not available.


T233

Tip T233 - You are using the 32-bit version of Sandra on a 64-bit AMD64 or EM64T system. Consider using the 64-bit AMD64/EM64T version of Sandra, native for this system.

Fix: Uninstall Sandra; when re-installing select the 64-bit AMD64/EM64T Unicode version of Sandra. You may need to upgrade if such an option is not available.


T301

Tip T301 - 64/128-bit cards need at least 4MB video memory for optimum performance. If the card has 3D functions at least 8/16MB memory is recommended as well as AGP support.

Fix: Check your video card manual to make sure that the card’s memory can be upgraded and get more memory for it.


T305

Tip T305 - Video drivers designed for Windows are 32/64-bit and are faster than older 16-bit drivers on new hardware.

Fix: Check for a new driver, specifically for your operating system version, is available for your video adapter.


T306

Tip T306 - A Plug & Play / DDC compliant video driver is recommended today since it removes most configuration/resource allocation problems and optimises the video mode as well.

Fix: If both your video card and monitor support PnP then check whether an updated video driver or BIOS, which is DDC compatible, is available.

Otherwise, you will need a new monitor or video adapter that supports DDC.


T310

Tip T310 - DirectDraw is not installed. All recent and future Windows games and multi-media applications use DirectDraw so you may need to install it sooner or later. Also, full-motion video players may run faster with it.

Fix: Install the latest version of DirectX.


T311

Tip T311 - Direct3D is not installed. New Windows 3D games and multi-media applications are starting to use Direct3D for 3D rendering.

Fix: Install the latest version of DirectX.


T312

Tip T312: The OpenGL driver is not hardware accelerated.

Fix: If you have a modern graphics card, the video driver should include an ICD/MCD to accelerate OpenGL functions. This will allow you to use OpenGL software and games on your computer where it was intended to be used. Check whether an OpenGL driver is available for your video card.


T315

Tip T315 - 15-bit colour depth uses 15-bit which is not a multiple of 8-bit (a byte) like 16-bit modes (2 bytes). Most adapters use 16-bit anyway for 15-bit since it’s faster but reduce the number of simultaneous colours available on the display to 32K instead of 64K.

Fix: 16-bit modes instead of 15-bit always.


T316

Tip T316 - A DPMS saving monitor can turn itself off (when instructed by the video adapter) and thus reduce power consumption as well as increasing its life. Nowadays all monitors should support DPMS.

Fix: You cannot fix it - but keep it in mind when you buy your next monitor.


T319

Tip T319 - Usually, a refresh rate of 75Hz or more is necessary to completely remove flicker from monitor screens - depending on resolution, the brightness of the display and the person itself. If you have a flat-panel (LCD) display ignore this tip.

Fix: Switch to a higher refresh rate from Control Panel\Display\Display Properties\Settings, click Advanced Properties\Adapter. Choose the highest supported.


T322

Tip T322 - It is better (and greener) to use the power-down function of the monitor instead of the silly screen saver. You are supposed to save the screen!

Fix: Go to Control Panel\Display\Display Properties\Screen Saver, set the Screen Saver to (none) and set time-outs for Low-power standby and Shut-off monitor.


T323

Tip T323 - Unless you have a lot of RAM and computing power, using a desktop wallpaper consumes memory and decreases the display speed since it must be re-painted when needed.

Fix: Go to Control Panel\Display\Display Properties\Background set the Wallpaper to (none).


T324

Tip T324 - The video driver you are using was included with Windows itself. While this means it is certified to be stable, almost certainly an updated driver is available from the video adapter manufacturer that should be superior overall.

Fix: Check whether an updated driver is available from the video card manufacturer.


T325

Tip T325 - Windows animation is cute at the beginning but reduces display speed and can become annoying.

Fix: Turn it off using the TweakUI utility from Microsoft’s PowerToys.


T326

Tip T326 - Animated cursors are fun but they consume memory and quite a few processor time. Unless you have the very latest video adapter they also flicker.

Fix: Unless you’re really keen on them you could consider turning them off from Control Panel\Mouse\Pointers.


T327

Tip T327 - While 24-bit or 32-bit colour modes provide the best palettes for graphic use and modern games and multimedia programs, most video cards are much slower in 32-bit than in 16-bit. Also more memory and resources is consumed for storing screen bitmaps and textures.

Fix: Consider switching to 16-bit mode. In most cases, the quality is just as good.


T328

Tip T328 - Higher resolution increase the desktop available and can increase productivity. The resolution you’re using is very high which may reduce the range of colour depths as well as the refresh rates supported.

Fix: Consider reducing it to balance the resolution with colour depth and refresh rate.


T329

Tip T329 - For full-movie movie playback (MPEG, DVD) you need to use 24/32-bit colour depth if you want to get a quality picture.

Fix: Switch to 24 or 32-bit colour modes.


T330

Tip T330 - Using small icons will make them harder to see and click but you will gain a considerable increase in usable desktop space.

Fix: Go to Control Panel\Display\Plus! And uncheck Use Large Icons.


T331

Tip T331 - Using small fonts will make text harder to read and dialogues smaller but you will gain a considerable increase in usable desktop space.

Fix: Go to Control Panel\Display\Settings and choose Small Fonts from the Font Size combo-box.


T332

Tip T332 - Modern monitors are Plug & Play (VESA/DDC) compatible. Windows detects them automatically and optimises the refresh rates automatically.

Fix: You cannot fix this if your monitor is not Plug & Play - unless you buy a new one. If your monitor is PnP but your video card is, make sure that you buy one that supports PnP when you decide to replace it. If both are PnP, make sure you have the latest driver and video BIOS for your video card. If you have a BNC cable you need to use the standard 15-pin one - PnP does not work over BNC.


T401

Tip T401 - the resolution of the printer is low for this type of printer. Make sure this is what you want, otherwise you will get less quality print-outs than possible with your printer.

Fix: Go to Control Panel\Printers, right-click this printer and choose Properties\Graphics and change the Resolution.


T403

Tip T403 - generally you should use the EMF data format since it is faster and takes less space. Use RAW only if the printer (i.e. faxes) cannot use EMF, only RAW data format.

Fix: Go to Control Panel\Printers, right-click this printer and choose Properties\Details click Spool Settings and choose EMF from the Spool Data Format check-box.


T404

Tip T404 - while printing directly is faster, your machine may become unresponsive during printing. Spooling the print data takes longer but your machine will become available sooner.

Fix: Go to Control Panel\Printers, right-click this printer and choose Properties\Details click Spool Settings and choose Spool Print Jobs together with Spool After the first page is spooled.


T405

Tip T405 - if you use the actual fonts built-in your printer you will get faster printing since the fonts do not need to be downloaded or rendered.

Fix: See your printer manual for the list of built-in fonts. If you have a print cartridge installed make sure you installed the soft fonts that come with it so that Windows can use them. Go to Control Panel\Printers, right-click this printer and choose Properties\Fonts and enter the relevant information there.


T406

Tip T406 - you’re using a very high resolution. While the quality increases, so do the printing speed and resources consumed. Unless you really need to use it, you should reduce it.

Fix: Go to Control Panel\Printers, right-click this printer and choose Properties\Graphics and change the Resolution.


T407

Tip T407 - by optimising the PostScript driver settings you may obtain faster printing and/or better quality.

Fix: See your printer manual for more information. Go to Control Panel\Printers, right-click this printer and choose Properties.


T500

Tip T500 - The WinSock version is earlier than 2. Version 2 introduces many new enhancements that may improve performance.

Fix: Upgrade to the latest service pack for your operating system.


T501

Tip T501 - The IPX/SPX protocol is mainly used by Netware and other LAN networks.

Fix: If you are not on a LAN, you only need TCP/IP to connect to the Internet - IPX/SPX does not help you. Even if you have a LAN, most LANs use NetBEUI that is the default for Microsoft networks. In these cases you should remove IPX/SPX. Open Control Panel\Network\Configuration, click on IPX/SPX and click Delete. Reboot your computer.


T707

Tip T707 - Today’s sound cards use 16-bit sampling which offers better sound quality.

Fix: While 8-bit devices still work you should upgrade your sound card.


T708

Tip T708 - Today’s sound cards support at least 2 channels (stereo). Stereo, 4, 5.1 and 7.1 channel devices have long superseded mono sound cards.

Fix: You should upgrade your sound card.


T709

Tip T709 - Your sound card does not support the high quality sample rates used for high quality (CD) music. The quality of sound from audio devices (wave, video, etc.) may be less than optimal.

Fix: You should upgrade your sound card if possible.


T800

Tip T800 - Make sure the Accesibility Features are not enabled by mistake. If you are not disabled it or you don’t use them it’s best to either uninstall them or disable them.

Fix: Go to Control Panel\Add/Remove Programs\Windows Setup and uncheck Accessibility Options. On Windows 2000/XP/2003 you cannot fully remove them, so just disable them.


T803

Tip T803 - a mouse with wheel (e.g. IntelliMouse) will greatly enhance your control in Windows, especially when browsing and using complex applications.

Fix: Consider getting one as it will improve your Windows and Internet experience.


T804

Tip T804 - you have a serial/bus mouse. Modern computers use PS/2 or USB mice. This way you can have both serial ports free to use with serial devices.

Fix: If your mainboard has PS/2 or USB sockets (check the manual) then you’ll need to purchase such a mouse. Keep this in mind when you buy your next computer.


T900

Tip T900 - Make sure the Accesibility Features are not enabled by mistake. If you are not disabled it or you don’t use them it’s best to either uninstall them or disable them.

Fix: Go to Control Panel\Add/Remove Programs\Windows Setup and uncheck Accessibility Options. On Windows 2000/XP/2003 you cannot fully remove them, so just disable them.


T1006

Tip T1006 - Drive spin-down is not very useful for desktops running from the mains since other devices consume much more power. Usually hard drives are left running since this keeps the temperature relatively constant which requires less thermal re-calibration.

Fix: Go to Control Panel\Power\Disk Drives and uncheck the checkbox next to When powered by AC power.


T1007

Tip T1007 - ACPI (OnNow!) is not supported. ACPI can put the system in hibernate mode or suspend its state to disk thus making boot-up almost instantaneous. Also, it manages the power much better resulting in a more efficient system.

Fix: Check whether a system BIOS upgrade is available.


T1100

Tip T1100 - Typically desktops don’t need to use APM. Monitors don’t need APM to shut-down, this is done using VESA/PM by the video adapter.

Fix: Unless you’re actually using it, go to BIOS Setup\APM and disable it. If you are using it run the Control Panel\Add New Hardware Wizard to install the drivers for APM. If ACPI enabled you should disable APM.


T1104

Tip T1104 - The latest version of APM adds various new improvements.

Fix: Check whether a system BIOS upgrade is available.


T1200

Tip T1200 - As discussed above, PCI 2.10 revision offers more functions and greater compatibility since the new PCI devices are 2.120 compatible and may not run on older versions.

Fix: Check whether a system BIOS upgrade is available. This will only work if the chipset can support PCI 2.10.


T1202

Tip T1202 - Bus mastering is a method of transmitting data by taking control of the bus. This is much faster than making many smaller transactions if a lot of data is to be transferred over the bus. Advanced devices transferring a lot of data support this feature.

Fix: You cannot fix this - but keep it in mind when buying your next device.


T1205

Tip T1205 - An AGP 2/3 or later device (or AGP Pro) video board and chipset would offer better performance.

Fix: AGP 2 offers 4x transfers, fast-writes and other enhancements to speed-up video performance further. AGP 3 offers 8x transfers. You cannot update AGP 1 hardware to AGP 2/3 or later! When upgrading, upgrade to an AGP 2/3 or later device.


T1300

Tip T1300 - If you are the owner of this copy of Windows and this computer is at your home it is customary to enter the house name and address or just home.

Fix: You need to use a utility like Winhacker, Tweaki or MoreControl to change this setting.


T1301

Tip T1301 - You should enter you full name if you’re the owner of this copy of Windows.

Fix: You need to use a utility like Winhacker, Tweaki or MoreControl to change this setting.


T1305

Tip T1305 - Windows has been running for a long time on this machine. Performance may deteriorate over time due to rogue programs or memory fragmentation.

Fix: You should reboot it regularly.


T1307

Tip T1307 - The registry is much larger than usual. If you have installed and un-installed many programs or have used Windows for years it may be time to clean-up.

Fix: Use a registry clean program like Microsoft RegClean or Norton WinDoctor.


T1308

Tip T1308 - While the Windows logo is cute, if you want to see the boot-up messages and boot faster you should consider turning it off.

Fix: Install the Microsoft Power Toys and go to Control Panel\TweakUI\Boot and uncheck Display splash screen while booting.


T1309

Tip T1309 - The task-bar should be set to auto-hide to maximise available desktop space, especially on a small monitor. This way you get the best of both worlds unless you need to switch between applications regularly.

Fix: Right-click on the task-bar, choose Properties and check Auto Hide.


T1314

Tip T1314 - You are using 32-bit Windows on a 64-bit IA64 machine. Consider using the native Windows 64-bit IA64 version for your machine. This version is native for your machine instead of using legacy/compatibility mode.

Fix: You will need to upgrade to Windows 2003 64-bit IA64 edition.


T1315

Tip T1315 - You are using 32-bit Windows on a 64-bit AMD64 machine. Consider using the native Windows 64-bit AMD64 version for your machine. This version is native for your machine instead of using legacy/compatibility mode.

Fix: You will need to upgrade to Windows 2003 64-bit AMD64 edition.


T1400

Tip T1400 - To get reliable and fast communications in Windows the UART driving the COM port must have large (e.g. 10-16+) internal data buffers. Only 16550 or later UARTs do and you should have at least a 16550A UART especially if you have a high-speed modem.

Fix: You may need to use an internal modem or buy a fast serial card for your computer.


T1803

Tip T1803 - the maximum disk cache size is low for the amount of system memory you have installed. Generally this should not be lower than ¼ of physical memory installed.

Fix: Compute ¼ of you physical memory in kilobytes (say 8192KB for 32MB). In system.ini find the [vcache] section and add MaxFileCache=8192 (i.e. the number you computed). Reboot Windows.


T1804

Tip T1804 - the minimum disk cache size is high for the amount of system memory you have installed. The system may need to use the swap file more, thus decreasing performance. Generally, this should not be higher than ¼ of physical memory installed.

Fix: Compute 1/8 of you physical memory in kilobytes (say 4096KB for 32MB or use 512KB). In system.ini find the [vcache] section and add MaxFileCache=512 (i.e. the number you computed). Reboot Windows.


T1805

Tip T1805 - if you have a lot of memory, changing the typical role to network server will improve disk performance at the expense of memory - but this should not be a problem for you.

Fix: Go to Control Panel\System\Performance\File System\Hard Disk and select Network Server as Typical role of this machine.


T1806

Tip T1806 - if you have little memory installed, changing the typical role to mobile computer will decrease memory usage, and thus improving overall performance.

Fix: Go to Control Panel\System\Performance\File System\Hard Disk and select Mobile Computer as Typical role of this machine.


T1807

Tip T1807 - the size of the read-ahead buffer is too small for the size of the memory installed. You should set it to maximum to improve disk performance.

Fix: Go to Control Panel\System\Performance\File System\Hard Disk and move the Read-ahead optimisation slider to Full.


T1809

Tip T1809 - the CD-ROM cache size is too large compared to the amount of physical memory installed. You should reduce it to improve overall system performance at the expense of a slight drop in CD-ROM performance.

Fix: Go to Control Panel\System\Performance\File System\CD-ROM and move the Supplemental cache size slider towards Small.


T1810

Tip T1810 - using a 32/64-bit disk driver is recommend. If you are using a legacy 16-bit driver there must be a conflict between Windows and such a driver.

Fix: Remove old device drivers from config.sys and let Windows use a native driver. If Windows does not have such a driver, contact the computer manufacturer for an updated driver.


T1811

Tip T1811 - turning on the troubleshooting options may result in incompatibilities. Generally you should not change them.

Fix: Go to Control Panel\System\Performance\File System\Troubleshooting and uncheck all the boxes there.


T1812

Tip T1812 - the Recycle Bin size is rather large compared to the free disk space on this drive.

Fix: Consider emptying it - but check whether you are likely to need any of the deleted files: you won’t be able to get the back! Right-click on it, choose Properties\Global and move the slider to reduce the percentage of space allocated to the Recycle Bin.


T1813

Tip T1813 - you should scan you drive for errors at least weekly to prevent data loss or other problems. Set-up an automatic scan at pre-defined times.

Fix: Right-click on the drive in My Computer, select Properties\Tools and click Check Now.


T1814

Tip T1814 - you should optimise the drive at least monthly to keep it in shape.

Fix: Right-click on the drive in My Computer, select Properties\Tools and click Defragment Now.


T1815

Tip T1815 - if you have moderate memory installed, changing the typical role to desktop computer may yield the best performance.

Fix: Go to Control Panel\System\Performance\File System\Hard Disk and select Desktop Computer as Typical role of this machine.


T1816

Tip T1816 - the CD-ROM optimise pattern may be set up incorrectly. Generally it should match the speed of the CD-ROM drive.

Fix: Go to Control Panel\System\Performance\File System\CD-ROM and select the correct speed for your drive from the Optimise access pattern for combo-box.


T1817

Tip T1817 - you should back-up the drive at least weekly to prevent data loss. You should schedule backups at regular intervals to tape, CD-ROM, DAT, etc.

Fix: Right-click on the drive in My Computer, select Properties\Tools and click Backup Now.


T1818

Tip T1818 - you should scan the drive for viruses at least weekly, even if you have a virus monitor program. You never know how viruses manage to sneak in downloaded files and other similar ways.

Fix: If you have an anti-virus program installed (e.g. Norton Anti-Virus), right-click on the drive in My Computer and select Scan.


T1819

Tip T1819 - you should image the drive at least weekly to improve the chances of error detection and correction should any problems arise.

Fix: Right-click on the drive in My Computer, select Properties\Norton and click Image Now.


T1820

Tip T1820 - your virus definition files seem old. You should update them at least quarterly, preferably monthly.

Fix: Use the Norton On-Line Update Wizard to download the new virus definition files.


T1821

Tip T1821 - generally, all drives should have names.

Fix: Label/name the drive.


T1822

Tip T1822 - DMA transfers are not enabled for this drive. Check whether your drive supports DMA transfers and enable it in Control Panel - System. DMA is faster as the processor is not involved in the data transfer and can do other processing in the meantime.

Fix: Go to Control Panel\System\Device Manager, click Disk Drives and double click the drive. Click Settings and check the DMA check-box.


T1823

Tip T1823 - while ATA drives are cheap and fast, SCSI drives and controllers are recommended for their performance as well as upgradability. You should use SCSI devices if you can.

Fix: You cannot fix this - but keep it in mind when you buy your next device. Make it SCSI.


T1828

Tip T1828 - the CD-ROM cache size is too small for the physical amount of memory installed. You should increase this to increase the CD-ROM performance.

Fix: Go to Control Panel\System\Performance\File System\CD-ROM and move the Supplemental cache size slider towards Large.


T2000

Tip T2000 - You need to install more memory to use Windows at peak performance.

Fix: Upgrade your memory. Check your mainboard manual first to make sure which type and speed of memory is needed. As a rough Windows 2000/XP needs about 256MB, Windows 2003 512MB and Windows Vista 1GB or more.


T2005

Tip T2005 - While letting Windows manage the swap file is safer, performance may suffer as the swap file needs to grow/shrink depending on memory requirements. Also, it may become fragmented or allocated in a different part of the disk, which further reduces performance.

Fix: Defragment your drive first. Go to Control Panel\System\Performance\Virtual Memory, select Let me specify my own virtual memory settings, select the fastest and roomiest drive. Calculate 2 times your physical memory and enter this number in both Maximum and Minimum boxes.

NB. If you want more safety, leave the Maximum blank so that Windows can grow the swap file should you run out of virtual memory; the Minimum will ensure the swap file is generally not fragmented.

NB. On systems with 128MB or more you may consider creating a swap file equal to the memory size unless you’re running a server that needs large amounts of memory. Systems with 256MB or more could run with no swap file at all.


T2009

Tip T2009 - Memory doublers/compressors rarely do what it is stated on the box and are more trouble than they are worth. Since physical memory prices are rather low it is better to buy more physical memory than use software memory compressors.

Fix: You should remove the memory doubler.


T2130

Tip T2130 - Service may be disabled on Personal/Professional version of the OS.

Fix: If you want to conserve resources, you may disable this service if you’re using the OS for personal use - if you’re not using it. Go to Control Panel\Services and set the start-up to Demand instead of Auto so that the service will still be started if required but not by default.


T2200

Tip T2200 - DirectX is not installed on your computer. Most new games and multimedia applications use it so you’ll have to install it eventually. Also, most new drivers include DirectX components anyway.

Fix: Install the latest version of DirectX.


T2201

Tip T2201 - DirectDraw is not installed. This probably means that your video drivers are not installed properly or there is some conflict.

Fix: Install the latest version of DirectX.


T2202

Tip T2202 - Direct3D is not installed. Most new video cards should come with drivers that include Direct3D even if they do not support accelerated 3D functions.

Fix: Install the latest version of DirectX.


T2203

Tip T2203 - DirectSound is not installed. This probably means that your sound card drivers are very old. are not installed properly or there is some conflict.

Fix: Install the latest version of DirectX.


T2204

Tip T2204 - DirectPlay is not installed.

Fix: Install the latest version of DirectX.


T2205

Tip T2205 - The DirectX version installed is old.

Fix: Install the latest version of DirectX.


T2206

Tip T2206 - The video driver does not support Direct3D.

Fix: You should check for an updated video driver from the manufacturer.


T2207

Tip T2207 - Your video card does not support any hardware 3D functions or they are not implemented in this version of the video driver.

Fix: If you do have the latest video driver, consider upgrading the video card if you play 3D games.


(Untitled)

Tip T2208 - Your video card uses bank switching which is much slower than LFB (Linear Frame Buffer).

Fix: You should consider upgrading your video card.


(Untitled)

Tip T2209 - The free video memory available for Direct3D is very small.

Fix: Consider upgrading the video memory on your video adapter or reducing the resolution/colour depth of the display.


T2212

Tip T2212 - The video hardware does not support stretching in hardware. Full-screen performance for games and video will be reduced.

NB: Not applicable to 3D only cards like the 3Dfx VooDoo or VooDoo II.

Fix: You should check for an updated video driver from the manufacturer if you know the card should support this. If not, consider upgrading the video card.


T2213

Tip T2213 - The video hardware does not support overlay in hardware. Overlay video applications like TV and video capture may be affected.

NB: Not applicable to 3D only cards like the 3Dfx VooDoo or VooDoo II.

Fix: You should check for an updated video driver from the manufacturer if you know the card should support this.


T2214

Tip T2214 - The video card does not support mip-mapping. New games use this feature for improved display quality.

Fix: You should check for an updated video driver from the manufacturer if you know the card should support this.


T2215

Tip T2215 - The video hardware does not support texture mapping. This is a major function that all 3D hardware should support.

Fix: You should check for an updated video driver from the manufacturer if you know the card should support this. If not, consider upgrading the video card.


T2216

Tip T2216 - The video hardware does not support Z-buffering (depth). This is a major function that all modern 3D hardware should support.

Fix: You should check for an updated video driver from the manufacturer if you know the card should support this. If not, consider upgrading the video card.


T2217

Tip T2217 - The video hardware does not support dithering. This is used to improve the display quality especially when running in high-colour modes.

Fix: You should check for an updated video driver from the manufacturer if you know the card should support this. If not, consider upgrading the video card.


T2218

Tip T2218 - The video hardware does not support alpha-blending.

Fix: You should check for an updated video driver from the manufacturer if you know the card should support this.


T2219

Tip T2219 - The video hardware does not support perspective-correction. This is a major function that all modern 3D hardware should support.

Fix: You should check for an updated video driver from the manufacturer if you know the card should support this. If not, consider upgrading the video card.


T2220

Tip T2220 - The video hardware does not support transparency.

Fix: You should check for an updated video driver from the manufacturer if you know the card should support this.


T2221

Tip T2221 - The driver is not certified by Microsoft.

Fix: This is not a problem since most drivers are not certified (takes time) but it’s good to have a certified driver to check whether the bugs are in the driver or in the application.


T2222

Tip T2222 - The video hardware does not support fog.

Fix: You should check for an updated video driver from the manufacturer if you know the card should support this.


T2501

Tip T2501 - External or L2 cache greatly increases system performance. Without it you generally have a 15-30% slower PC especially in memory intensive applications.

Fix: Get some external cache. Check the mainboard manual first to make sure the type and size of cache supported. Also check whether the mainboard has a COAST socket where you can install this cache. Pipeline burst cache is preferred, go for 512KB or 1MB. If the cache is soldered on the mainboard you cannot change it.


T2502

Tip T2502 - While the asynchronous cache was the original type of cache used on 386, 486 & 5x86 CPUs, new chipsets work best with pipeline-burst cache. If the chipset supports it you can get 5-15% improvement just by changing the cache.

Fix: Get some pipeline burst cache. Check the mainboard manual first to make sure this type is supported. Also check whether the mainboard has a COAST socket where you can install this cache. If the cache is soldered on the mainboard you cannot change it.


T2503

Tip T2503 - If you have 64MB or more you should have 512KB L2 cache installed for optimum performance. Also check whether the chipset can cache more than 32/64MB of memory. With some mainboards you need to increase the cache when you increase memory.

Fix: If the mainboard has a COAST socket and supports more than 256KB of cache then get 512KB or more cache - preferably pipeline-burst.


T2504

Tip T2504 - If you have a lot of memory (256MB+) you may need as much as 1MB L2 cache. Remember that some 486 systems had 8M RAM and 256KB cache, so 1MB is little if you have 128MB RAM or more.

Fix: If you have a 586 class mainboard with a COAST socket which supports more than 256KB of cache then get 512KB or more. If you have a CPU with integrated cache, you will have to upgrade to a processor with more L2 cache.


T2509

Tip T2509 - Memory bus speed seems low. Check that you are running it at the correct speed.

Fix: Most modern (585 class or later) computers use bus speeds of 66MHz or higher. If yours is lower you may be able to increase it, depending on processor.


T2511

Tip T2511 - You still have some free memory slots so you can upgrade the memory easily when the time comes.

Fix: Nothing to fix.


T2514

Tip T2514 - The read timing for the memory seems low. Some OEMs don’t optimise the BIOS timings before shipping the computer resulting in inferior performance.

Fix: Go to BIOS set-up then Advanced BIOS Settings or Chipset Set-up and select 60ns timing if you have 60ns or faster FPM/EDO memory or decrease the memory timing from x444 to x333 or even x222. Also decrease the leadoff as much as you can (e.g. 7 or lower). If SDRAM is used, decrease the SDRAM timings (e.g. CAS2 from CAS3).


T2515

Tip T2515 - The write timing for the memory seems low. Some companies don’t optimise the BIOS timings before shipping the computer resulting in inferior performance.

Fix: Go to your BIOS set-up then Advanced BIOS Settings or Chipset Set-up and select 60ns timing if you have 60ns or faster FPM/EDO memory or decrease the memory timing from x444 to x333 and also decrease the leadoff as much as you can (e.g. 5 or lower). If SDRAM is used, decrease the SDRAM timings (e.g. CAS2 from CAS3).


T2516

Tip T2516 - Modern computers use RDRAM or SDRAM memory to improve performance.

Fix: Buy RDRAM, SDRAM or even BEDO or EDO especially if you need to add more memory. Check whether the chipset supports this kind of memory before trying this option.


T2517

Tip T2517 - Modern computers can use 60ns or even faster memory to improve performance.

Fix: If you already have EDO it’s not worth fixing. But if you have older memory, buy SDRAM or EDO especially if you need to add more memory. Check whether the chipset supports this kind of memory.


T2522

Tip T2522 - SDRAM, HSDRAM or RDRAM is recommended for systems with high memory bus speeds, e.g. 100, 133MHz or faster. If you have older memory that you want to use, check whether the system allows you to run it at AGP bus speed (66MHz). However, there will be a drop in performance.

Fix: Replace the memory with PC800 RDRAM, PC100 SDRAM, PC133 HSDRAM memory or faster. You may wish to consider CAS2 memory for faster performance. If data integrity is a priority, specify ECC memory.


T2524

Tip T2524 - The AGP aperture size may not be set properly. Generally the AGP aperture size should be at most equal to system memory and generally lower. While the GART driver will allocate memory to be used for AGP dynamically it is good to set an upper bound in order to maximise memory utilisation. In any case, it should not be disabled.

Fix: Go into BIOS Setup and change it to match system memory size or set it lower, e.g. 64MB. Note that some adapters may work better if you set it to the maximum value 256MB, or at least 64MB. Consult the video board manual for more details.


T2525

Tip T2525 - Current AGP data rate not optimal, i.e. less than chipset’s maximum AGP data rate. E.g. current AGP data rate is 1x while the chipset and the AGP card both support 2x. You should get better performance with a higher data rate but this depends on the application.

Fix: First, use the PCI & AGP Information module to confirm that the AGP card also supports the maximum chipset data rate. If it does not, don’t worry about it. For non-Intel chipsets, make sure you install the latest version of their AGP mini-drivers. You should update the video card drivers as well. Some non-Intel chipsets can only work in 1x mode with some video cards.


T2530

Tip T2530 - The MP BIOS in this machine is not MPS 1.04 or later compatible. This specification contains many improvements and is recommended for MP systems.

Fix: Check BIOS settings and set to MPS 1.04 or higher; otherwise consider a BIOS upgrade if there is no later BIOS upgrade available.


T2532

Tip T2532 - The MP system supports more CPUs than installed. Generally in order to use such a board to its full potential all CPUs should be installed.

Fix: Add more CPUs up to the maximum. You may need to upgrade the BIOS, the OS kernel, device drivers and various settings to take advantage of the new CPUs. Make sure they are all utilised by the system after installation.


T2545

Tip T2545 - Large memory modules (256MB or greater) should be Registered/Buffered, especially if more than 2 are installed on the same channel. This improves signal quality by reducing the load on the chipset channel. While these modules add an extra clock delay due to the on-board buffers (thus CL2 effectively becomes CL3), the stability will be worth it. Server chipsets with many memory slots generally require Registered memory.

Fix: If you plan on adding more memory, consider replacing the modules with Registered/Buffered modules. Do note that you cannot mix Unbuffered and Registered/Buffered modules on the same channel, but you may be able to if the chipset has multiple memory channels.


T2546

Tip T2546 - Large memory modules (512 or greater) should be ECC/Parity. Since the probability that a bit will be corrupt is the same or increases with module density, the bigger the module, the bigger the overall probability that you will get one or more corrupted bits. While these modules add an extra delay on partial writes (e.g. less than data width) as parity for the whole line must be re-calculated, the stability will be worth it.

Fix: If you plan on adding more memory, consider replacing the modules with ECC/Parity modules. Do note that running plain and ECC/Parity modules will turn off ECC/Parity for the whole memory array.


T2547

Tip T2547 - Speed set by jumpers/switch. For flexibility, consider by BIOS/software.

Fix: Set BIOS to ignore switches/jumpers or set switches to BIOS speed. Then set the speeds via the BIOS. This will also allow Sandra to read-back the speed settings.


T2548

Tip T2548 - Speed set by software. For reliability, consider by jumpers/switch.

Fix: Set BIOS to use switches/jumper settings. Set the speeds via the switches/jumpers.


T2549

Tip T2549 - Spread spectrum is off. Consider turning it on to minimise EMI (ElectroMagnetic Interference). This feature of the PLL IC (clock generator) varies the base frequency area within a certain field range to reduce strong EMI peaks that could cause interference in electronic devices.

Fix: Turn spread spectrum on in the BIOS. You may also need to use speed by BIOS instead of jumpers/switches in order to turn this on.


T2700

Tip T2700 - The number of fonts installed in this system is very high. Memory may be at a premium. Typically office suites, DTP and graphics programs may install 100’s of fonts you don’t use and don’t need.

Fix: Go to Control Panel\Fonts and go through them. Go to the View menu and select List fonts by similarity. Remove the fonts you do not use - especially if there is another one that looks very much like it already.


T2901

Tip T2901 - IP header compression is not used. Most hosts support IP header compression which reduces the packet size and therefore the overhead for data packets. It should be enabled unless you know that it causes problems.

Fix - Go to My Computer\Dial-Up Networking, right-click the connection and choose Properties\Server Types, click TCP/IP Settings and check the corresponding check-box.


T2902

Tip T2902 - Software compression is not used. Software compression will only work if both computers support it, but you should keep it enabled as most computers do. This will compress data exchanges resulting in higher throughput.

Fix - Go to My Computer\Dial-Up Networking, right-click the connection and choose Properties\Server Types and check the corresponding check-box.


T2903

Tip T2903 - PPP is not used. Currently PPP is the preferred framing protocol. UNIX machines use SLIP, Netware uses NRN, etc. Make sure that you need to use other protocol instead of PPP - if not switch to PPP.

Fix - Fix - Go to My Computer\Dial-Up Networking, right-click the connection and choose Properties\Server Types and select PPP from the combo-box.


T2904

Tip T2904 - A script file is not used. If you connect to a system daily it’s easier to set-up a script file that does the log-in for you automatically. This way you can be connected at a touch of a button.

Fix - Windows 2000/XP/2003 have it built-in. Read the documentation on how to write a script file then go to Go to My Computer\Dial-Up Networking, right-click the connection and choose Properties\Scripting and enter the filename in the corresponding box.


T3100

Tip T3100 - SMART is not enabled. For safety/reliability it is best for it to be enabled. SMART monitors critical drive parameters and is able to warn you if the drive is about to fail so that you can back up the data and replace the drive. It has minimal performance impact that is offset by the security.

Fix: Look in the BIOS settings and enable SMART monitoring for all drives.


T5000

Tip T5000 - the processor utilisation is too high. This means that there are background applications that are using the processor while the benchmark is executing.

Fix: You should close these processes down as they interfere with the benchmark.


T5001

Tip T5001 - the Dhrystone score seems low for this type of processor/class.

Fix: Check whether the settings are correct.


T5002

Tip T5002 - the Whetstone score seems low for this type of processor/class.

Fix: Check whether the settings are correct.


T5008

Tip T5008 - If you want to run a specific benchmark instead of the best benchmark for the system click the Option button and enable/disable the benchmarks you want.

Fix: Nothing to fix.


T5201

Tip T5201 - the disk index seems low for this type of drive.

Fix: Check controller settings and driver settings.


T5202

Tip T5202 - If use cache option is disabled in the benchmark the Windows disk cache is bypassed by the test. Generally programs do not do this as this improves disk performance significantly.

Fix: If you want to measure Windows disk performance set the benchmark to use the Windows disk cache from module options.


T5203

Tip T5203 - If use cache option is enabled in the benchmark the Windows disk cache is not bypassed by the test. The results may not tally with the results expected for the drive or controller.

Fix: If you want to measure the raw disk controller/drive performance set the benchmark to bypass the Windows disk cache from module options.


T5207

Tip T5207 - Consider using the File Systems instead if the device is non-Flash based. As there is no reliable way to know the physical type of the device, it is left to the user to use the correct benchmark.

Fix: This benchmark has been optimised for solid state (Flash) media, and thus will not yield correct results on other devices. Such devices have negligible seek times and are transfer-speed bound, generally by the interface (e.g. USB 1.x). This is not the case for magnetic based devices like floppies, hard disks and tapes.


T5208

Tip T5208 - Consider using the Removable Storage instead of the device is Flash based. As there is no reliable way to know the physical type of the device, it is left to the user to use the correct benchmark.

Fix: This benchmark has been optimised for magnetic (floppies, hard disks, etc.) where seek times are significant and usually more important than actual transfer speed, i.e. the device is not interface bound. This is not the case for solid state (Flash) media.


T5300

Tip T5300 - a bigger media disc is recommended for thorough testing. Otherwise the results may have a higher degree of inaccuracy.

Related Topics

Fix: See Error E5300 for more information.


T5301

Tip T5301 - for best results use an official Sandra media test disc or compatible.

See Error E5300 for more information.


T5302

Tip T5302 - your drive is DVD capable. To test its performance, use a test DVD disc.

Fix: Use the Sandra test DVD or a compatible disc.

NB. Commercial DVD discs (movies, etc.) cannot be used in general as they are encrypted thus cannot be read. If you do not have the Sandra test DVD you will need to burn yourself one.


T5303

Tip T5303 - your drive is CD capable. To test its performance, use a test CD disc.

Fix: Use the Sandra test CD or a compatible disc.

NB. Commercial CD discs (audio, video, etc.) that are copy protected may not be usable. If you do not have the Sandra test CD you will need to burn yourself one.


T5304

Tip T5304 - your drive is HD DVD capable. To test its performance, use a test HD DVD disc.

Fix: Use the Sandra test DHD VD or a compatible disc.

NB. Commercial HD DVD discs (movies, etc.) cannot be used in general as they are encrypted thus cannot be read. If you do not have the Sandra test HD DVD you will need to burn yourself one.


T5305

Tip T5305 - your drive is Blu-ray capable. To test its performance, use a test Blu-ray disc.

Fix: Use the Sandra test Blu-ray or a compatible disc.

NB. Commercial Blu-ray discs (movies, etc.) cannot be used in general as they are encrypted thus cannot be read. If you do not have the Sandra test Blu-ray you will need to burn yourself one.


T5306

Tip T5306 - your drive is CD Audio capable. To test its audio ripping performance, use a test CD Audio disc.

Fix: Use the Sandra test Audio CD or a compatible disc.

NB. Commercial Audio CD discs that are copy protected may not be usable. If you do not have the Sandra test Audio CD you will need to burn yourself one.


T5500

Warning T5500 - The CPU does not support MMX/SSE(2) instructions, the ALU is used instead. While the code is optimised for greater performance on modern CPUs, the performance will be much lower than on a MMX/SSE(2) processor.

Fix: Upgrade to a MMX or SSE(2) processor.


T5501

Warning T5501 - The CPU does not support SSE(2) or 3DNow! instructions, the FPU is used instead. While on processors with pipelined FPUs (e.g. Pentium II) the optimised FPU code runs quite fast, performance will be lower than when using a SSE(2) or 3DNow! capable processor.

Fix: Upgrade to a SSE(2) or 3DNow! processor.


Tip of the Day

Shows a tip of the day from Sandra’s tip database. This is a standard feature on modern Windows applications.


Toolbar

The toolbar is displayed across the top of the application window, below the menu bar. The toolbar provides quick mouse access to many tools used in this application.

To hide or display the Toolbar, choose Toolbar from the View menu (ALT, V, T).


Auto Arrange

Auto arranges the module list


Details/Report

Shows modules in a report and shows module information.


Large Icons

Use Large Icons for the module list.


List

List/Tile

Shows modules in a list or tiles.


Small Icons

Use Small Icons for the module list.


W1

Warning W1 - Please read the help file (i.e. this document), the (FAQ) and make sure you know what you're doing before proceeding.


W2

Warning W2: Benchmarking stresses components. Some components may fail if they have any weaknesses.

Fix: Just make sure you understand what this means; as per Licence, SiSoftware will not accept any liability for any component failures as a result of benchmarking, testing, etc.


W3

Warning W3 - No data has been generated by the module thus the list is empty. Some options are disabled which may account for this. Make sure you do want those options turned off. You should consider turning them on to get data in this module.


(Untitled)

Warning W4 - All options for this module are disabled thus no data has been generated. If you don’t need this module you can delete it; otherwise consider enabling some of the options to get some data in this module.


W204

Warning W204 - Older CPUs (e.g. 486) do not support the CPU identify instruction.

Fix: You should upgrade to a 585 class machine if you have a 386 or 486 system. Some early 586 systems also don’t support this instructions.


W214

Warning W214 - The BIOS can be updated (flashed) but is surface mounted. If the update goes wrong you may not be able to get a new chip to replace the old BIOS. This does not mean that you cannot recover from an unsuccessful flash but it removes an option. (Intel main boards and those using AWARD BIOS have a recovery option)

Fix: You cannot fix this - but keep it in mind when your buy your next main board.


W215

Warning W215 - CPU temperature is too high (i.e. over rated core temperature). This should appear only if your CPU has a temperature-monitoring sensor installed. Most modern systems should have such a sensor installed – but check the manual to make sure.

Fix: Power down the system immediately. Open the case and check that the CPU fan is working and the heat sink is not unusually hot. Make sure the CPU has good all-round ventilation.


W216

Warning W216 - The CPU fan appears to have failed, the CPU fan is not connected correctly or the environment monitor chip is not responding.

Fix: Power down your system immediately. Open the case and check that the CPU fan is working and the heat sink is not unusually hot. Make sure the CPU has good all-round ventilation.


W220

Warning W220 - The CPU serial number is enabled. This unique identifier can be used by software to identify your system for various purposes (transactions, software licensing, etc.). Most CPUs today have this identifier but it is turned off.

Fix: If you consider such an ID an invasion of your privacy, then you should be able to disable it from the BIOS. See the main board manual on how to do so. There is also a program on Intel’s website that can help should the BIOS not support such an option.


W221

Warning W221 - The CPU serial number is disabled. This unique identifier may be required by some software to run, in which case you should turn it on.

Fix: Enable it from the BIOS. See the main board manual on how to do this.


W222

Warning W222 - The processor is operating above its frequency specification (rated speed), a condition commonly known as overcloking. The CPU may be unstable or produce erroneous results, some of which may not be readily apparent. The life expectancy will be reduced.

Fix: If you haven’t overclocked it yourself then you should contact the place-of-purchase for an explanation. You may have a remarked processor. To confirm, download the manufacturer’s own utility:

  • AMD: AMD Processor Utilities and Updates [image].
  • Intel: Intel Processor Identification Utility [image].

Note: The above links will open in your default web browser.


W223

Warning W223 - The CPU rated speed may be inaccurate. For certain CPUs this information has been obtained from unofficial sources and may not be accurate for all models. Engineering sample CPUs generally do not contain this information.

Fix: If it does not seem correct, disregard it.


W225

Warning W225 - The CPU is not a production (release) version but an ES (engineering sample or alpha/beta silicon) and thus not meant for distribution or extended usage. Such a CPU may behave differently or contain bugs/errata; the information displayed may be inaccurate.

Fix: If you have bought this CPU, return it for a production version.


W226

Warning W226 - The information on the non-BSP (i.e. not boot) CPU may be inaccurate on operating systems (OS) that do not have the MP (multi-processor) kernel installed. This is because Sandra cannot override the OS and interrogate the other processors.

Fix: Use a MP-aware OS with the MP kernel installed; please see your OS documentation on how to change the kernel.


W227

Warning W227 - CPU FSB higher than rated FSB of the CPU. Even if you’re below the CPU rated speed, by over clocking the FSB you are running the CPU I/O buffers above spec – just be aware of this.

Fix: Reduce the FSB to rated FSB. You can increase the multiplier if the resulting speed is less than CPU rated speed.


W228

Warning W228 - The CPU has not been validated for MP (multi-processor) usage, like running in this MP system. While it may work in MP mode, it may not support certain functions required for proper MP operation or have different timings or voltage requirements. MP CPUs need to pass more stringent tests, thus a CPU not validated for MP usage may fail in boundary cases.

Fix: Double-check if this is a MP certified CPU, if not attempt to swap it for a MP certified one.


W230

Warning W230 - The processors in this MP (multi-processor) system are not all the same type/version. To use all processors the operating system restricts itself to the features of the least capable processor in the system. Should problems occur with this system, contact the CPU manufacturer to see if this mix of processors is supported.

Fix: Swap out the processor(s) with some that match the remaining one. If you cannot, at the very least swap round the processors so that the one with the least features or lowest version is the BSP (primary) processor.


W231

Warning W231 - The IOQD (Host Bus In-Order Queue Depth) is set too low, most likely 1, i.e. no queue. This indicates the depth of the host bus pipelining; thus 1 indicates that no pipelining is to be done on the bus. This reduces the performance of the host bus which is crucial to performance. P6 (Pentium Pro, II, III, Celeron) has an IOQD depth of 8 while the P4/PM have an IOQD of 12. Most chipsets have an IOQD of 4 or more.

Fix: Check that BIOS settings were not reset or set to Fail-Safe defaults. Reset them to Optimised or Normal settings.


W234

Warning W234 - You are using a Hyper-Threaded system (HT/SMT) on an operating system (OS) that either does not support it or does not support the total number of logical processors of the system. Thus Hyper-Threading is not properly utilised. You may as well disable it.

Fix: Make sure you are using the right Hyper-Threading kernel or update your operating system for HT support (use Windows XP/2003 or later). Do note that some operating systems and software have licensing limits that may prevent you from using all CPUs or you may be in violation of your licence.


W235

Warning W235 - Processor core voltage (Vcore) is less than rated minimum. Unless the reported value is incorrect or the processor is a different type that is not correctly detected, the voltage is lower than it should be. If you’re under-clocking the processor you may have pushed too far.

Under-clocking is a condition where the processor is operating below its frequency specification (rated speed). Sometimes the core voltage is decreased to reduce power dissipation.

Fix: If the BIOS supports processor Vcore setting, check that the voltage programmed is correct for the processor installed. If not, check whether the mainboard supports the installed processor.


W236

Warning W236 - Processor core voltage (Vcore) is higher than rated maximum. Unless the reported value is incorrect or the processor is a different type that is not correctly detected, the voltage is higher than it should be. If you’re over-clocking the processor you may have pushed too far.

Over-clocking is a condition where the processor is operating above its frequency specification (rated speed). Sometimes the core voltage is increased to improve stability.

Fix: If the BIOS supports processor Vcore setting, check that the voltage programmed is correct for the processor installed. If not, check whether the mainboard supports the installed processor.


W237

Warning W237 - Processor power exceeds maximum power for this processor. If the processor core voltage (Vcore) is correct, the cooling system may need to be improved to cope with such a processor.

Fix: Check cooling system and upgrade if required. Make sure it is rated to cope with the processor you have installed.


W238

Warning W238 - Cooling system thermal resistance is abnormally high. If the values reported for processor power, processor and mainboard temperatures are correct then something may be wrong with the cooling system. The fan may have failed or is not spinning at its rated speed.

Fix: Check cooling system, including the fan(s) and thermal interface material. Also check that the cooling system is rated to cope with the processor you have installed at the speed it is running. If you have over-clocked the processor you may need a better cooling solution.


W239

Warning W239 - Cooling system thermal resistance is higher than recommended for this type of processor. Manufacturers recommend a certain performance for their thermal solutions (aka coolers) that is very important especially for very fast processors that generate a huge amount of heat (50W or more).

Fix: Check that the cooler is properly installed. Check interface material between cooler and CPU and consider using some high-performance interface material (e.g. Artic Silver). Check that the cooler is rated to support the processor you have installed at the speed it is running. If you have over-clocked the processor you may need a better cooling solution.


W300

Warning W300 - using the unknown monitor setting may result in incompatibilities and flickering.

Fix: Go to Control Panel\Display\Display Properties\Settings, click Advanced Properties\Monitor and click Change. Select your monitor model from the list or a similar one.


W302

Warning W302 - 16 colour (4-bit) modes are obsolete and may cause trouble.

Fix: Switch to a at least 256 colour mode. If you cannot, most likely the optimised video drivers for your video adaptor are not installed. Visit the manufacturer's website and download them.


W303

Warning W303 - 24-bit colour depth uses 3 bytes that is not a power of 2 number. 32-bit colour depth uses 4 bytes (64-bit) and can be accessed much faster resulting in a performance increase even though more video memory is used.

Fix: If your video adaptor supports it, always use 32-bit modes instead of 24-bit. Otherwise drop back to 16-bit colour.


W304

Warning W304 - VGA desktops (640x480) are the absolute minimum, XGA (1024x768) is the norm for 15” LCDs and 17” monitors. There’s no point in using anything less. The best selling monitors/LCDs are the 19” with the larger one coming down in price all the time.

Fix: Use a higher video mode. If you cannot, and the monitor supports it, check the correct video drivers are installed for your video adaptor.


W307

Warning W307 - The video hardware acceleration is not set to full. You should not reduce it unless you have video problems with your video adapter/driver. The full mode offers the best performance.

Fix: Go to Control Panel\Display\Display Properties\Settings, click Advanced Properties\Performance and move the Hardware Acceleration slider to Full.


W313

Warning W313 - While the font smoothing feature makes the display look much better, it reduces the overall graphics performance by a significant amount.

Fix: If the display seems sluggish - disable this feature from Control Panel\Display\Display Properties\Plus!.


W314

Warning W314 - The video BIOS is more than 3 years old. If the video adapter has a flash video BIOS, check whether an update is available and install it. You may gain extra performance or bug fixes.

Fix: If your video card has a flash BIOS check whether an updated version is available from the manufacturer.


W318

Warning W318 - You are using the highest mode supported by the monitor. Since you’re at the limit, the image may be less focused/sharp and the colours less bright. You may also see interference.

Fix: Usually it is better to decrease the resolution to the next down or buy a new monitor if you want use this mode.


W320

Warning W320 - The hardware cursor should be enabled unless you have problems with it. Disabling it will cause the cursor to flicker.

Fix: Go to Control Panel\Display\Display Properties\Settings, click Advanced Properties\Performance and move the Hardware Acceleration slider to Full.


W321

Warning W321 - The LFB (Linear Frame Buffer) should be enabled - otherwise performance may suffer.

Fix: Check your video card manual to make sure that the video card supports a LFB. If yes, then check whether it is enabled and that you have the latest video driver.


W400

Warning W400 - the printer driver was written for a previous version of Windows.

Fix: To take full advantage of the device, get an updated printer driver from the manufacturer.


W402

Warning W402 - the print quality of the printer is low for this type of printer. Make sure this is what you want, otherwise you will get less quality print-outs than possible with your printer.

Fix: Go to Control Panel\Printers, right-click this printer and choose Properties\Graphics and uncheck the Draft option if one is present.


W502

Warning W502 - Not all network adapters are firewalled.

Fix: Check that the firewall is enabled for all network adapters in the system (including dial-up connections, Bluetooth, etc.) unless there is a good reason they are not.

Even on a protected LAN a software firewall is useful to protect the other computers if one of the computers on the LAN gets infected.


W503

Warning W503 - Some simple IP services are enabled. The simple services include Echo, Discard, Day Time, Quote of the Day and so on. While most UNIX workstations enable them by default, most of the time they are not required.

Fix: Uninstall or disable them unless you really need them.


W504

Warning W504 - Some server IP services are enabled. These include FTP, POP3, DNS, HTTP, Gopher, SMTP and so on. Workstations typically don’t offer any such services. Servers do offer such services, but make sure you enable only the ones that you need - for resource and security reasons.

Fix: Uninstall or disable them unless you really need them.


W506

Warning W506 - All the installed firewalls on the computer appear to be disabled.

Fix: If you are using the Windows firewall, check it is enabled. If you are using a 3-rd party firewall, check that it is installed properly and that it reports its status correctly to Windows’ Security Center.


W507

Warning W507 - More than one firewall is installed and enabled on the computer.

Fix: If you installed a 3-rd party firewall, you can disable the Windows firewall. Usually there is no reason to have more than one software firewall unless they deal with different protocols (e.g. IPv4 & IPv6).


W508

Warning W508 - More than one anti-virus scanner is installed and/or enabled on the computer.

Fix: It is not a good idea to have more than one anti-virus scanner installed never mind enabled on the computer as they may mistake each other’s virus definitions for real viruses.

Leave only one anti-virus scanner installed and enabled on the system.


W509

Warning W509 - The anti-virus scanner reports that on-demand scanning is disabled.

Fix: Check whether on-demand scanning is disabled indeed. It is best to leave this on unless you are running frequent virus scans of the whole computer and you are not downloading/installing new applications before scanning them.

On-demand scanning does reduce the computer’s performance as well as consume resources.


W510

Warning W510 - The anti-virus scanner reports that its virus definitions are out of date.

Fix: Check whether the anti-virus scanner has been updated recently and if not update it. If your subscription has expired it may be time to upgrade or look for alternatives.

There are free virus scanners out there, there is no reason not to have one.


W512

Warning W512 - Bluetooth radio is in discovery mode.

Fix: Unless you are trying to pair your computer with a device via Bluetooth and you want the device to discover your computer, turn discovery off from Control Panel \ Bluetooth. This prevents malicious users from attempting to connect to your computer via Bluetooth and attept to hack into it. While Bluetooth does require authentication, various stacks (drivers) may have weaknesses that can be exploited to hack into your computer.


W513

Warning W513 - Wireless connection unsecured.

Fix: The wireless connection you are using is open, thus anybody can connect to this network. This could allow malicious users to join the wireless network and attempt to hack into the other hosts on this network. This presents a security risk to you especially if you are not using a firewall that blocks all services available on your computer. Even then, weaknesses in your software may leave you vulnerable to attacks from such malicious users.

Contact the wireless network administrator to enable authentication and encryption on this wireless network.


W514

Warning W514 - Wireless connection not encrypted.

Fix: The wireless connection you are using is not encrypted, thus malicious users could intercept and read the data transferred between your computer and the network. In addition, such malicious users can spoof packets and attempt to join the wireless network bypassing authentication.

Contact the wireless network administrator to enable encryption on this wireless network.


W515

Warning W513 - Wireless connection uses WEP.

Fix: The wireless connection you are using uses WEP. WEP is no longer secure and has been shown to be easily crackable in just a few minutes with the right tools. This could allow malicious users could intercept and read the data transferred between your computer and the network. In addition, such malicious users can spoof packets and attempt to join the wireless network bypassing authentication.

Contact the wireless network administrator to change the encryption on this wireless network.


W516

Warning W516 - Wireless connection signal quality low.

Fix: The signal qality of the wireless connection you are using is low. The connections speed is most likely lower than optimal and you may experience higher latency too due to lost/corrupted packets.

You need to change your computer's position, location or boost the power of your wireless network adapter or the Access Point / Router. Alternatively, add more Access Points in bridge mode in different locations to increase network range.


W517

Warning W517 - Wireless connection is ad-hoc, i.e. to a device and not infrastructure/network (Access Point).

Fix: If you are indeed connecting to a device then ignore this warning; if you were expecting an infrastructure/network (Access Point) then beware: it can be a hijack attempt. Malicious users may set up their computers to provide wireless networks using the same name as known networks to have you comnnect to their computers instead; this way they can attempt to hack into your computer.

Set your system (Wireless \ Advanced) to connect only to infrastructure/network and not any or ad-hoc (device to device).


W518

Warning W518 - Wireless adapter in ad-hoc mode.

Fix: Your wireless adapter is set to ad-hoc (device to device) mode. This allows other computers to connect to your computer. If this is what you want to do, ignore this warning, otherwise turn it off. This would allow malicious users to attempt to connect to your computer via the wireless ad-hoc network it offers to hack into your computer.

Check your system (Wireless \ Advanced) to turn off ad-hoc network mode.


W519

Warning W519 - Wireless modes disabled in hardware or software.

Fix: Your wireless adaptor has disabled physical modes in hardware or software. If you have disabled it yourself, ignore this warning, otherwise this means that certain capabilities of your wireless adapter are disabled. This means some wireless networks will be unavailable to you to connect to even though your hardware could connect to it.

Check the configuration or settings of your wireless adapter.

For example a 802.11b/g adapter may have "b" disabled, thus it could only connect to "g" networks and not "b" networks even though it could connect to it.


W520

Warning W520 - Wireless background scan mode disabled.

Fix: If background scan for wireless networks is disable, you need to manually initiate a scan to find and connect to available wireless networks.

Generally it is best to have background scan set to enabled as this would connect your computer automatically to any pre-configured wireless networks (i.e. the ones you have set profiles for with connection settings). This means your computer will have a network connection automatically configured depending on which wireless networks are available.


W521

Warning W521 - Wireless networks with hidden SSID (name) detected.

Fix: The SSID (name) of the wireless network is hidden for security reasons. This means that you need to know the name of the network to connect to it and will not be able to "see it" in the available wireless network list.

Enter the SSID (name) of the wireless network in the profile for the wireless network in order to connect. You will not be able to connect to this wireless network without setting up a profile first with its SSID (name).


W522

Warning W522 - Wireless ad-hoc networks detected.

Fix: Some wireless networks are ad-hoc (device to device). Unless you want to specifically connect to a device rather than an infrastructure/network, beware of such wireless networks, they may be hijack attempts.

Malicious users may set up their computers to offer wireless networks with the same name as established networks, thus you would connect to them rather than the actual wireless network. This way they can either hack into your computer or read the data transferred between your computer and the actual network.


W523

Warning W523 - Not all wireless networks are available for connection.

Fix: Some wireless networks cannot be connected to for various reasons - see individual network for actual reason.

Sometimes features of your wireless adapter are disabled or not supported or the security policy of your computer or the wireless network prevents your from connecting to that specific wireless network. Unless you want to connect to that network, you can ignore this warning.


W524

Warning W524 - Unsecured wireless networks detected.

Fix: There are unsecured wireless networks available.

Unless you are after "free Internet access", avoid connecting to these networks as their lack of security exposes you to potential security threaths from malicious users. Such malicious users could join such a network and attempt to hack into your computer.


W525

Warning W525 - Unencrypted wireless networks detected.

Fix: There are un-encrypted wireless networks available.

Unless you are after "free Internet access", avoid connecting to these networks as their lack of encryption exposes you to potential security threaths from malicious users. Such malicious users could read any transfers between your computer and the network and attempt to join the network by spoofing packets and bypass network authentication.


W526

Warning W526 - WEP encrypted wireless networks detected.

Fix: There are WEP encrypted wireless networks available.

Unless you are after "free Internet access", avoid connecting to these networks as their lack of good encryption exposes you to potential security threaths from malicious users as WEP has been shown to be easily crackable in a few minutes. Such malicious users could read any transfers between your computer and the network and attempt to join the network by spoofing packets and bypass network authentication.


W527

Warning W527 - Wireless profile corrupted.

Fix: Delete the profile for the network and the re-create it.


W700

Warning W700 - a sound card is required in today’s PCs since most programs need one, not just games.

Fix: You should purchase a sound card or install the correct drivers if you already have one.


W701

Warning W701 - wave/audio drivers are vital to the operation of the sound card.

Fix: Unless your sound card supports only MIDI, this means that some drivers are not installed properly. Run the Add New Hardware Wizard.


W702

Warning W702 - wave/audio recording drivers are not installed. You will not be able to record using your sound card. Generally all sound cards support recording.

Fix: Check with your sound card manual and try un-installing and re-installing the drivers.


W703

Warning W703 - MIDI/music input drivers are not installed. You will not be able to plug-in and use external MIDI devices like keyboards and synthesisers.

Fix: Check with your sound card manual and try un-installing and re-installing the drivers.


W704

Warning W704 - MIDI/music playback drivers are not installed. You cannot play MIDI music. Most sound cards do have a synthesiser built-in.

Fix: Check with your sound card manual and try un-installing and re-installing the drivers.


W705

Warning W705 - no mixer drivers are installed. All sound cards contain a mixer. If mixer drivers are not installed you won’t be able to set the volume/balance for channels or you may not hear any sound at all.

Fix: Check with your sound card manual and try un-installing and re-installing the drivers.


W706

Warning W706 - no auxiliary drivers are installed. This means that some channels may be muted or you won’t be able to adjust their volume/balance. Check that your sound drivers have been properly installed.

Fix: Check with your sound card manual and try un-installing and re-installing the drivers.


W710

Warning W710 - the driver for the sound card seems to be obsolete.

Fix: Make sure it was written specifically for Windows and it is not an old (legacy) driver. Check whether an updated driver is available from the sound card manufacturer.


W802

Warning W802 - the double-click speed has been set very low - make sure you’re able to double-click!

Fix: Go to Control Panel\Mouse\Buttons and move the Double-click speed slider towards Fast.


W901

Warning W901 - the type of keyboard installed is not the standard type. Unless you’re using a laptop or a special keyboard you could be using the wrong driver.

Fix: Go to Control Panel\Keyboard\General and check whether you have installed the correct driver for your keyboard. If not click Change and select the correct type.


W1101

Warning W1101 - Since APM tries to conserve energy at the expense of performance, if you don’t need to conserve energy you should disable APM to get the maximum available performance out of your PC.

Fix: Unless you’re actually using it, go to BIOS Setup\APM and disable it. If ACPI enabled you should disable APM.


W1102

Warning W1102 - If CPU clock-slowdown is enabled you will get reduced performance.

Fix: Unless you’re actually using it, go to BIOS Setup\APM and disable it.


W1103

Warning W1103 - The battery level is low.

Fix: Find a mains supply, change the battery or save your work before it’s too late.


W1105

Warning W1105 - The drive spin-down time may be too low. In general manufacturers recommend 30-60 minutes for a desktop or 10-30 minutes for a portable. A small value may reduce the drive’s life since changes in temperature adversely affect hard drives.

Fix: Go to Control Panel\Power\Disk Drives and increase the When powered by AC power drive spin-down time.


W1108

Warning W1108 - Processor power policy not optimal for power efficiency.

Fix: Choose a power policy that uses adaptive mode to dynamically change power modes depending on load. However, the system and the processor must support dynamic power modes, this may require BIOS updates, configuration changes and processor driver updates.


W1109

Warning W1109 - Power policy is not optimised for performance. A power policy optimised for performance causes the operating system to be biased towards using the cooling fans and running the processors at full speed. A power policy optimised for power saving causes the operating system to be biased towards using low processor speeds and relying on passive cooling.

Fix: If you require performance is required rather than power saving, you should select a power policy optimised for performance.


W1201

Warning W1201 - This device is the very first revision. While this does not mean it is buggy in any way, all new devices are potentially buggy. It’s up to you if you want to live on the bleeding edge.

Fix: You cannot fix this - but keep it in mind when you buy your next mainboard or devices.


W1203

Warning W1203 - VGA palette snooping is only useful if you have an ISA bus capture or overlay card to synchronise with the palette of the video card. Otherwise you should disable it or video performance may be seriously impaired.

Fix: Go to BIOS Setup\Settings and disable ISA VGA palette snooping.


W1204

Warning W1204 - This device seems slow. While this does not hamper the bus speed directly transactions with this device will take longer and thus reducing the overall efficiency.

Fix: You cannot fix this - but keep it in mind when buying your next device.


W1206

Warning W1206 - Device latency is high - the higher the latency, the more data a device can transfer in one go. The device may be hogging the bus for too long. Some video card drivers set the latency high in order to perform faster. The problem is that other devices (especially sound cards, network) won’t have enough time to transfer their data resulting in lower performance (e.g. sound drop outs, lockup). Generally, all devices should have latency of 32, with high performance devices (e.g. video card, disk, giga-LAN) with 64 and AGP to 128.

Fix: Go to BIOS Setup\Settings\PCI & AGP Devices and reduce PCI latency to 64 or 32. Contact the mainboard manufacturer or video card manufacturer for more details.


W1207

Warning W1207 - AGP 2/3 devices may be incompatible with AGP 1 mainboards and may need later drivers (e.g. AGP miniport, video drivers).

Fix: Make sure you have updated your System BIOS and Video BIOS. If you're using a legacy version of Windows, consider upgrading to Windows 2000/XP/2003. If you’re not using an Intel chipset, download the latest version of the miniport driver for your chipset.


W1208

Warning W1208 - The video card shares and interrupt with another device. This may cause problems in certain cases. It is advisable that the video card has its own interrupt.

Fix: Change the interrupt assigned to the video card from the BIOS Setup\Settings\PCI & AGP Devices or force it from Control Panel\System\Devices. If that does not work, change the interrupt of the other device (using the same method) or plug the other device in another slot. See the mainboard manual for a list of interrupts and their slots.


W1209

Warning W1209 - The video card does not have an interrupt assigned. All modern video cards need an interrupt. Even older PCI video cards work faster if an interrupt is used.

Fix: Go to BIOS Setup\Settings\PCI & AGP Devices and set Assign IRQ to video card to yes. You may also try setting First Video Adapter setting to AGP. Some video cards may need to be configured to use an interrupt, either through an utility or a jumper.


W1316

Warning W1316 - This version of Windows contains Product Activation technology (WPA).

Fix: Just keep in mind that a re-activation may be triggered if you make major hardware or software changes to your computer.

It is recommended that you activate after you make all your hardware and software changes and the system is stable.


W1317

Warning W1317 - This version of Windows contains Product Activation technology (WPA) and has not yet been activated.

Fix: If you have made all your system changes and the system is stable, activate your system as soon as possible. You may not be able to login until you activate if the period expires.


W1318

Warning W1318 - This version of Windows is an evaluation version that has an expiration date.

Fix: Keep an eye on the remaining evaluation days as you will not be able to boot or login once they expire.


W1319

Warning W1319 - Windows auto-update is disabled or turned off. You will not be notified of updates.

Fix: Consider setting it to “notify but don’t download and install” so at least you are told when new updates are available. Then you can decide whether to download and install them or not.


W1320

Warning W1320 - The latest service pack available for this version of Windows has not been applied.

Fix: Service packs generally contain many fixes as well as support. Unless there is a known incompatibility you should apply the latest service pack.


W1322

Warning W1322 - Data Execution Prevention (DEP) is not supported by the CPU(s) of your computer. Windows can only use software DEP to protect your system from malicious programs.

Fix: Ideally you should upgrade to a CPU that supports NX (Non-eXecute) or XD (eXecution Disable) features so that Windows can enable DEP and protect your system.


W1600

Warning W1600 - This process is either a 16-bit process written for Windows 3.1 or a 32-bit process written for Windows NT 3.

Fix: You should check whether a new version is available from the manufacturer.


W1601

Warning W1601 - This process consumes a huge amount of memory.

Fix: If you have many processes like this one, make sure you have enough physical memory to sustain them. Otherwise the system performance may decrease due to lack of memory.


W1700

Warning W1700 - This module is either a 16-bit process written for Windows 3.1 or a 32-bit module written for Windows NT 3.

Fix: You should check whether a new version is available from the manufacturer.


W1800

Warning W1800 - the free space on this drive is very low. Programs using temporary files may crash.

Fix: Delete some files, relocate them to another drive or consider compressing the drive.


W1801

Warning W1801 - compression programs may be incompatible with certain programs and typically reduce performance as well as using system resources (processor power, memory).

Fix: You should consider buying a new, roomier driver which does not need to use compressors.


W1802

Warning W1802 - large cluster sizes (e.g. 16KB or larger) greatly increase the amount of slack (disk space wasted).

Fix: You should re-partition the drive into smaller parts or use a 32-bit FAT like FAT32 or NTFS. If you have Partition Magic or use the Drive Manager.


W1808

Warning W1808 - large cluster sizes (e.g. 16KB or larger) greatly increase the amount of slack (disk space wasted). You should re-partition the drive into smaller parts or use a 32-bit FAT like FAT32 or NTFS.

Fix: You should re-partition the drive into smaller parts or use a 32-bit FAT like FAT32 or NTFS. If you have Partition Magic or Windows’ Drive Manager.


W1824

Warning W1824 - free disk space is low on this drive.

Fix: Free more space by emptying the Recycle Bin.


W1825

Warning W1825 - free disk space is low on this drive.

Fix: Make more space available by compressing the drive.


W1826

Warning W1826 - free disk space is low on this drive.

Fix: Free more space by deleting some of the unused files and folders.


W1827

Warning W1827 - the BIOS drive settings do not seem to be correct.

Fix: Go to BIOS Set-up and check them to see if they are set up properly.


W2001

Warning W2001 - The free system resources are low. You may have insufficient memory to use all the currently loaded applications simultaneously. Alternatively if some programs have crashed or Windows is running for a long time, there may be too much memory/heap fragmentation.

Fix: Close down some programs or re-boot Windows if this does not help.


W2002

Warning W2002 - The memory load is 95% or more. Windows is using more than the memory you have installed which is not recommended. Your system may become too slow to be usable.

Fix: Close down some applications or install more memory if you need to run them all simultaneously.


W2003

Warning W2003 - The swap file is almost full.

Fix: You should increase the size of the swap file (Control Panel\System\Performance\Virtual Memory) if you decided not to let Windows manage the swap file itself. However, if the swap file is currently as big or bigger than the installed physical memory you may need to add more memory rather than increase the size of the swap file.


W2004

Warning W2004 - The swap file is too large compared to the amount of physical memory installed. There is no point in making the swap file bigger than 2-2.5 the size of physical memory as the system will become unusable long before this limit is reached. You may be wasting disk space unnecessarily.

Fix: Go to Control Panel\System\Performance\Virtual Memory, select Let me specify my own virtual memory settings and reduce the Maximum number to at most 2.5 times your physical memory.


W2008

Warning W2008 - The drive that holds the swap file is almost full. The swap file will be unable to grow and you may run out of memory.

Fix: Free some disk space or move the swap file to a roomier drive.


W2210

Warning W2210 - DirectInput is not installed.

Fix: Install the latest version of DirectX.


W2211

Warning W2211 - The video hardware does not support colour-space conversion. This may be required for games or video players (MPEG, DVD).

NB: Not applicable to 3D only cards like the 3Dfx VooDoo or VooDoo II.

Fix: You should check for an updated video driver from the manufacturer if you know the card should support this. If not, consider upgrading the video card.


W2223

Warning W2223 - DirectX version is old; the DirectDraw interface supported is old.

Fix: Upgrade DirectX.


W2224

Warning W2224 - DirectX version is old; the Direct3D interface supported is old.

Fix: Upgrade DirectX.


W2300

Warning W2300 - The modem does not seem to be Plug & Play. Modern modems are PnP to allow Windows to detect them automatically and set them up to the optimum performance.

Fix: You cannot fix this but bear it in mind when you upgrade your modem.


W2500

Tip W2500 - Windows considers this PC to be rather slow. This is usually due to insufficient memory (less than 16MB) but a faster CPU would also help.

Fix: Upgrade the memory. Check the mainboard manual first to make sure which type and speed of memory is needed. As a rough guide 2000/XP needs 256MB, Windows 2003 512MB and Vista 1GB or more.


W2505

Warning W2505 - If the system does not support memory error detection, any memory malfunction will not be detected resulting in corrupt data or crashes. All systems should support error detection. However most memory is non-parity these days.

Fix: Use parity (1-bit error detection) or ECC (2-bit error detection) memory. Make sure the chipset supports this kind memory. Some chipsets support ECC up to a certain memory bus speed or FSB.


W2506

Warning W2506 - If the system does not support memory error correction (e.g. using ECC) if an error is detected the system will stop. A system that supports correction will attempt to correct the error and continue. A server should use error-correcting memory always.

Fix: Use ECC (1-bit error correction) memory. Make sure the chipset supports ECC memory. Some chipsets support ECC up to a certain memory bus speed or FSB.


W2507

Warning W2507 - There are very few memory slots. If some are already filled, to upgrade the memory will mean to discard some of the existing modules that will prove expensive. Try not to buy a mainboard with less than 6 SIMM sockets or 2 DIMM or RIMM sockets.

Fix: You cannot fix this - but keep it in mind when you buy your next mainboard. Buy one with more memory slots and use higher capacity memory modules.


W2508

Warning W2508 - All the memory slots are full. To upgrade the memory you will need to discard some or even all the existing modules that may prove expensive.

Fix: You cannot fix this - but keep it in mind when you buy your next mainboard. Buy one with more memory slots and use higher capacity memory modules.


W2510

Warning W2510 - The chipset may not have the capability to cache all the installed memory (e.g. Intel Triton chipsets cannot cache more than 64MB). While the overall performance may be higher if you’re using all the installed memory, you may get higher performance if the additional memory is not used. Alternatively upgrade the mainboard with one using a more advanced chipset.

Fix: You cannot fix this - but keep it in mind when you buy your next mainboard. Buy one with a good chipset.


W2512

Warning W2512 - The USB host controller is obsolete. Some incompatibilities may arise when you connect new USB devices.

Fix: You cannot fix this. Windows 2000/XP/2003 have it built in. Windows NT does not support USB.

USB2 requires special drivers in Windows 2000/XP; Windows 2003 has it built in.


W2513

Warning W2513 - The AGP bus is disabled.

Fix: If you have an AGP mainboard, you should get a AGP video adapter to take advantage of it. An AGP adapter would greatly improve 3D performance. However, it should still have at least 32MB or more of local memory.


(Untitled)

Warning W2518 - Mainboard temperature is too high (i.e. over 50ºC). This should appear only if the mainboard has a temperature-monitoring sensor installed.

Fix: Power down the system immediately. Open the case and check that all the fans are working and check whether components are unusually hot inside. Make sure the components have good all-round ventilation. Use more fans if required.


W2519

Warning W2519 - One of the mainboard fans has failed or is spinning too slowly. This should appear only if the mainboard has a temperature-monitoring sensor installed and the fans have tachometers. If the fan is speed controlled, this may be normal.

Fix: If the fan is not speed controller, power down the system immediately. Open the case and check that all the fans are working and check whether components are unusually hot inside. Make sure the components have good all-round ventilation.


W2520

Warning W2520 - The PCI bus speed is too high. The PCI bus speed should not be increased over 36MHz. While most PCI cards may work, some hard drives, CD-ROMs, network cards and other cards may not and you could get data corruption without knowing.

Fix: Make sure the FSB is not higher than 68MHz. While 75, 83 or 90MHz give you higher performance the data loss may not be worth it. If the chipset supports asynchronous PCI, enable this option to keep the speed at 33MHz, independent of FSB.


W2521

Warning W2521 - The AGP bus speed is too high. The AGP bus speed should not be increased over 75MHz (base clock). Most AGP cards won’t work or will default to 1x mode.

Fix: Make sure the AGP/CLK selector (if present in the BIOS) is 2x for 133MHz or 2/3 for 100MHz FSB. FSB speeds higher than the standard may result in AGP bus speeds way outside the specification.


W2523

Warning W2523 - The memory bus speed exceeds the module speed rating. While most memory will operate at slightly higher speeds, this is not recommended. Consider buying higher rated memory.

Fix: If the memory bus speed always equals FSB for your system, reduce FSB speed. If the system allows you to run the memory bus speed at AGP bus speed or a lower speed, set it to use the lower speed. Alternatively, if you happen to have CAS2 memory, you can set it for CAS3 if the other parameters are within range.


W2526

Warning W2526 - Current ISA/DMA bus speed is too high. Generally the ISA bus speed should not exceed 10MHz (8MHz rated speed) and the DMA bus speed should not exceed 5MHz (4MHz rating).

Fix: Increase PCI/ISA multiplier (e.g. from 1/2 to 1/3) from the BIOS or reduce PCI bus speed.


W2528

Warning W2528 - System monitor device implementation is known to vary. System monitoring devices can be used in different ways on different mainboards (e.g. sensor 1 measures CPU temperature instead of board temperature or Vin1 measures +5V instead of +12V) rather than using the manufacturer’s implementation guidelines that we’re using. The software will show incorrect data in this case as it cannot know the specific implementation details.

Fix: Let us know so we can attempt to support your board. As always, assume the BIOS is right as it is tuned specifically for your board rather than being generic like Sandra which supports thousands of different boards.


W2529

Warning W2529 - The APIC bus speed is high. Generally APIC speed should be 1/4 to 1/1 of PCI speed (usually 1/2) up to 33MHz or so.

Fix: Check and reduce PCI bus speed to the specified 33MHz and/or reduce PCI/APIC multiplier in the BIOS.


W2531

Warning W2531 - The MP BIOS configuration table seems inaccurate.

Fix: Update the BIOS and/or check BIOS settings and return to defaults.


W2533

Warning W2533 - The system has host controllers that have not been enabled by the BIOS/OS. It may be possible to obtain information by querying devices (if any) attached to these host controllers if they were to be enabled.

Fix: Check BIOS settings and enable the host controllers. Or change Sandra options to enable them.


W2534

Warning W2534 - Enabling the disabled host controllers using Sandra is risky and should only be attempted as a last resort as it may not be registered correctly with the OS.

Fix: Either do not do it if you are unsure or keep a lookout for any problems.


W2537

Warning W2537 - Enabling the disabled hardware monitors using Sandra is risky and may not yield the expected results. This is because Sandra is generic and not customised for your respective mainboard.

Fix: Nothing to fix - keep a lookout for any problems.


W2538

Warning W2538 - The system has hardware monitors that have not been enabled by the BIOS/OS. It may be possible to obtain information by querying them if they were to be enabled.

Fix: Check BIOS settings and enable the hardware monitors. Or change Sandra options to enable them.


W2540

Warning W2540 - No APIC (advanced PIC) has been detected for this MP system. All modern MP systems should contain an APIC; some advanced single-CPU systems may also contain one.

Fix: Check BIOS settings and enable the APIC.


W2541

Warning W2541 - FSB exceeds chipset rated FSB. If you’re over clocking the system just be aware that it may not be as stable as you may think.

Fix: Reduce the FSB in the BIOS settings/jumpers to the rated FSB.


W2542

Warning W2542 - Memory bus speed exceeds chipset rated memory bus speed. . If you’re over clocking the system just be aware that it may not be as stable as you may think. Also you may be over clocking the memory modules themselves.

Fix: Reduce the FSB or reduce the FSB/Memory multiplier.


W2543

Warning W2543 - Memory hole detected may not be required. For legacy reasons (with 16-bit device drivers/hardware), most chipsets allow you to set memory holes in the legacy memory space (either in the 1st MB or between 0 to 16MB) to be used for data transfers. If you do not have such legacy devices, make sure the hole is off.

Fix: Check BIOS settings and disable the hole.


(Untitled)

Warning W2544 - The chipset appears to have a built-in chip that uses system memory as video memory. Be aware that this reduces available system memory bandwidth quite a bit, especially when using high resolutions/colour depths/refresh rates or 3D applications. This reduces system performance appreciably.

Fix: If possible, use an external graphics adapter.


W2550

Warning W2550 - Chipset does not support Hyper-Threading, while the installed CPU does.

Fix: If you like to take advantage of the Hyper-Threading technology of your CPU, you will need to update to a Hyper-Threading capable mainboard.


W2551

Warning W2551 - Chipset does not support Multi-Processors, while the installed CPU(s) do(es).

Fix: If you like to take advantage of the Multi-Processor capability of your CPU, you will need a Dual-Processor or Multi-Processor capable mainboard.

NB. While some chipsets may use multi-processors with external glue logic, this is not recommended for mission critical systems.


W2552

Warning W2552 - No NUMA support has been detected. Multiple node systems need NUMA support in both the BIOS and OS for best performance.

Fix: Firstly, check that the mainboard does export a NUMA table for the operating system and that this functionality is enabled. Then check that the operating system has NUMA support (e.g. Windows XP/2003 and later) and that the correct kernel has been installed.

NB. NUMA is especially important for CPUs that have built-in memory controllers (e.g. AMD Opteron), this works out at one node per CPU. As the memory is local to each CPU, it is important that programs and the operating system allocate the memory on the proper CPU for best performance.


W2600

Warning W2600 - The SCSI device does not adhere to any of the ANSI standards (SCSI-1, SCSI-2, etc.)

Fix: Generally ATA/ATAPI emulated by Windows generates this warning - this is normal - ATA/ATAPI devices do not adhere to SCSI. If it’s a SCSI device it must be rather old. All modern SCSI devices should support (at least) SCSI-2.


W2900

Warning W2900 - the phone number is not specified. Usually this means that you’ve entered it wrongly.

Fix - make sure that the country code, are code and local phone number are all entered correctly. Go to My Computer\Dial-Up Networking, right-click the connection and choose Properties and enter the correct information.


W3000

Warning W3000 - ODBC data layer installed is obsolete. For modern applications ODBC version 3.5x or later is recommended with ODBC 3 required by almost all applications.

Fix: Please download and install MDAC 2.6 or later from Microsoft.


W3001

Warning W3001 - ODBC driver installed is obsolete. For modern applications ODBC driver version 3.5x or later is recommended with ODBC 3 required by almost all applications.

Fix: Please download and install MDAC 2.6 or later from Microsoft that contains many drivers. If the driver for the database is not included in the MDAC please download and install the latest version from the vendor’s website.


W3101

Warning W3101 - Power management is enabled. For desktops this is best to be disabled. If it is enabled, it may cause the drive to go into a low power/performance state or turn off.

Fix: If this is a desktop, look in the BIOS settings and disable power management/sleep for drives. If this is a laptop that is usually used on battery power, leave it as it is.


W3102

Warning W3102 - Read Cache (look-ahead buffer) or Write Cache (write-back) are disabled. For performance both should be enabled. The look-ahead buffer should only be disabled in specialised applications where the majority of I/O is random and look ahead would not be beneficial. The write-back cache should only be disabled if data is paramount or the system is prone to power loss that would prevent the cache to flush.

Fix: You may need to use a specific utility for the drive downloadable from the manufacturer’s website to enable or disable these settings. Some advanced controllers allow you to set such settings also.


W3103

Warning W3103 - Acoustic Management enabled. While this reduces the noise the drive generates, the performance is almost always impaired. Most of the time fans generate more noise than the drive itself. If the drive does generate a lot of noise, it may be faulty. You could also consider swapping the drive for another model that generates less noise.

Fix: You may need to use a specific utility for the drive downloadable from the manufacturer’s website to enable or disable these settings.


W3104

Warning W3104 - Current transfer mode not optimal, i.e. not highest supported. This affects drive performance. If the controller is also capable of the highest supported transfer mode, there is no reason not to use it.

Fix: First check controller supported transfer modes. Then check the mode the driver for the controller/BIOS is set to use and modify; some default to a lower mode for compatibility. You may need to install newer drivers if the current drivers do not natively support the controller (especially for RAID). You may need to update the controller BIOS or drive firmware, if the mode does not stick. If data corruption occurs verify the cable and consider switching (if any) drives on the same channel onto other channels.

If the built-in controller does not support the mode, consider using the on-board/RAID controller or even disable the built-in controller and install a new controller.


W3105

Warning W3105 - Current block size not optimal, i.e. not highest supported. This affects transfer performance.

Fix: Check BIOS settings and set block size to maximum. Some advanced controllers allow you to set such settings also.


W3107

Warning W3107 - Drive temperature is too high (>60C). Check system fans status.

Fix: Check that all fans work and check case temperature. If the fans are OK and case temperature is high (>40C) review cooling system arrangements (i.e. check air flow and either replace fans with better versions or install more) or device installation (i.e. leave some space between drives).


W3108

Warning W3108 - Drive is using PIO instead of DMA. This seriously limits performance of modern drives.

Fix: Check controller and driver settings and make sure you enable DMA. If the current driver does not support the controller natively install an updated driver.


W5003

Warning W5003 - the benchmark has tested the primary CPU only. This may not reflect the total power of the system

Fix: Turn on the multi-processor option. You need to use Windows NT/2000/XP/2003 and the multi-processor kernel to use the other processors.


W5005

Warning W5005 - Use the dynamic load balance option in special cases only. This is meant for AMP (asynchronous multi-processor) systems or SMP systems running with different speed CPUs. The calibration routine is run for each CPU in turn and the work is divided according to initial CPU performance. While this works OK on SMP systems as well, the algorithm incurs higher overheads that may result in slightly different results.

Fix: If you do not have such a system, disable dynamic load balancing.


W5007

Warning W5007 - This MP system does not have the MP kernel installed and thus only one CPU will be used by the benchmark. The performance index does reflect the performance of the system, as it is but not the true performance of the system with the correct kernel.

Fix: Upgrade to a MP-aware OS and/or install the correct MP kernel.


W5009

Warning W5009 - Mobile processors may yield lower indexes in power management modes when throttling is enabled. Unlike desktop/standard processors that run at the maximum speed all the time (except some sleep modes) modern mobile processors are capable of multiple performance modes that vary the frequency and core voltage based on utilisation and power.

Fix: If the index is lower than expected, check the manual to see how to force the processor to run at the highest rated speed or highest performance mode.


W5010

Warning W5010 : Cannot use large page memory pages due to lack of privileges.

Fix: Use the Local Security Policy to give yourself lock memory pages privilege.

Large memory pages greatly improve performance when large memory blocks are allocated.


W5011

Warning W5011 : NUMA nodes have inefficient memory allocation.

Fix: For best performance, it is important that all nodes in a NUMA system, after the operating system has loaded, have the same amount of memory free; generally this may mean that node 0 should have more memory than the other nodes.


W5012

Warning W5012 : NUMA nodes have inefficient speed allocation.

Fix: For best performance, all nodes in a NUMA system should be matched in terms of memory type and speed; if this is not possible then the fastest nodes should also have the most memory so that the algorithm can allocate more work blocks to those nodes.


W5100

Warning W5100 - Low video index.

Fix: Please close all running programs.


W5200

Warning W5200 - the available free space on this drive is low.

Fix: Increase free space before running the benchmark.


W5204

Warning W5204 - CPU utilisation is high. Modern ATA and SCSI disk controllers use DMA bus-mastering which frees the CPU from transferring data from/to the disk and increase system peformance. Such systems typically use maximum 10% of CPU time while other systems use 90-99% of CPU time during transfers.

Fix: Check if the disk controller and drives support bus-mastering. If yes, check for updated drivers for the disk controller from the manufacturer. Refer to the manual for information on how to turn DMA bus-mastering on. If you’re using the Windows bus-mastering drivers, check the DMA box in Control Panel\System\Device Manager\Disk Drives\Disk click Properties and open the Settings tab.


W5205

Warning W5205 - The write index/performance seems low. While (generally) the sustained read performance will be higher than the write performance, the write performance (on uncompressed drives) should be comparable, e.g. not ½ or less than read performance.

Fix: Some SCSI hard drives/controllers may have write verify on; this feature checks that the data written matches the data on the disk by reading and comparing it. While this function is very important for data integrity, the performance hit is large.

More commonly the write cache may be off (i.e. write through mode). This is done to protect the data in case of power/system failure by making sure it is always written to disk synchronously. Again, this feature causes a performance hit so enable only if necessary.

NB. If your drive is compressed (e.g. by setting “Compress drive to safe disk space”) this warning is generally issued unless the system is very fast and able to compress the data very quickly; generally the hit is enough to cause the write speed low as decompression is much faster. This is by design.


W5206

Warning W5206 - The drive index seems low.

Fix: While this is a generic warning - i.e. it does not specify the nature of the problem - generally, the problem would be the lack of DMA bus-mastering which forces the drive to work in PIO mode which not only hurts performance but also increases CPU utilisation. Check that the controller drivers are installed and that DMA is enabled for the channel and the drive itself.


W5208

Warning W5208 - The test files have failed to be deleted from the tested device.

Fix: Make sure the device is not write protected and/or write only.


W5400

Warning W5400 - Low memory bandwidth efficiency (advanced test). Generally this means a setting is incorrect or set too “safe” resulting in too low performance.

Fix: Check memory timings (reduce them) or check other chipset or memory speed settings.


W5401

Warning W5401 - Low memory bandwidth efficiency (legacy test). Generally this means a setting is incorrect or set too “safe” resulting in too low performance.

Fix: Check memory timings (reduce them) or check other chipset or memory speed settings.


W5402

Warning W5402 - Low L2 cache memory index. The throughput for the cache seems low.

Fix: If the system has L2 cache, make sure it is enabled. Some systems disable the L2 cache if the memory installed is larger supported by the cache controller.


W5403

Warning W5403 - The tests using multi-media instructions MMX/SSE(2) are not standard as STREAM was defined. While they follow the same algorithm, the data is processed in blocks rather than one at a time. This may yield different results from the tests using the standard instructions.

Fix: Disable multi-media tests from module options or keep this in mind when comparing with other results.


W5407

Warning W5407 - CPU specific Optimisation Overrides have been engaged! This means that a optimum code path has been chosen for the CPU that does not use the “latest” features but has higher performance.

Fix: You can disable this override from module Options.

NB 1. While some processors support many instruction sets, not all processors perform best using the very latest instruction set due to their architecture. The software then chooses another path that uses older instruction sets but performs better.

NB 2. For example both the Intel Pentium M and AMD Athlon 64 support SSE2. Unlike the Intel Pentium 4, they perform better with SSE instructions. The benchmark thus uses SSE instead of SSE2 as higher performance can be obtained by using these instructions.


W5800

Warning W5800: Smart Card / SIM Card type not known by the operating system.

Fix: Cards must be introduced to the operating system and providers registered that can handle card I/O and cryptographic functions. Otherwise the operating system and generic applications will not be able to talk to the card.


W5801

Warning W5801 : Smart Card / SIM Card provider not found.

Fix: In order for the operating system and generic applications to talk to the card, the card must be introduced to the operating system.


W5802

Warning W5802: Smart Card / SIM Card cryptographic provider not found.

Fix: In order for the operating system and generic applications talk to a card that uses encryption, the card must be introduced to the operating system and its cryptographic provider registered and associated with the card.


W5900

Warning W5900 : Endurance Index can only be used to compare devices of the same type, e.g. SLC (single-level cell) device with SLC device and MLC (multi-level cell) device with MLC device.

Fix: Do not compare the endurance indexes of a SLC and a MLC device.


Waiting

This window notifies you that SiSoftware Sandra is analysing your system and you should not disturb the system while this is going on. If you do the results will be lower than expected.

Don’t

  • Press any keys
  • Move the mouse or click the buttons
  • Run background processes (MIDI/Wave/Video playback, Internet transfers, network transfers, etc.)

Please wait until the test is completed. Most take less than 1 minute and no test lasts more than 5 minutes


Add New Module

This wizard allows you to add modules to Sandra. These may be deleted modules, modules that were incompatible with your previous configuration or 3-rd party module add-ons.

Select the modules you want to add by checking the checkbox next to them.

Shortcut

Keys: CTRL+A


Burn-in Computer - Count Down

Here you can specify various settings relating to the burn:

  • Count - the number of times you want the test suite to be executed.

  • Continuously - run the test suite continuously; useful when you want to test the system for a long amount of time or in the background.
  • Low Priority - run the test suite at low priority so that other processes on the system can execute; useful when you want to test the system for a long time or to run the burn-in in the background.
  • Monitor System Health - check the environment hardware system monitor regularly to check the system temperatures, voltages, fans, etc.
  • Terminate on Overheat/Fail - stop the test if the settings fall outside the normal parameters.


Burn-in Computer - Processor

Here you can specify the processor utilisation should you not want them to be tested at 100% utilisation. This is useful when the processor(s) is/are not stable at full utilisation or you do not want to trigger over temperature, etc. alarms.

You can select the processors you want to test should you not want to test all of them. Check the checkboxes next to the processor in the processor list that you want to test. You obviously need a multi-processor system with the multi-processor OS kernel installed in order for this to work.


Burn-in Computer

This wizard allows you to test the stability and reliability of your computer by running the benchmarking modules (in verify mode) or specialised burn-in modules while monitoring the computer.

While the benchmarks are not specifically designed for burning-in, they are designed to stress the components they test to the limit (CPU, chipset, memory, drives or network). The verify mode ensures that the results are valid.

The burn-in modules are designed to stress the components by executing tasks that are known to cause problems and test/use as much of the components’ functionality as possible. Generally this causes the components' temperature to increase as much as possible.

Batch/Command-line Mode: create a script and use the /r command line option. Do note that this functionality is only available in the commercial versions only.

Warning: Burning-in stresses components. Thus any weaknesses may cause them to fail or be damaged permanently. Do not run unless you know what and why you do it.

Shortcut

Keys: CTRL+B


Burn-in Computer - Maximum Temperatures

Here you can adjust the maximum temperatures that the test allows for each specific component that is being monitored.

A supported hardware monitor chip is required to monitor the temperatures of the devices.


Burn-in Computer - Minimum Fan Speeds

Here you can adjust the minimum fan speeds that the test allows for each specific component that is being monitored.

A supported hardware monitor chip is required to monitor the temperatures of the devices.


Performance Index

This wizard allows you to quickly compare all the performance indexes of your system with the reference systems by generating a combined index.

This is done by executing all relevant benchmarks in succession and displaying the results using a convergence matrix (currently a pentagon). This allows you to quickly see in which areas (if any) your system is deficient and what needs to be changed to ensure full overlap. This is most useful when upgrading or replacing equipment.

In simple terms:

  1. The back-end matrix (i.e. blue pentagon) represents the reference system as selected.
  2. The front-end matrix (i.e. red pentagon) represents your system.
  3. If there are areas where the back-end matrix shows through, then in that area your system is inferior to the reference system.
  4. If you do not see the back-end matrix in an area, then your system is superior to the reference system.
  5. Generally you do not want to see the back-end matrix at all (i.e. no blue). This means your system is as good as or superior to the selected reference system.

More benchmarks will be added in the future to ensure all areas of the system are tested.

Shortcut

Keys: Ctrl+W


Multiple Wizards - Confirm

This is just a warning and confirmation that you understand what is going to happen and that you’re OK with it.


Connect to Source - ADO database source

Here you can select the report to be read-back from the database.

Use the combo-box to select the ID of the report you want.

In order to be able to read-back reports you need to:

  • Create a database on your database server using the schemas provided. (see ADO database insert for more information)
  • Use the Create Report wizard to insert reports in the first place.

Note: You can only read-back reports inserted with a version of Sandra compatible with the current version you are using. Older versions may not be directly readable.


Connect to Source - Local computer

The wizard has enough information to proceed, just click OK to continue.


Connect to Source - ODBC data source

Here you can select the report from the database.

Use the combo-box to select the ID of the report you want from the database.

In order to be able to read-back reports you need to:

  • Create a database on your database server using the schemas provided. (see ODBC database insert for more information)
  • Use the Create Report wizard to insert reports in the first place.

Note: You can only read-back reports inserted with a version of Sandra compatible with the current version you are using. Older versions may not be directly readable.


Connect to Source - Remote computer

Here you can specify the connection details for the remote computer. The connection is made through standard RPC/DCOM, for more details please refer to the specification.

Note: The Sandra service must be installed and running in order to connect to a remote system. Only the Enterprise version can push the service onto remote computers that do not have Sandra installed.

  • Type: choose the type of the connection protocol to be used.
    • TCP/IP (ncacn_ip_tcp) is recommended if installed but may be blocked by firewalls, routers, etc.
    • Named pipes (ncacn_np) is network protocol independent and also forwards security credentials.
    • HTTP through IIS (ncacn_http) is best over the Internet but requires configuration through IIS. Refer to IIS RPC Proxy chapter in IIS documentation for more details on setting this up.
  • Security: specify the connection security. It’s best to choose 'packet encryption' especially over the Internet or LAN or at least 'packet integrity' so that the authenticity of the packets is verified.
  • Authentication: specify how your user credentials will be verified on the remote system. It is recommended to select 'negotiate' so that the systems work out the best method automatically. If 'Kerberos' is installed use that otherwise use 'Windows' authentication.
  • Server: specify the remote computer name in the standard Windows format, its DNS name or its IP address. You can use the "..." button to search for computers on your network. Note that if you leave it blank you will connect to the local computer!
  • Options: specify any extra options for the connection as per RPC/DCOM protocol. Normally this should be left blank unless you know what you are doing.


Connect to Source - Connection

Here you can choose the source of the data connection for the Sandra client:

  • Null (Wizards Only): Use when you don't want to connect to a data source but just run the wizards (e.g. to update, register, etc.). In the Enterprise version use it to connect each wizard to a different data source individually rather than globally for all wizards.

  • Local Computer: Use to connect to the local computer. All modules, benchmarks, wizards, etc. will be executed on the local computer using your current user credentials (you must have administrator rights).
  • PDA / Smart Phone (Windows) - this tests any connected PDA or Smart Phone device through ActiveSync/Mobile Center. The device must be docked or connected to the system.
  • PDA / Smart Phone (Palm) - this tests any connected PDA or Smart Phone device through HotSync. The device must be docked or connected to the system.
  • Remote Computer: Use to connect to a remote computer. All modules, benchmarks, wizards, etc. will be executed on the remote computer using your current user credentials (you must have administrator rights on the remote computer)

    Note that only the Enterprise version can push Sandra server on a remote computer; all other versions require Sandra server to be installed.

  • Read from ADO database: Use to connect to a database through ADO and read-back Sandra reports.
  • Read from ODBC database: Use to connect to a database through ODBC and read-back Sandra reports.

    Note that the database must have the Sandra Report schema installed as well as at least one Sandra report saved into it.

  • Read from Report File: Use to open a Sandra report file and read-back the Sandra report. Note that not all report file formats can be read-back only some of them.


Connect to Source - Push

Note: This topic applies to the Enterprise version only.

These options govern how the Remote Agent (Sandra Service) is to be deployed by the Management Console on the remote computer. If Sandra is not installed on the remote computer, the agent has to be deployed to return information.

  • Push: Deploy the Remote Agent to the remote computer if it is not present or installed.
  • Install: You can either just run the agent remotely without installation or install it as a service. Generally you would install it as a proper Windows service, however you may choose not to.
  • Use WMI: You can either use Windows' WMI (Windows Management Instrumentation) interface or SiSoftware' own Deploy Agent to deploy the Remote Agent to the remote computer. Our solution is preferred as WMI depends on the operating system implementation but may be already configured to work with firewalls, etc.

Note: To deploy to a remote computer, you naturally need Administrator rights on the remote computer. The default shares must also be available in some configurations.


Connect to Source - Credentials

Here you can enter your crendetials on your local or remote computer. In order to connect, you need an account with log-in rights on the computer.

Sandra integrates directly with Active Directory, thus all security settings are managed through the Domain Controller (PDC/BDC).

  • Use Logon Credentials: Use the current logon credentials to login to the local or remote computer. If you are Domain Administrator or similar, this is the best option.
  • Log on As: Use this if your current account does not exist on the remote computer or does not have Administrator credentials. You would also use this if the computer is not on the same domain/workgroup as your computer.

Note: If the Sandra Agent or Service are not running on the computer, you need Administrator privileges on that computer to start them. You may want to set them to run Automatically rather than Manual if you or the users are using accounts with non-Administrator privileges.

Enterprise Version Note: Make sure the remote computer is marked as "Trusted for Kerberos Delegation" in Active Directory. Otherwise, Sandra will be unable to delegate your credentials to other services running on the remote computer or other computers.

Enterprise Version WARNING: As Sandra depends on Active Directory, it will NOT work properly in a non-domain environment, e.g. stand-alone or workgroup computers! For such environments use Sandra Professional included on your media.


Multiple Wizards - ADO database insert

Firstly you will need to create the database on the database server and run the specific schema to initialise it:

  • SQL Server: SQL Server Schema.sql
  • Access: Report Schema.mdb
  • Oracle: Oracle Schema.sql
  • MySQL: mySQL Schema.sql

For SQL Server databases, specify:

  • Provider - SQLOLEDB
  • Server - the host name of the SQL Server database.
  • Database - the database (schema) name.
  • Driver - leave blank.
  • Use Windows Authentication - check if security is to be handled by Windows. The current login user name/password will be used as credentials. If unchecked, specify user name and password.
  • Supports Identity/AutoIncrement - check.
  • Supports Sequences - uncheck.
  • Use Client Cursors - uncheck.
  • User - database user name (blank if anonymous) if not using Windows authentication.
  • Password - database user password (if needed) if not using Windows authentication.

For connection ODBC databases specify:

  • Provider - MSDASQL
  • Server - host name of server if applicable; blank otherwise.
  • Database - database name if server specified or database file name.
  • Driver - full name of ODBC driver, verbatim.
  • Use Windows Authentication - leave unchecked.
  • Supports Identity/AutoIncrement - check or uncheck depending on database.
  • Supports Sequences - check or uncheck depending on database.
  • Use Client Cursors - check or uncheck depending on database.
  • User - the database user name or blank if anonymous.
  • Password - the database user password or blank if none needed.

This mode of connection is very useful when no ADO/OLE DB driver is available for the database but a DSN-less connection is required. It is recommended to test the connection through ODBC first.

For Oracle databases, specify:

  • Provider - MSDAORA
  • Server - the host name of the Oracle database.
  • Database - the schema (database) name.
  • Driver - leave blank.
  • Use Windows Authentication - check if security is to be handled by Windows. The current user login needs to be set up as an external user. If unchecked, specify user name and password.
  • Supports Identity/AutoIncrement - uncheck.
  • Supports Sequences - check.
  • Use Client Cursors - check; the OLE DB provider does not support server cursors.
  • User - the database user name or blank if anonymous.
  • Password - the database user password or blank if none needed.

Note that you need to install the Oracle Client software and the SQL*Net drivers and configure them properly before attempting to connect. Use the ODBC option to test the connection first.

For Access/Jet databases, specify:

  • Provider - Microsoft.Jet.OLEDB.X.XX where X.XX is the Jet version, e.g. 4.0, 3.51, etc.
  • Server - leave blank.
  • Database - file name of the database.
  • Driver - leave blank.
  • Use Windows Authentication - unchecked.
  • Supports Identity/AutoIncrement - check.
  • Supports Sequences - uncheck.
  • Use Client Cursors - uncheck.
  • User - the database user name or blank if anonymous.
  • Password - the database user password or blank if none needed.

NB. Some client software may overwrite the OLE DB drivers or other libraries. You can try reinstalling the latest version of MDAC afterwards.


Multiple Wizards - MAPI Email post

Here you can specify:

  • E-Mail Message’s Subject - type your own subject or accept the default.
  • E-Mail Recipient(s) - type the address(es) of the recipients for the message. They are usually separated by ‘,’ or ‘;’. You don’t need to type the person’s name, only the address.


Multiple Wizards - Save to Disk

Multiple Wizard - Save to Disk

Here you can specify the file name of the report you want to be generated. The format of the file can be changed by going back to the previous step.


Multiple Wizards - NNTP News post

Here you specify:

  • News Message’s Subject - type your own subject or accept the default.
  • Newsgroups(s) - type the newsgroup(s) of the recipients for the message. They are usually separated by ‘,’ or ‘;’.
  • E-Mail Sender - type the account name or address of the sender.
  • NNTP Server Host - type the name of the host of the NNTP relay server or localhost if local.
  • NNTP Server Port - type the port of the NNTP relay server. Usually it is 119.
  • Use SSL to Authenticate - check it if you want SSL protocol to be used for authentication. Make sure the server
  • Account User Name - type in the user name of the account if a login is required.
  • Account Password - type in the password of the account if a login is required. Leave blank if anonymous login is fine.


Multiple Wizards - ODBC database insert

Firstly you will need to create the database on the database server and run the specific schema to initialise it:

  • SQL Server: SQL Server Schema.sql
  • Access: Report Schema.mdb
  • Oracle: Oracle Schema.sql
  • MySQL: mySQL Schema.sql

Here you can specify:

  • DSN - the data source name on the local machine.
  • User - the database user name or blank if anonymous.
  • Password - the database user password or blank if none needed.

Create the DSN using Control Panel\Admin Tools\ODBC. It is advisable you make it a system DSN rather than a user DSN unless this is a security measure. Please set all the required settings (if any) there.

For SQL Server databases, specify:

  • Supports Identity/AutoIncrement - check.
  • Supports Sequences - uncheck.

For Oracle databases, specify:

  • Supports Identity/AutoIncrement - uncheck.
  • Supports Sequences - check.

Note that you need to install the Oracle Client software and the SQL*Net drivers and configure them properly before attempting to connect. Use the ODBC option to test the connection first.

For Access/Jet databases, specify:

  • Supports Identity/AutoIncrement - check.
  • Supports Sequences - uncheck.

For MySQL databases, specify:

  • Supports Identity/AutoIncrement - uncheck (even if supported).
  • Supports Sequences - uncheck.

NB. Some client software may overwrite the ODBC drivers or other libraries. You can try reinstalling the latest version of MDAC afterwards.


Multiple Wizards - Print or Fax

Multiple Wizard - Print or Fax

Here you can specify the printer or fax you want to use. Use the browse button to choose the printer or fax.


Multiple Wizards - MSMQ queue post

Here you specify:

  • Queue - type the queue name in the correct format, i.e. <computer>\<queue name> (if remote) or .\private$\<queue name> if it’s a private queue on the local machine.
  • Transactional - check if the queue is a transactional. Since a single message is sent, the queue does not need to be transactional.
  • Publicly accessible - check if the queue is to be accessible by other users not just the creator.
  • Encrypt message body - check if you would like the message body to be encrypted. This is done by MSMQ and not Sandra, thus the cryptographic provider is the default provider for that copy of Windows. The user’s certificate is used as the key.
  • Use default user credentials - uncheck if the current user does not have rights to post to the queue and enter the account details of a user that is allowed to post to the queue.
  • Account User Name - type in the user name of the account if the current login credentials are not enough.
  • Account Password - type in the password of the account if a login is required.


Multiple Wizards - Upload to site

Here the site to upload to (either web/http, ftp, etc.) has been filled in for you already. You need to specify your credentials (if anonymous upload is disabled) and agree to the legal statements to continue.

  • User - the name of the user account (or leave blank if anonymous).
  • Password - the password for the user account (or leave blank if anonymous).
  • Privacy Statement: please visit the link displayed at the next step, read the document and if you agree continue with the wizard.
  • Legal Statement: please visit the link displayed at the next step, read the document and if you agree continue with the wizard.


Multiple Wizards - SMTP Email post

Here you specify:

  • E-Mail Message’s Subject - type your own subject or accept the default.
  • E-Mail Recipient(s) - type the address(es) of the recipients for the message. They are usually separated by ‘,’ or ‘;’. You don’t need to type the person’s name, only the address.
  • E-Mail Sender - type the account name or address of the sender.
  • SMTP Server Host - type the name of the host of the SMTP relay server or localhost if local.
  • SMTP Server Port - type the port of the SMTP relay server. Usually it is 25.
  • Use SSL to Authenticate - check it if you want SSL protocol to be used for authentication. Make sure the server
  • Account User Name - type in the user name of the account if a login is required.
  • Account Password - type in the password of the account if a login is required. Leave blank if anonymous login is fine.


Multiple Wizards - Upload to server

For web/http upload you can specify:

  • Host - type the full URL and folder of the destination, e.g. http://www.server.com/uploads/. For SSL secured, use https://www.secure.com/uploads/.
  • User - the name of the user account (or leave blank if anonymous).
  • Password - the password for the user account (or leave blank if anonymous).

For ftp upload you can specify:

  • Host - type the full URL and folder of the destination, e.g. ftp://ftp.server.com/uploads/.
  • User - the name of the user account, or anonymous.
  • Password - the password for the user account, or e-mail address if anonymous.


Multiple Wizards - Configuration

Here you can select the manner in which you want the report to be created:

  • Make choices and generate report - continue with the wizard making choices as to what, how and where the report should be create and generate it.
  • Save the settings in a script file for later use - a script will be created using the current options defined in the wizard. You can run the script later using the command: Sandra /r <script file name>. This option does not generate a report - only saves the options you selected.
  • Load the settings from a script file - select a script file and use the settings in it to generate a report interactively. This is a good way to check whether a previously generated script (either manually or automatically) does work the way you expect.
  • Use the settings from a built-in profile - select one of the profiles listed in the combo-box (if any) and enter any information that may be needed to complete the report. This way you can create a report in the specific format as defined by the profile creator.


Multiple Wizards - Choose Modules

This wizard allows you to select which modules you want to include in the report:

  • Check the checkbox next to each module you want to include in the report.
  • Uncheck the checkbox next to each module you want to exclude from the report.
  • All modules are selected by default.
  • To select all modules, click the Select All button.
  • To deselect all modules, click the Clear All button.
  • If you want to set a module’s options, click the Options button.


Multiple Wizards - Save Report

Here you can choose the way the report file is created:

  • Text Document (.txt) - This is the normal format, readable by humans (i.e. with proper formatting, alignments and other things). But it cannot be easily imported into a database or spreadsheet. Sandra herself cannot read it.
  • Report/Hierarchical Compatible (.rpt) -To allow Sandra to read it back, you should choose this option. While not readily accepted as input to a database or spreadsheet - a converter can be quickly made to convert most other formats. For more information see Report Format.
  • Web/Html Compatible (.htm) - If you want to create a report for Internet publication or to print out. It looks better but it is much larger than a text report. It should also be used if you intend to use proportional fonts or import it into a modern editor. You can import your own style sheet if you don’t like the default. For more information see HTML File Format.
  • Web/XML Compatible (.xml) – Create a report in XML format, from which you can readily import it into any XML compliant system, format or convert to any other format. You can view or format it directly with Microsoft Internet Explorer 5 or later. For more information see XML Format.
  • CIM SMS/DMI Compatible (.mif) – Create a report in CIM (Common Interface Model) format developed by DMTF (Desktop Management Task Force) part of WBEM (Web-Based Enterprise Management) initiative. Microsoft’s SMS (Systems Management Server) uses it and you can import a report directly into it. Any CIM/DMI compliant system should work also. For more information see CIM Format.
  • Append to Existing Report - Check it if you want the new report to be appended to the selected file instead of overwriting the file. Be warned that this only works for normal, text type reports.
  • Compress Report (.cab) - Available only if you save the report to a file (including e-mail/post/etc). The report will be compressed in the Windows cabinet format. As the file is text the saving may be appreciable (90% or more).
  • Encrypt Report (.cry) - Available only if you save the report to a file (including e-mail/post/etc). The report will be encrypted using a well-known algorithm using a key of 128-bit or higher (depending on encryption pack) hashed from the key you’ve entered. Make sure the key you’re using is not too simple (e.g. 8 characters or more, etc.).


Environment Monitor

This wizard allows the monitoring of a computer's environment while executing its various tasks. You can select the monitoring parameters and then observe the changes to the computer's environment as it operates.

You can monitor:

  • Temperatures (Mainboard, CPUs, etc.)
  • Fan Speeds (Mainboard, CPUs, etc.)
  • Voltages (power supply, etc.)
  • Currents (power supply, etc.)
  • Core power of processors
  • Cooling systems' thermal resistance

Batch/Command-line Mode: create a script and use the /r command line option. Do note that this functionality is only available in the commercial versions only.

Note: The computer must have an enabled hardware environment monitor chip that is supported by Sandra.


Registration Wizard

Register Program

This wizard registers or activates your copy of the program. This ensures that you are running a genuine copy of Sandra and that you will be able to download updates and upgrades.

Key: Please use the 30 alphanumeric key provided by the distributor to register. This key is unique to you and should be kept secret. Any key that becomes public will be banned by us and the account locked.

Piracy: Please do not use, uninstall and report to us any pirated copies of our software. You can mail us at Piracy Information.


Multiple Wizards - Commens

Multiple Wizards - Comments

Enter your comments in the edit box. If you don’t type anything, no comments will appear in the report.

If you choose to e-mail/post the report, this text becomes the message body (the actual report is send as an attachment) so you should definitely enter some information for the receiver of the message.


Multiple Wizards - Delivery

Here you can choose the way you want the report to be delivered:

  • Save to Disk - you will be able to select the drive, path and filename for the report.
  • Print or Fax - you will be able to choose the printer or fax you want to send the report to and also set the device settings, number of copies, etc. A print or fax needs to be installed.
  • E-Mail by MAPI - you will be able to enter the message subject and the recipient’s name(s). The report will be send as a file attachment. Make sure you check the compress checkbox to minimise message size. A MAPI compatible client needs to be installed and configured properly.
  • Email by SMTP - you will able to enter the message subject and the recipient’s name(s). Also, you will need to enter the SMTP server details and user account information. The report will be send as a file attachment. Make sure you check the compress checkbox to minimise message size. CDO need to be installed and the SMTP service configured.
  • Post by NNTP - you will able to enter the message subject and the newsgroup(s). Also, you will need to enter the NNTP server details and user account information. The report will be send as a file attachment. Make sure you check the compress checkbox to minimise message size. CDO need to be installed and the NNTP service configured.
  • Upload it - you will be able to enter the URL of the server you want to upload it to, the account user name and password. If you’re uploading to a FTP server, use the ftp://ftp.server.com/folder convention. If you’re uploading to a web/http server, use the http://www.server.com/folder or https://www.secure.com/folder convention.
  • ODBC database - you will be able to enter the DSN (data source name), the user name and password to connect to it. You need a previously set-up data source (generally a system data source) through the ODBC Control Panel extension. Any (relational) database supported by ODBC can be used. See Database Schema for schema information.
  • ADO database - you will be able to enter the provider (i.e. the database layer, e.g. SQLOLEDB), server host name, database name, user and password. Generally this is the recommended option for SQL Server or other specialised storage providers. See Database Schema for schema information. You can also connect through ODBC if a DSN-less connection is required.
  • Post to MSMQ queue - you will be able to enter the queue name and the account user name and password. If you’re posting to a private queue, make sure you prefix the queue name with the private$ keyword.


Create Report

This wizard allows you to run one or any group of modules and save the output to almost any device. You can also set the options to each module to select just the data needed.

You can also use the settings in a profile to configure the settings of the wizard and thus create a report in a specific format all the time.

You can also create a script of the settings to be used in batch-mode to create unattended reports.

Batch/Command-line Mode: create a script and use the /r command line option. Do note that this functionality is only available in the commercial versions only.

Shortcut

Keys: CTRL+R


Analysis and Advice

This wizard runs all enabled information, testing and diagnostic modules and compiles a list of the performance enhancing tips as well as other errors or warnings generated.

It is a convenient way of obtaining a complete view of your system in one go without going through every module. Do note that this operation may take some time, although less than creating a complete report.

You can choose to save or print the report rather than having it displayed on the screen.

Batch/Command-line Mode: create a script and use the /r command line option. Do note that this functionality is only available in the commercial versions only.

Tips

See the modules below for information about the tips displayed:

Tips (Performance) List

Shortcut

Keys: CTRL+P


Update Wizard

This wizard helps keep Sandra up-to-date. The wizard uses your computer's Internet connection to automatically download updates directly from the SiSoftware website. These updates are free.

You may be able to upgrade to a newer major version or a commercial version at cost.

You should run this wizard monthly to see if there are any new updates. New updates add more modules, new features and/or fix bugs or other incompatibilities.


Update Wizard - Select Update Site

Here you can select the site that should be used to check for any updates to your software. While the default site should work in all instances in times of high usage it may be required to use a site in another geographic region that is less busy.


Upload Results

Using this wizard you can join the SiSoftware Customer Experience Improvement Programme and help improve the quality, realiability and performance of Sandra. This wizard uses your computer's Internet connection to upload your computer results to the SiSoftware website anonymously.

These reports will be analysed, based on which we will add features, hardware and software support, fixes and other improvements.